Bug 349559 - K System Settings crash
Summary: K System Settings crash
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-06-24 09:21 UTC by garethic
Modified: 2015-07-10 14:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description garethic 2015-06-24 09:21:59 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-21-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
Attempting to change the Application Appearance. I changed windows without 'Apply'ing, then Applied at the prompt, then it crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8b39184780 (LWP 22508))]

Thread 3 (Thread 0x7f8b18a36700 (LWP 22522)):
#0  0x00007f8b358e98dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f8b325feebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f8b325fefcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8b36201c6c in QEventDispatcherGlib::processEvents (this=0x7f8b140008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f8b361a63e2 in QEventLoop::exec (this=this@entry=0x7f8b18a35e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f8b35f65b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f8b34f30f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f8b35f6ab0e in QThreadPrivate::start (arg=0x137c940) at thread/qthread_unix.cpp:337
#8  0x00007f8b32b1d6aa in start_thread (arg=0x7f8b18a36700) at pthread_create.c:333
#9  0x00007f8b358f4eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f8b11340700 (LWP 22523)):
#0  0x00007f8b358e549d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f8b326422f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f8b325fe96c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8b325fee60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f8b325fefcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f8b36201c6c in QEventDispatcherGlib::processEvents (this=0x7f8b0c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#6  0x00007f8b361a63e2 in QEventLoop::exec (this=this@entry=0x7f8b1133fe20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#7  0x00007f8b35f65b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#8  0x00007f8b34f30f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007f8b35f6ab0e in QThreadPrivate::start (arg=0x161ff40) at thread/qthread_unix.cpp:337
#10 0x00007f8b32b1d6aa in start_thread (arg=0x7f8b11340700) at pthread_create.c:333
#11 0x00007f8b358f4eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f8b39184780 (LWP 22508)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f8b349b5628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f8b349b4d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f8b133aac9a in Plasma::FrameSvgItem::updatePaintNode (this=0x3f551c0, oldNode=0x406efa0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f8b34a084bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f8b34a094cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f8b34a09d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f8b349d8f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f8b349d9979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f8b36f94b2c in QApplicationPrivate::notify_helper (this=0xe59b10, receiver=0x137a5c0, e=0x7fffd7c5d290) at kernel/qapplication.cpp:3720
#16 0x00007f8b36f9a000 in QApplication::notify (this=0x7fffd7c5d600, receiver=0x137a5c0, e=0x7fffd7c5d290) at kernel/qapplication.cpp:3503
#17 0x00007f8b361a8c2b in QCoreApplication::notifyInternal (this=0x7fffd7c5d600, receiver=0x137a5c0, event=event@entry=0x7fffd7c5d290) at kernel/qcoreapplication.cpp:935
#18 0x00007f8b36200ae5 in sendEvent (event=0x7fffd7c5d290, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0xe97e40) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f8b36200f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f8b325fec3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f8b325fef20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f8b325fefcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f8b36201c57 in QEventDispatcherGlib::processEvents (this=0xe9bab0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f8b361a63e2 in QEventLoop::exec (this=this@entry=0x7fffd7c5d4e0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f8b361ae02c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f8b369cf31c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f8b36f907a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-07-10 14:15:01 UTC

*** This bug has been marked as a duplicate of bug 345675 ***