Bug 355826 - Fall on changing window decoration
Summary: Fall on changing window decoration
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-11-24 09:06 UTC by House15
Modified: 2015-12-03 13:09 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description House15 2015-11-24 09:06:01 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-33-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed: try to change window decoration from system settings. When went menu "Window decoration" in "Application decoration" error was show it self.

The crash can be reproduced every time.

-- Backtrace:
Application: Параметры системы (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7fcabe0a2780 (LWP 1879))]

Thread 5 (Thread 0x7fcaab9eb700 (LWP 1880)):
#0  0x00007fcaba80d8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fcab8b27b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fcab8b2964f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fcaae7a6099 in QXcbEventReader::run (this=0x263dea0) at qxcbconnection.cpp:1105
#4  0x00007fcabae8eb0e in QThreadPrivate::start (arg=0x263dea0) at thread/qthread_unix.cpp:337
#5  0x00007fcab7a416aa in start_thread (arg=0x7fcaab9eb700) at pthread_create.c:333
#6  0x00007fcaba818eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7fca9c302700 (LWP 1886)):
#0  0x00007fcaba80d8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fcab7522ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcab7522fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcabb125c6c in QEventDispatcherGlib::processEvents (this=0x7fca940008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fcabb0ca3e2 in QEventLoop::exec (this=this@entry=0x7fca9c301e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fcabae89b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fcab9e54f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fcabae8eb0e in QThreadPrivate::start (arg=0x2ee2400) at thread/qthread_unix.cpp:337
#8  0x00007fcab7a416aa in start_thread (arg=0x7fca9c302700) at pthread_create.c:333
#9  0x00007fcaba818eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fca98999700 (LWP 1887)):
#0  0x00007fcaba80d8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fcab7522ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcab7522fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcabb125c6c in QEventDispatcherGlib::processEvents (this=0x7fca8c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fcabb0ca3e2 in QEventLoop::exec (this=this@entry=0x7fca98998e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fcabae89b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fcab9e54f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fcabae8eb0e in QThreadPrivate::start (arg=0x3066900) at thread/qthread_unix.cpp:337
#8  0x00007fcab7a416aa in start_thread (arg=0x7fca98999700) at pthread_create.c:333
#9  0x00007fcaba818eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fca925d7700 (LWP 1889)):
[KCrash Handler]
#6  0x0000000000000090 in ?? ()
#7  0x00007fcab98d9628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fcab98d8d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007fca9acacc9a in Plasma::FrameSvgItem::updatePaintNode (this=0x41342c0, oldNode=0x7fca896d55b0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007fcab992c4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fcab992d4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fcab992dd80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fcab98ff1dd in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fcab99000a1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007fcab9901360 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#16 0x00007fcabae8eb0e in QThreadPrivate::start (arg=0x32226f0) at thread/qthread_unix.cpp:337
#17 0x00007fcab7a416aa in start_thread (arg=0x7fca925d7700) at pthread_create.c:333
#18 0x00007fcaba818eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fcabe0a2780 (LWP 1879)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fcabae8fc6b in wait (time=18446744073709551615, this=0x355a5d0) at thread/qwaitcondition_unix.cpp:128
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x3222730, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:200
#3  0x00007fcab9902c48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#4  0x00007fcab9903cad in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007fcabbeb8b2c in QApplicationPrivate::notify_helper (this=0x26109a0, receiver=0x2c637f0, e=0x7ffea3ac2330) at kernel/qapplication.cpp:3720
#6  0x00007fcabbebe000 in QApplication::notify (this=0x7ffea3ac26a0, receiver=0x2c637f0, e=0x7ffea3ac2330) at kernel/qapplication.cpp:3503
#7  0x00007fcabb0ccc2b in QCoreApplication::notifyInternal (this=0x7ffea3ac26a0, receiver=0x2c637f0, event=event@entry=0x7ffea3ac2330) at kernel/qcoreapplication.cpp:935
#8  0x00007fcabb124ae5 in sendEvent (event=0x7ffea3ac2330, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#9  QTimerInfoList::activateTimers (this=0x2683c40) at kernel/qtimerinfo_unix.cpp:635
#10 0x00007fcabb124f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#11 0x00007fcab7522c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007fcab7522f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007fcab7522fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#14 0x00007fcabb125c57 in QEventDispatcherGlib::processEvents (this=0x26922a0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#15 0x00007fcabb0ca3e2 in QEventLoop::exec (this=this@entry=0x7ffea3ac2580, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#16 0x00007fcabb0d202c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#17 0x00007fcabb8f331c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#18 0x00007fcabbeb47a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#19 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-12-03 13:09:26 UTC

*** This bug has been marked as a duplicate of bug 345675 ***