Bug 345894 - KDE settings crashes when selecting Window Decorations
Summary: KDE settings crashes when selecting Window Decorations
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kwin
Classification: Unclassified
Component: decorations (show other bugs)
Version: 5.2.2
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-04-05 18:12 UTC by Gabor Wacha
Modified: 2015-12-19 02:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Wacha 2015-04-05 18:12:47 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-12-generic x86_64
Distribution: Ubuntu Vivid Vervet (development branch)

-- Information about the crash:
- What I was doing when the application crashed:
In the KDE settings I choose "Alkalmazások megjelenése" in HU translation (Appearance of applications in direct translation), and then I select "Ablakdekorációk" (Window decorations in direct translation)
systemsettings5 crashes with SIGSEGV

The crash can be reproduced every time.

-- Backtrace:
Application: Rendszerbeállítások (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4e9f988780 (LWP 1901))]

Thread 5 (Thread 0x7f4e90685700 (LWP 1902)):
#0  0x00007f4e9c0ff8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f4e9ae44b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f4e9ae4664f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f4e92bd0099 in QXcbEventReader::run (this=0xc90050) at qxcbconnection.cpp:1105
#4  0x00007f4e9c780b0e in QThreadPrivate::start (arg=0xc90050) at thread/qthread_unix.cpp:337
#5  0x00007f4e99d5e6aa in start_thread (arg=0x7f4e90685700) at pthread_create.c:333
#6  0x00007f4e9c10aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f4e6bcf5700 (LWP 1910)):
#0  0x00007f4e9983cf2f in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f4e9983f39b in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f4e9983fde8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4e9983ffcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f4e9ca17c6c in QEventDispatcherGlib::processEvents (this=0x7f4e5c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007f4e9c9bc3e2 in QEventLoop::exec (this=this@entry=0x7f4e6bcf4e40, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f4e9c77bb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007f4e9c780b0e in QThreadPrivate::start (arg=0x30d9e80) at thread/qthread_unix.cpp:337
#8  0x00007f4e99d5e6aa in start_thread (arg=0x7f4e6bcf5700) at pthread_create.c:333
#9  0x00007f4e9c10aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f4e68989700 (LWP 2018)):
#0  0x00007f4e9c0ff8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f4e9983febc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f4e9983ffcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4e9ca17c6c in QEventDispatcherGlib::processEvents (this=0x7f4e6018cfe0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f4e9c9bc3e2 in QEventLoop::exec (this=this@entry=0x7f4e68988e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f4e9c77bb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f4e80253f45 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f4e9c780b0e in QThreadPrivate::start (arg=0x2e71a70) at thread/qthread_unix.cpp:337
#8  0x00007f4e99d5e6aa in start_thread (arg=0x7f4e68989700) at pthread_create.c:333
#9  0x00007f4e9c10aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f4e7f4a4700 (LWP 2019)):
#0  0x00007f4e9c0ff8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f4e9983febc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f4e9983ffcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4e9ca17c6c in QEventDispatcherGlib::processEvents (this=0x7f4e780b16a0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f4e9c9bc3e2 in QEventLoop::exec (this=this@entry=0x7f4e7f4a3e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f4e9c77bb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f4e80253f45 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f4e9c780b0e in QThreadPrivate::start (arg=0x2b66c90) at thread/qthread_unix.cpp:337
#8  0x00007f4e99d5e6aa in start_thread (arg=0x7f4e7f4a4700) at pthread_create.c:333
#9  0x00007f4e9c10aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f4e9f988780 (LWP 1901)):
[KCrash Handler]
#6  0x0000000000000070 in ?? ()
#7  0x00007f4e804f8628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f4e804f7d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f4e7d94f142 in Plasma::FrameSvgItem::updatePaintNode (this=0x2e9e770, oldNode=0x497cd90) at ../../../../src/declarativeimports/core/framesvgitem.cpp:473
#10 0x00007f4e8054b4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f4e8054c4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f4e8054cd80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f4e8051bf05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f4e8051c979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f4e9d7a9b2c in QApplicationPrivate::notify_helper (this=0xc79680, receiver=0x10ae7d0, e=0x7ffdcc8d0dd0) at kernel/qapplication.cpp:3720
#16 0x00007f4e9d7af000 in QApplication::notify (this=0x7ffdcc8d1140, receiver=0x10ae7d0, e=0x7ffdcc8d0dd0) at kernel/qapplication.cpp:3503
#17 0x00007f4e9c9bec2b in QCoreApplication::notifyInternal (this=0x7ffdcc8d1140, receiver=0x10ae7d0, event=event@entry=0x7ffdcc8d0dd0) at kernel/qcoreapplication.cpp:935
#18 0x00007f4e9ca16ae5 in sendEvent (event=0x7ffdcc8d0dd0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0xcb7b70) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f4e9ca16f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f4e9983fc3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f4e9983ff20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f4e9983ffcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f4e9ca17c57 in QEventDispatcherGlib::processEvents (this=0xcb7670, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f4e9c9bc3e2 in QEventLoop::exec (this=this@entry=0x7ffdcc8d1020, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f4e9c9c402c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f4e9d1e431c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f4e9d7a57a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Thomas Lübking 2015-04-16 20:15:36 UTC

*** This bug has been marked as a duplicate of bug 345675 ***