Bug 346670 - System settings crash when trying to select Window Decorations in Application Style
Summary: System settings crash when trying to select Window Decorations in Application...
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-04-25 20:42 UTC by lesezirkel
Modified: 2015-04-28 10:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lesezirkel 2015-04-25 20:42:08 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-15-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
I had installed several window decoration themes, including one named "OS X". I activated the OS X theme, which worked sucessfully. Now when I go back to switch themes, System Settings crashes every time I click "Window Decorations", just after generating the previews.

- Custom settings of the application:
"OS X" Window Decoration theme

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe3afe50780 (LWP 12623))]

Thread 4 (Thread 0x7fe39f5ca700 (LWP 12624)):
#0  0x00007fe3ac5b58dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fe3aa8cfb72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fe3aa8d164f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fe3a1b15099 in QXcbEventReader::run (this=0x10493a0) at qxcbconnection.cpp:1105
#4  0x00007fe3acc36b0e in QThreadPrivate::start (arg=0x10493a0) at thread/qthread_unix.cpp:337
#5  0x00007fe3a97e96aa in start_thread (arg=0x7fe39f5ca700) at pthread_create.c:333
#6  0x00007fe3ac5c0eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fe38e253700 (LWP 12642)):
#0  0x00007ffd6f315c2e in clock_gettime ()
#1  0x00007fe3ac5cf38d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007fe3acceccb6 in qt_clock_gettime (ts=0x7fe38e252b80, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:161
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:170
#5  0x00007fe3acecb639 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7fe380002cd0) at kernel/qtimerinfo_unix.cpp:84
#6  0x00007fe3acecbba5 in QTimerInfoList::timerWait (this=0x7fe380002cd0, tm=...) at kernel/qtimerinfo_unix.cpp:379
#7  0x00007fe3acecd03e in timerSourcePrepareHelper (timeout=0x7fe38e252c54, src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:127
#8  timerSourcePrepare (source=<optimized out>, timeout=0x7fe38e252c54) at kernel/qeventdispatcher_glib.cpp:160
#9  0x00007fe3a92ca3fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007fe3a92cade8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007fe3a92cafcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007fe3acecdc6c in QEventDispatcherGlib::processEvents (this=0x7fe3800008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#13 0x00007fe3ace723e2 in QEventLoop::exec (this=this@entry=0x7fe38e252e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#14 0x00007fe3acc31b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#15 0x00007fe3abbfcf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#16 0x00007fe3acc36b0e in QThreadPrivate::start (arg=0x11bf390) at thread/qthread_unix.cpp:337
#17 0x00007fe3a97e96aa in start_thread (arg=0x7fe38e253700) at pthread_create.c:333
#18 0x00007fe3ac5c0eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fe386c6c700 (LWP 12644)):
#0  0x00007fe3ac5b58dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fe3a92caebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe3a92cafcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe3acecdc6c in QEventDispatcherGlib::processEvents (this=0x7fe37c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fe3ace723e2 in QEventLoop::exec (this=this@entry=0x7fe386c6be20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fe3acc31b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fe3abbfcf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fe3acc36b0e in QThreadPrivate::start (arg=0x18a3bd0) at thread/qthread_unix.cpp:337
#8  0x00007fe3a97e96aa in start_thread (arg=0x7fe386c6c700) at pthread_create.c:333
#9  0x00007fe3ac5c0eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fe3afe50780 (LWP 12623)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007fe3ab681628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fe3ab680d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007fe38c711c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x4f6d400, oldNode=0x50855a0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007fe3ab6d44bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fe3ab6d54cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fe3ab6d5d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fe3ab6a4f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fe3ab6a5979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007fe3adc60b2c in QApplicationPrivate::notify_helper (this=0x1032b10, receiver=0x1501fc0, e=0x7ffd6f264ee0) at kernel/qapplication.cpp:3720
#16 0x00007fe3adc66000 in QApplication::notify (this=0x7ffd6f265250, receiver=0x1501fc0, e=0x7ffd6f264ee0) at kernel/qapplication.cpp:3503
#17 0x00007fe3ace74c2b in QCoreApplication::notifyInternal (this=0x7ffd6f265250, receiver=0x1501fc0, event=event@entry=0x7ffd6f264ee0) at kernel/qcoreapplication.cpp:935
#18 0x00007fe3aceccae5 in sendEvent (event=0x7ffd6f264ee0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x107bce0) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007fe3aceccf61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007fe3a92cac3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fe3a92caf20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fe3a92cafcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fe3acecdc57 in QEventDispatcherGlib::processEvents (this=0x1079610, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007fe3ace723e2 in QEventLoop::exec (this=this@entry=0x7ffd6f265130, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007fe3ace7a02c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007fe3ad69b31c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007fe3adc5c7a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-04-28 10:39:51 UTC

*** This bug has been marked as a duplicate of bug 345675 ***