Bug 346659 - Window Decoration Settings crash
Summary: Window Decoration Settings crash
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-04-25 18:06 UTC by Theaitetos
Modified: 2015-04-28 10:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Theaitetos 2015-04-25 18:06:53 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-15-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
Downloaded a few new window decorations. Everything fine.
Began scrolling through the newly installed window decorations, and it crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f77f29e1780 (LWP 4718))]

Thread 4 (Thread 0x7f77e1ec7700 (LWP 4719)):
#0  0x00007f77ef15f8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f77ed479b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f77ed47b64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f77e4412099 in QXcbEventReader::run (this=0x22785e0) at qxcbconnection.cpp:1105
#4  0x00007f77ef7e0b0e in QThreadPrivate::start (arg=0x22785e0) at thread/qthread_unix.cpp:337
#5  0x00007f77ec3936aa in start_thread (arg=0x7f77e1ec7700) at pthread_create.c:333
#6  0x00007f77ef16aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f77d15ac700 (LWP 4725)):
#0  0x00007f77ef15f8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f77ebe74ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f77ebe74fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f77efa77c6c in QEventDispatcherGlib::processEvents (this=0x7f77cc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f77efa1c3e2 in QEventLoop::exec (this=this@entry=0x7f77d15abe20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f77ef7dbb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f77ee7a6f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f77ef7e0b0e in QThreadPrivate::start (arg=0x2c88af0) at thread/qthread_unix.cpp:337
#8  0x00007f77ec3936aa in start_thread (arg=0x7f77d15ac700) at pthread_create.c:333
#9  0x00007f77ef16aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f77c9fb3700 (LWP 4726)):
#0  0x00007f77ef15f8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f77ebe74ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f77ebe74fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f77efa77c6c in QEventDispatcherGlib::processEvents (this=0x7f77c40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f77efa1c3e2 in QEventLoop::exec (this=this@entry=0x7f77c9fb2e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f77ef7dbb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f77ee7a6f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f77ef7e0b0e in QThreadPrivate::start (arg=0x4470510) at thread/qthread_unix.cpp:337
#8  0x00007f77ec3936aa in start_thread (arg=0x7f77c9fb3700) at pthread_create.c:333
#9  0x00007f77ef16aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f77f29e1780 (LWP 4718)):
[KCrash Handler]
#6  0x0000000000000018 in ?? ()
#7  0x00007f77ee22b628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f77ee22ad3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f77cbdd9c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x6aa09c0, oldNode=0x6ba89f0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f77ee27e4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f77ee27f4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f77ee27fd80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f77ee24ef05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f77ee24f979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f77f080ab2c in QApplicationPrivate::notify_helper (this=0x2260b10, receiver=0x28ea820, e=0x7ffc4673ae60) at kernel/qapplication.cpp:3720
#16 0x00007f77f0810000 in QApplication::notify (this=0x7ffc4673b1d0, receiver=0x28ea820, e=0x7ffc4673ae60) at kernel/qapplication.cpp:3503
#17 0x00007f77efa1ec2b in QCoreApplication::notifyInternal (this=0x7ffc4673b1d0, receiver=0x28ea820, event=event@entry=0x7ffc4673ae60) at kernel/qcoreapplication.cpp:935
#18 0x00007f77efa76ae5 in sendEvent (event=0x7ffc4673ae60, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x229c4a0) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f77efa76f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f77ebe74c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f77ebe74f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f77ebe74fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f77efa77c57 in QEventDispatcherGlib::processEvents (this=0x229a460, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f77efa1c3e2 in QEventLoop::exec (this=this@entry=0x7ffc4673b0b0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f77efa2402c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f77f024531c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f77f08067a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-04-28 10:39:31 UTC

*** This bug has been marked as a duplicate of bug 345675 ***