Bug 347677 - Error changing KDE Window Decoration
Summary: Error changing KDE Window Decoration
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-13 17:58 UTC by hixian
Modified: 2015-05-16 17:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hixian 2015-05-13 17:58:48 UTC
Application: systemsettings5 (5.3.0)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-16-lowlatency x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
Trying to remove problematic Window Decoration Ghost-Deco.

- Unusual behavior I noticed:
The app crash only trying to change Ghost-Deco window decoration.

- Custom settings of the application:
Ghost-Deco window decoration

The crash can be reproduced every time.

-- Backtrace:
Application: Configurações do Sistema (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fdad2ff9780 (LWP 11201))]

Thread 6 (Thread 0x7fdac414b700 (LWP 11202)):
#0  0x00007fdacf7758dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x0000003efb209b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x0000003efb20b64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fdac6086099 in QXcbEventReader::run (this=0xcec620) at qxcbconnection.cpp:1105
#4  0x00007fdacfdf6b0e in QThreadPrivate::start (arg=0xcec620) at thread/qthread_unix.cpp:337
#5  0x00007fdaccbc86aa in start_thread (arg=0x7fdac414b700) at pthread_create.c:333
#6  0x00007fdacf780eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7fdaa0b4c700 (LWP 12232)):
#0  0x00007fdacf7758dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fdacc6a9ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fdacc6aa242 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fda80fcaae6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007fdacc6d0955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fdaccbc86aa in start_thread (arg=0x7fdaa0b4c700) at pthread_create.c:333
#6  0x00007fdacf780eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7fda75ffa700 (LWP 13119)):
#0  0x00007fdacc6ee7a4 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fdacc6a9eb1 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fdacc6a9fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fdad008dc6c in QEventDispatcherGlib::processEvents (this=0x7fda9c101b80, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fdad00323e2 in QEventLoop::exec (this=this@entry=0x7fda75ff9e00, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fdacfdf1b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fda78307cf7 in KCupsConnection::run() () from /usr/lib/x86_64-linux-gnu/libkcupslib.so
#7  0x00007fdacfdf6b0e in QThreadPrivate::start (arg=0x6efd630) at thread/qthread_unix.cpp:337
#8  0x00007fdaccbc86aa in start_thread (arg=0x7fda75ffa700) at pthread_create.c:333
#9  0x00007fdacf780eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fda77910700 (LWP 13399)):
#0  0x00007fff553e4c58 in clock_gettime ()
#1  0x00007fdacf78f38d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007fdacfeaccb6 in qt_clock_gettime (ts=0x7fda7790fb80, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:161
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:170
#5  0x00007fdad008b639 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7fdaac17fa60) at kernel/qtimerinfo_unix.cpp:84
#6  0x00007fdad008bba5 in QTimerInfoList::timerWait (this=0x7fdaac17fa60, tm=...) at kernel/qtimerinfo_unix.cpp:379
#7  0x00007fdad008d03e in timerSourcePrepareHelper (timeout=0x7fda7790fc54, src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:127
#8  timerSourcePrepare (source=<optimized out>, timeout=0x7fda7790fc54) at kernel/qeventdispatcher_glib.cpp:160
#9  0x00007fdacc6a93fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007fdacc6a9de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007fdacc6a9fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007fdad008dc6c in QEventDispatcherGlib::processEvents (this=0x7fdaac0e48c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#13 0x00007fdad00323e2 in QEventLoop::exec (this=this@entry=0x7fda7790fe20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#14 0x00007fdacfdf1b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#15 0x00007fdacedbcf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#16 0x00007fdacfdf6b0e in QThreadPrivate::start (arg=0x76db130) at thread/qthread_unix.cpp:337
#17 0x00007fdaccbc86aa in start_thread (arg=0x7fda77910700) at pthread_create.c:333
#18 0x00007fdacf780eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fdaa21ad700 (LWP 13400)):
#0  0x00007fdacf77149d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fdacc6ed2f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fdacc6a996c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fdacc6a9e60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fdacc6a9fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fdad008dc6c in QEventDispatcherGlib::processEvents (this=0x7fda8c0367e0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#6  0x00007fdad00323e2 in QEventLoop::exec (this=this@entry=0x7fdaa21ace20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#7  0x00007fdacfdf1b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#8  0x00007fdacedbcf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007fdacfdf6b0e in QThreadPrivate::start (arg=0xa11a720) at thread/qthread_unix.cpp:337
#10 0x00007fdaccbc86aa in start_thread (arg=0x7fdaa21ad700) at pthread_create.c:333
#11 0x00007fdacf780eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fdad2ff9780 (LWP 11201)):
[KCrash Handler]
#6  0x0000000000000070 in ?? ()
#7  0x00007fdace841628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fdace840d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007fda7a874c9a in Plasma::FrameSvgItem::updatePaintNode (this=0xb399810, oldNode=0xb614180) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007fdace8944bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fdace8954cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fdace895d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fdace864f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fdace865979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007fdad0e20b2c in QApplicationPrivate::notify_helper (this=0xcd5b10, receiver=0x60a7dc0, e=0x7fff553477c0) at kernel/qapplication.cpp:3720
#16 0x00007fdad0e26000 in QApplication::notify (this=0x7fff55347b30, receiver=0x60a7dc0, e=0x7fff553477c0) at kernel/qapplication.cpp:3503
#17 0x00007fdad0034c2b in QCoreApplication::notifyInternal (this=0x7fff55347b30, receiver=0x60a7dc0, event=event@entry=0x7fff553477c0) at kernel/qcoreapplication.cpp:935
#18 0x00007fdad008cae5 in sendEvent (event=0x7fff553477c0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0xd1cfd0) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007fdad008cf61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007fdacc6a9c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fdacc6a9f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fdacc6a9fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fdad008dc57 in QEventDispatcherGlib::processEvents (this=0xd101a0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007fdad00323e2 in QEventLoop::exec (this=this@entry=0x7fff55347a10, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007fdad003a02c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007fdad085b31c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007fdad0e1c7a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040ef5b in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:55

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-16 17:01:23 UTC

*** This bug has been marked as a duplicate of bug 345675 ***