Bug 347124 - System Settings in Plasma 5 Crash
Summary: System Settings in Plasma 5 Crash
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-03 20:20 UTC by peter flexer
Modified: 2015-05-09 19:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peter flexer 2015-05-03 20:20:36 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-15-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed: I was just changing the windows title style, when the windows suddenly dissapeared.

The crash can be reproduced sometimes.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f181ad97780 (LWP 2717))]

Thread 6 (Thread 0x7f17ff5fe700 (LWP 2720)):
#0  0x00007f1814222ddb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f1814223242 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1803d5fae6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#3  0x00007f1814249955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f18147416aa in start_thread (arg=0x7f17ff5fe700) at pthread_create.c:333
#5  0x00007f1817518eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f17fedfd700 (LWP 2721)):
#0  0x00007f18142228b9 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f1814222e60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1814222fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1814223009 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f1814249955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f18147416aa in start_thread (arg=0x7f17fedfd700) at pthread_create.c:333
#6  0x00007f1817518eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f17ed464700 (LWP 2724)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f17efa144fb in ?? () from /usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so
#2  0x00007f17efa13c87 in ?? () from /usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so
#3  0x00007f18147416aa in start_thread (arg=0x7f17ed464700) at pthread_create.c:333
#4  0x00007f1817518eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f17fe5fc700 (LWP 2853)):
#0  socketNotifierSourceCheck (source=0x7f17f4065af0) at kernel/qeventdispatcher_glib.cpp:70
#1  0x00007f18142228c1 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1814222e60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1814222fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f1817e25c6c in QEventDispatcherGlib::processEvents (this=0x7f17f4012f50, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007f1817dca3e2 in QEventLoop::exec (this=this@entry=0x7f17fe5fbe20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f1817b89b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007f1816b54f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f1817b8eb0e in QThreadPrivate::start (arg=0x2c791f0) at thread/qthread_unix.cpp:337
#9  0x00007f18147416aa in start_thread (arg=0x7f17fe5fc700) at pthread_create.c:333
#10 0x00007f1817518eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f17dffff700 (LWP 2854)):
#0  0x00007f1814267798 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f1814222641 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1814222e37 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1814222fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f1817e25c6c in QEventDispatcherGlib::processEvents (this=0x7f17d815c7e0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007f1817dca3e2 in QEventLoop::exec (this=this@entry=0x7f17dfffee20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f1817b89b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007f1816b54f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f1817b8eb0e in QThreadPrivate::start (arg=0x2d6c720) at thread/qthread_unix.cpp:337
#9  0x00007f18147416aa in start_thread (arg=0x7f17dffff700) at pthread_create.c:333
#10 0x00007f1817518eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f181ad97780 (LWP 2717)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f1816288e26 in ManagedTextureNode::~ManagedTextureNode() () from /usr/lib/x86_64-linux-gnu/libKF5QuickAddons.so.5
#8  0x00007f18165cfc13 in QSGNode::destroy() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f18165cfc47 in QSGNode::~QSGNode() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#10 0x00007f18165cfc79 in QSGNode::~QSGNode() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f18165cfc13 in QSGNode::destroy() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f18165cfc47 in QSGNode::~QSGNode() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f18165cfdf9 in QSGOpacityNode::~QSGOpacityNode() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f18165cfc13 in QSGNode::destroy() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f18165cfc47 in QSGNode::~QSGNode() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#16 0x00007f18165cfdb9 in QSGTransformNode::~QSGTransformNode() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#17 0x00007f181662d3c4 in QQuickWindowPrivate::cleanupNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#18 0x00007f181662d45e in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#19 0x00007f181662dd80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#20 0x00007f18165fcf05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#21 0x00007f18165fd979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#22 0x00007f1818bb8b2c in QApplicationPrivate::notify_helper (this=0x1041b10, receiver=0x16b92d0, e=0x7fff117bd260) at kernel/qapplication.cpp:3720
#23 0x00007f1818bbe000 in QApplication::notify (this=0x7fff117bd5d0, receiver=0x16b92d0, e=0x7fff117bd260) at kernel/qapplication.cpp:3503
#24 0x00007f1817dccc2b in QCoreApplication::notifyInternal (this=0x7fff117bd5d0, receiver=0x16b92d0, event=event@entry=0x7fff117bd260) at kernel/qcoreapplication.cpp:935
#25 0x00007f1817e24ae5 in sendEvent (event=0x7fff117bd260, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#26 QTimerInfoList::activateTimers (this=0x103dd20) at kernel/qtimerinfo_unix.cpp:635
#27 0x00007f1817e24f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#28 0x00007f1814222c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f1814222f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f1814222fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f1817e25c57 in QEventDispatcherGlib::processEvents (this=0x10f8330, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#32 0x00007f1817dca3e2 in QEventLoop::exec (this=this@entry=0x7fff117bd4b0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#33 0x00007f1817dd202c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#34 0x00007f18185f331c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#35 0x00007f1818bb47a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#36 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 peter flexer 2015-05-03 20:40:34 UTC
Correction: it was "Windows Decoration" I was trying to change. i can reproduce this, Settings crash:

Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f7cefbeb780 (LWP 3563))]

Thread 6 (Thread 0x7f7cd4421700 (LWP 3566)):
#0  0x00007f7ce90bb7a4 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f7ce9076490 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7ce9076de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7ce9077242 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f7cdcc80ae6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#5  0x00007f7ce909d955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f7ce95956aa in start_thread (arg=0x7f7cd4421700) at pthread_create.c:333
#7  0x00007f7cec36ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f7cd3c20700 (LWP 3567)):
#0  0x00007f7cec3618d2 in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f7ce9076ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7ce9076fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7ce9077009 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f7ce909d955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f7ce95956aa in start_thread (arg=0x7f7cd3c20700) at pthread_create.c:333
#6  0x00007f7cec36ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f7cc201d700 (LWP 3570)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f7cd136c4fb in ?? () from /usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so
#2  0x00007f7cd136bc87 in ?? () from /usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so
#3  0x00007f7ce95956aa in start_thread (arg=0x7f7cc201d700) at pthread_create.c:333
#4  0x00007f7cec36ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f7cd2c1e700 (LWP 3574)):
#0  0x00007f7ce90bb7a4 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f7ce90766f9 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7ce9076e37 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7ce9076fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f7cecc79c6c in QEventDispatcherGlib::processEvents (this=0x7f7cbc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007f7cecc1e3e2 in QEventLoop::exec (this=this@entry=0x7f7cd2c1de20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f7cec9ddb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007f7ceb9a8f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f7cec9e2b0e in QThreadPrivate::start (arg=0x1e26a20) at thread/qthread_unix.cpp:337
#9  0x00007f7ce95956aa in start_thread (arg=0x7f7cd2c1e700) at pthread_create.c:333
#10 0x00007f7cec36ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f7cd341f700 (LWP 3575)):
#0  0x00007f7ce9076409 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f7ce9076de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7ce9076fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7cecc79c6c in QEventDispatcherGlib::processEvents (this=0x7f7cc8133f50, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f7cecc1e3e2 in QEventLoop::exec (this=this@entry=0x7f7cd341ee20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f7cec9ddb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f7ceb9a8f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f7cec9e2b0e in QThreadPrivate::start (arg=0x1525a70) at thread/qthread_unix.cpp:337
#8  0x00007f7ce95956aa in start_thread (arg=0x7f7cd341f700) at pthread_create.c:333
#9  0x00007f7cec36ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f7cefbeb780 (LWP 3563)):
[KCrash Handler]
#6  0x0000000000000065 in ?? ()
#7  0x00007f7ceb42d628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f7ceb42cd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f7cb3bdac9a in Plasma::FrameSvgItem::updatePaintNode (this=0x36164a0, oldNode=0x3738ac0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f7ceb4804bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f7ceb4814cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f7ceb481d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f7ceb450f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f7ceb451979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f7ceda0cb2c in QApplicationPrivate::notify_helper (this=0xd82b10, receiver=0x138d970, e=0x7ffd2f6e4640) at kernel/qapplication.cpp:3720
#16 0x00007f7ceda12000 in QApplication::notify (this=0x7ffd2f6e49b0, receiver=0x138d970, e=0x7ffd2f6e4640) at kernel/qapplication.cpp:3503
#17 0x00007f7cecc20c2b in QCoreApplication::notifyInternal (this=0x7ffd2f6e49b0, receiver=0x138d970, event=event@entry=0x7ffd2f6e4640) at kernel/qcoreapplication.cpp:935
#18 0x00007f7cecc78ae5 in sendEvent (event=0x7ffd2f6e4640, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0xd7ee00) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f7cecc78f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f7ce9076c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f7ce9076f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f7ce9076fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f7cecc79c57 in QEventDispatcherGlib::processEvents (this=0xe26f60, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f7cecc1e3e2 in QEventLoop::exec (this=this@entry=0x7ffd2f6e4890, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f7cecc2602c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f7ced44731c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f7ceda087a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54
Comment 2 Christoph Feck 2015-05-09 19:12:08 UTC

*** This bug has been marked as a duplicate of bug 345675 ***