Bug 350988 - KDE Control Module and System Settings crashing when visiting Window Decorations page after installing a new window decoration
Summary: KDE Control Module and System Settings crashing when visiting Window Decorati...
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-08-05 06:39 UTC by patrick
Modified: 2015-08-13 00:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description patrick 2015-08-05 06:39:29 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-25-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
I installed a decoration, can't remember which one, and when I went back to the select screen, it crashed. Now it crashes every time and I can't change my window decorations.
If I try to access from settings, it says System Settings crashed. If I right click a window bar, go to More Actions, and select Window Manager Settings, it will say KDE Control Manager crashed.
I'm running this on Virtual Box 5, Windows 10 host.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f421b192780 (LWP 2902))]

Thread 4 (Thread 0x7f420a90b700 (LWP 2903)):
#0  0x00007f42178f68dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f4215c10b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f4215c1264f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f420ce56099 in QXcbEventReader::run (this=0x103e5a0) at qxcbconnection.cpp:1105
#4  0x00007f4217f77b0e in QThreadPrivate::start (arg=0x103e5a0) at thread/qthread_unix.cpp:337
#5  0x00007f4214b2a6aa in start_thread (arg=0x7f420a90b700) at pthread_create.c:333
#6  0x00007f4217901eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f41f77fa700 (LWP 2906)):
#0  0x00007f4214650789 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f421460adf0 in g_main_context_acquire () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f421460bd75 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f421460bfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f421820ec6c in QEventDispatcherGlib::processEvents (this=0x7f41f00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007f42181b33e2 in QEventLoop::exec (this=this@entry=0x7f41f77f9e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f4217f72b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007f4216f3df65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f4217f77b0e in QThreadPrivate::start (arg=0x136d010) at thread/qthread_unix.cpp:337
#9  0x00007f4214b2a6aa in start_thread (arg=0x7f41f77fa700) at pthread_create.c:333
#10 0x00007f4217901eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f41effff700 (LWP 2907)):
#0  0x00007f4214650789 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f421460bea2 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f421460bfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f421820ec6c in QEventDispatcherGlib::processEvents (this=0x7f41e80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f42181b33e2 in QEventLoop::exec (this=this@entry=0x7f41efffee20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f4217f72b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f4216f3df65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f4217f77b0e in QThreadPrivate::start (arg=0x1750f40) at thread/qthread_unix.cpp:337
#8  0x00007f4214b2a6aa in start_thread (arg=0x7f41effff700) at pthread_create.c:333
#9  0x00007f4217901eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f421b192780 (LWP 2902)):
[KCrash Handler]
#6  0x00007f42169c2625 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#7  0x00007f42169c1d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f41f5cb9c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x3a34400, oldNode=0x3a9d360) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#9  0x00007f4216a154bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#10 0x00007f4216a164cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f4216a16d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f42169e5f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f42169e6979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f4218fa1b2c in QApplicationPrivate::notify_helper (this=0x1025b10, receiver=0x1444420, e=0x7ffcc6727780) at kernel/qapplication.cpp:3720
#15 0x00007f4218fa7000 in QApplication::notify (this=0x7ffcc6727af0, receiver=0x1444420, e=0x7ffcc6727780) at kernel/qapplication.cpp:3503
#16 0x00007f42181b5c2b in QCoreApplication::notifyInternal (this=0x7ffcc6727af0, receiver=0x1444420, event=event@entry=0x7ffcc6727780) at kernel/qcoreapplication.cpp:935
#17 0x00007f421820dae5 in sendEvent (event=0x7ffcc6727780, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#18 QTimerInfoList::activateTimers (this=0x1068ba0) at kernel/qtimerinfo_unix.cpp:635
#19 0x00007f421820df61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#20 0x00007f421460bc3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f421460bf20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f421460bfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f421820ec57 in QEventDispatcherGlib::processEvents (this=0x1074810, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#24 0x00007f42181b33e2 in QEventLoop::exec (this=this@entry=0x7ffcc67279d0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#25 0x00007f42181bb02c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#26 0x000000000040eebc in main ()

Reported using DrKonqi
Comment 1 Christoph Feck 2015-08-13 00:06:25 UTC

*** This bug has been marked as a duplicate of bug 345675 ***