Bug 352676 - 'System Settings"
Summary: 'System Settings"
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-09-14 01:06 UTC by n6ozi
Modified: 2015-09-14 09:45 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description n6ozi 2015-09-14 01:06:52 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-15-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
When opening System Settings/Application Style/Window Decorations, it crashes and closes Settings.

- Custom settings of the application:
I had just installed some additional themes and selected a Steampunk style.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f3944419780 (LWP 11366))]

Thread 4 (Thread 0x7f3933b9b700 (LWP 11367)):
#0  0x00007f3940b868dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f393eea0b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f393eea264f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f39360e6099 in QXcbEventReader::run (this=0x20dac80) at qxcbconnection.cpp:1105
#4  0x00007f3941207b0e in QThreadPrivate::start (arg=0x20dac80) at thread/qthread_unix.cpp:337
#5  0x00007f393ddba6aa in start_thread (arg=0x7f3933b9b700) at pthread_create.c:333
#6  0x00007f3940b91eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f3923631700 (LWP 11368)):
#0  0x00007f3940b868dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f393d89bebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f393d89bfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f394149ec6c in QEventDispatcherGlib::processEvents (this=0x7f391c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f39414433e2 in QEventLoop::exec (this=this@entry=0x7f3923630e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f3941202b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f39401cdf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f3941207b0e in QThreadPrivate::start (arg=0x2c09690) at thread/qthread_unix.cpp:337
#8  0x00007f393ddba6aa in start_thread (arg=0x7f3923631700) at pthread_create.c:333
#9  0x00007f3940b91eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f391bfff700 (LWP 11369)):
#0  0x00007f393d89b806 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f393d89be60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f393d89bfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f394149ec6c in QEventDispatcherGlib::processEvents (this=0x7f39140008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f39414433e2 in QEventLoop::exec (this=this@entry=0x7f391bffee20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f3941202b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f39401cdf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f3941207b0e in QThreadPrivate::start (arg=0x2eeb7f0) at thread/qthread_unix.cpp:337
#8  0x00007f393ddba6aa in start_thread (arg=0x7f391bfff700) at pthread_create.c:333
#9  0x00007f3940b91eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f3944419780 (LWP 11366)):
[KCrash Handler]
#6  0x00007f393fc52625 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#7  0x00007f393fc51d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f392202bc9a in Plasma::FrameSvgItem::updatePaintNode (this=0x53d3770, oldNode=0x678ac90) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#9  0x00007f393fca54bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#10 0x00007f393fca64cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f393fca6d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f393fc75f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f393fc76979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f3942231b2c in QApplicationPrivate::notify_helper (this=0x20c3b10, receiver=0x2c421b0, e=0x7ffd02d18f80) at kernel/qapplication.cpp:3720
#15 0x00007f3942237000 in QApplication::notify (this=0x7ffd02d192f0, receiver=0x2c421b0, e=0x7ffd02d18f80) at kernel/qapplication.cpp:3503
#16 0x00007f3941445c2b in QCoreApplication::notifyInternal (this=0x7ffd02d192f0, receiver=0x2c421b0, event=event@entry=0x7ffd02d18f80) at kernel/qcoreapplication.cpp:935
#17 0x00007f394149dae5 in sendEvent (event=0x7ffd02d18f80, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#18 QTimerInfoList::activateTimers (this=0x210b1f0) at kernel/qtimerinfo_unix.cpp:635
#19 0x00007f394149df61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#20 0x00007f393d89bc3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f393d89bf20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f393d89bfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f394149ec6c in QEventDispatcherGlib::processEvents (this=0x2109140, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#24 0x00007f39414433e2 in QEventLoop::exec (this=this@entry=0x7ffd02d191d0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#25 0x00007f394144b02c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#26 0x00007f3941c6c31c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#27 0x00007f394222d7a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#28 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-09-14 09:45:56 UTC

*** This bug has been marked as a duplicate of bug 345675 ***