Bug 351583 - Settings
Summary: Settings
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-08-21 20:11 UTC by Mark
Modified: 2015-08-22 14:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark 2015-08-21 20:11:35 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-25-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
keeps crashing and won't let me change the decorations.- What I was doing when the application crashed:
Window decorations
- Custom settings of the application:
Some decorations installed

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f566c32d780 (LWP 6715))]

Thread 5 (Thread 0x7f565baad700 (LWP 6716)):
#0  0x00007f5668a988dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f5666db2b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f5666db464f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f565dff8099 in QXcbEventReader::run (this=0x16ac630) at qxcbconnection.cpp:1105
#4  0x00007f5669119b0e in QThreadPrivate::start (arg=0x16ac630) at thread/qthread_unix.cpp:337
#5  0x00007f5665ccc6aa in start_thread (arg=0x7f565baad700) at pthread_create.c:333
#6  0x00007f5668aa3eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f5643c57700 (LWP 6721)):
#0  0x00007f5668a988dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f56657adebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f56657ae242 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f565208daf6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f56657d4955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f5665ccc6aa in start_thread (arg=0x7f5643c57700) at pthread_create.c:333
#6  0x00007f5668aa3eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f5642baa700 (LWP 6722)):
#0  0x00007f56657f2789 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f56657ad2d7 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f56657adde8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f56657adfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f56693b0c6c in QEventDispatcherGlib::processEvents (this=0x7f56340008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007f56693553e2 in QEventLoop::exec (this=this@entry=0x7f5642ba9e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f5669114b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007f56680dff65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f5669119b0e in QThreadPrivate::start (arg=0x2262a00) at thread/qthread_unix.cpp:337
#9  0x00007f5665ccc6aa in start_thread (arg=0x7f5642baa700) at pthread_create.c:333
#10 0x00007f5668aa3eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f563b5f8700 (LWP 6723)):
#0  0x00007f56657f2789 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f56657ad409 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f56657adde8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f56657adfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f56693b0c6c in QEventDispatcherGlib::processEvents (this=0x7f56300008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007f56693553e2 in QEventLoop::exec (this=this@entry=0x7f563b5f7e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f5669114b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007f56680dff65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f5669119b0e in QThreadPrivate::start (arg=0x27a9930) at thread/qthread_unix.cpp:337
#9  0x00007f5665ccc6aa in start_thread (arg=0x7f563b5f8700) at pthread_create.c:333
#10 0x00007f5668aa3eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f566c32d780 (LWP 6715)):
[KCrash Handler]
#6  0x0000000005ebb970 in ?? ()
#7  0x00007f5667b64628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f5667b63d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f5641614c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x5bff810, oldNode=0x5eba700) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f5667bb74bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f5667bb84cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f5667bb8d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f5667b87f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f5667b88979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f566a143b2c in QApplicationPrivate::notify_helper (this=0x1695b10, receiver=0x23d3b80, e=0x7fff7f0b71b0) at kernel/qapplication.cpp:3720
#16 0x00007f566a149000 in QApplication::notify (this=0x7fff7f0b7520, receiver=0x23d3b80, e=0x7fff7f0b71b0) at kernel/qapplication.cpp:3503
#17 0x00007f5669357c2b in QCoreApplication::notifyInternal (this=0x7fff7f0b7520, receiver=0x23d3b80, event=event@entry=0x7fff7f0b71b0) at kernel/qcoreapplication.cpp:935
#18 0x00007f56693afae5 in sendEvent (event=0x7fff7f0b71b0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x16d8680) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f56693aff61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f56657adc3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f56657adf20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f56657adfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f56693b0c57 in QEventDispatcherGlib::processEvents (this=0x16d4430, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f56693553e2 in QEventLoop::exec (this=this@entry=0x7fff7f0b7400, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f566935d02c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f5669b7e31c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f566a13f7a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-08-22 14:39:22 UTC

*** This bug has been marked as a duplicate of bug 345675 ***