Bug 355066 - Installing Windows Decorations
Summary: Installing Windows Decorations
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-11-09 02:10 UTC by Dallas
Modified: 2015-11-16 01:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dallas 2015-11-09 02:10:54 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-32-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed: I went through the process of installing a Window Decoration package in System Settings>Application Style>Window Decorations in Kubuntu 15.04. After installation the system crashes when entering Window Decorations in System Settings.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7fb37ffc3780 (LWP 1808))]

Thread 5 (Thread 0x7fb36d7cb700 (LWP 1809)):
#0  0x00007fb37c7348dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fb37aa4eb72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fb37aa5064f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fb37058c099 in QXcbEventReader::run (this=0x1669a30) at qxcbconnection.cpp:1105
#4  0x00007fb37cdb5b0e in QThreadPrivate::start (arg=0x1669a30) at thread/qthread_unix.cpp:337
#5  0x00007fb3799686aa in start_thread (arg=0x7fb36d7cb700) at pthread_create.c:333
#6  0x00007fb37c73feed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7fb357159700 (LWP 1813)):
#0  0x00007fff7fb1ccee in clock_gettime ()
#1  0x00007fb37c74e38d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007fb37ce6bcb6 in qt_clock_gettime (ts=0x7fb357158b80, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:161
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:170
#5  0x00007fb37d04a639 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7fb35011d5a0) at kernel/qtimerinfo_unix.cpp:84
#6  0x00007fb37d04aba5 in QTimerInfoList::timerWait (this=0x7fb35011d5a0, tm=...) at kernel/qtimerinfo_unix.cpp:379
#7  0x00007fb37d04c03e in timerSourcePrepareHelper (timeout=0x7fb357158c54, src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:127
#8  timerSourcePrepare (source=<optimized out>, timeout=0x7fb357158c54) at kernel/qeventdispatcher_glib.cpp:160
#9  0x00007fb3794493fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007fb379449de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007fb379449fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007fb37d04cc6c in QEventDispatcherGlib::processEvents (this=0x7fb350107e60, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#13 0x00007fb37cff13e2 in QEventLoop::exec (this=this@entry=0x7fb357158e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#14 0x00007fb37cdb0b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#15 0x00007fb37bd7bf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#16 0x00007fb37cdb5b0e in QThreadPrivate::start (arg=0x215fb50) at thread/qthread_unix.cpp:337
#17 0x00007fb3799686aa in start_thread (arg=0x7fb357159700) at pthread_create.c:333
#18 0x00007fb37c73feed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fb35e498700 (LWP 1814)):
[KCrash Handler]
#6  0x00007fb37b800625 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#7  0x00007fb37b7ffd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fb35cb21c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x2b53f20, oldNode=0x7fb358c72a30) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#9  0x00007fb37b8534bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#10 0x00007fb37b8544cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fb37b854d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fb37b8261dd in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fb37b8270a1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fb37b828360 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007fb37cdb5b0e in QThreadPrivate::start (arg=0x266d1e0) at thread/qthread_unix.cpp:337
#16 0x00007fb3799686aa in start_thread (arg=0x7fb35e498700) at pthread_create.c:333
#17 0x00007fb37c73feed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fb354860700 (LWP 1815)):
#0  0x00007fb37c7348dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fb379449ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb379449fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb37d04cc6c in QEventDispatcherGlib::processEvents (this=0x7fb3480008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fb37cff13e2 in QEventLoop::exec (this=this@entry=0x7fb35485fe20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fb37cdb0b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fb37bd7bf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fb37cdb5b0e in QThreadPrivate::start (arg=0x22f3420) at thread/qthread_unix.cpp:337
#8  0x00007fb3799686aa in start_thread (arg=0x7fb354860700) at pthread_create.c:333
#9  0x00007fb37c73feed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fb37ffc3780 (LWP 1808)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fb37cdb6c6b in wait (time=18446744073709551615, this=0x2621880) at thread/qwaitcondition_unix.cpp:128
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x266d220, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:200
#3  0x00007fb37b829c48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#4  0x00007fb37b82acad in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007fb37dddfb2c in QApplicationPrivate::notify_helper (this=0x163c550, receiver=0x1aeead0, e=0x7fff7fa146d0) at kernel/qapplication.cpp:3720
#6  0x00007fb37dde5000 in QApplication::notify (this=0x7fff7fa14a40, receiver=0x1aeead0, e=0x7fff7fa146d0) at kernel/qapplication.cpp:3503
#7  0x00007fb37cff3c2b in QCoreApplication::notifyInternal (this=0x7fff7fa14a40, receiver=0x1aeead0, event=event@entry=0x7fff7fa146d0) at kernel/qcoreapplication.cpp:935
#8  0x00007fb37d04bae5 in sendEvent (event=0x7fff7fa146d0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#9  QTimerInfoList::activateTimers (this=0x16b03a0) at kernel/qtimerinfo_unix.cpp:635
#10 0x00007fb37d04bf61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#11 0x00007fb379449c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007fb379449f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007fb379449fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#14 0x00007fb37d04cc57 in QEventDispatcherGlib::processEvents (this=0x16ae4b0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#15 0x00007fb37cff13e2 in QEventLoop::exec (this=this@entry=0x7fff7fa14920, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#16 0x00007fb37cff902c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#17 0x00007fb37d81a31c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#18 0x00007fb37dddb7a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#19 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-11-16 01:15:37 UTC

*** This bug has been marked as a duplicate of bug 345675 ***