Bug 350712 - System Settings Crashed when trying to set the Window Decorations
Summary: System Settings Crashed when trying to set the Window Decorations
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-07-28 17:21 UTC by Gerald Butler
Modified: 2015-08-02 09:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Butler 2015-07-28 17:21:29 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-25-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:

I was attempting to change the window decorations so that the font used for the title bar was smaller.

The crash can be reproduced sometimes.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7f12532ef780 (LWP 2594))]

Thread 7 (Thread 0x7f1240afa700 (LWP 2595)):
#0  0x00007f124fa618dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f124dd7bb72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f124dd7d64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f12438bc099 in QXcbEventReader::run (this=0x13a6a80) at qxcbconnection.cpp:1105
#4  0x00007f12500e2b0e in QThreadPrivate::start (arg=0x13a6a80) at thread/qthread_unix.cpp:337
#5  0x00007f124cc956aa in start_thread (arg=0x7f1240afa700) at pthread_create.c:333
#6  0x00007f124fa6ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 6 (Thread 0x7f1233136700 (LWP 2598)):
#0  0x00007f124fa618dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f124c776ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f124c777242 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f123a48aaf6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f124c79d955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f124cc956aa in start_thread (arg=0x7f1233136700) at pthread_create.c:333
#6  0x00007f124fa6ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f1232935700 (LWP 2599)):
#0  0x00007f124c7bb789 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f124c7762d7 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f124c776de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f124c776fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f124c777009 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f124c79d955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f124cc956aa in start_thread (arg=0x7f1232935700) at pthread_create.c:333
#7  0x00007f124fa6ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f12178b0700 (LWP 2610)):
#0  0x00007f124fa618dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f124c776ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f124c776fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1250379c6c in QEventDispatcherGlib::processEvents (this=0x7f1210133090, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f125031e3e2 in QEventLoop::exec (this=this@entry=0x7f12178afe20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f12500ddb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f124f0a8f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f12500e2b0e in QThreadPrivate::start (arg=0x1e27c60) at thread/qthread_unix.cpp:337
#8  0x00007f124cc956aa in start_thread (arg=0x7f12178b0700) at pthread_create.c:333
#9  0x00007f124fa6ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f1231bca700 (LWP 2611)):
[KCrash Handler]
#6  0x00007f124eb2d625 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#7  0x00007f124eb2cd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f121924fc9a in Plasma::FrameSvgItem::updatePaintNode (this=0x2a33390, oldNode=0x7f1228c0fac0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#9  0x00007f124eb804bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#10 0x00007f124eb814cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f124eb81d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f124eb531dd in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f124eb540a1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f124eb55360 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f12500e2b0e in QThreadPrivate::start (arg=0x1f331b0) at thread/qthread_unix.cpp:337
#16 0x00007f124cc956aa in start_thread (arg=0x7f1231bca700) at pthread_create.c:333
#17 0x00007f124fa6ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f120d9aa700 (LWP 2612)):
#0  0x00007f124fa618dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f124c776ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f124c776fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1250379c6c in QEventDispatcherGlib::processEvents (this=0x7f12080008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f125031e3e2 in QEventLoop::exec (this=this@entry=0x7f120d9a9e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f12500ddb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f124f0a8f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f12500e2b0e in QThreadPrivate::start (arg=0x23acfc0) at thread/qthread_unix.cpp:337
#8  0x00007f124cc956aa in start_thread (arg=0x7f120d9aa700) at pthread_create.c:333
#9  0x00007f124fa6ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f12532ef780 (LWP 2594)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f12500e3c6b in wait (time=18446744073709551615, this=0x1e09720) at thread/qwaitcondition_unix.cpp:128
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1f331f0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:200
#3  0x00007f124eb56c48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#4  0x00007f124eb57cad in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007f125110cb2c in QApplicationPrivate::notify_helper (this=0x1379550, receiver=0x1751ad0, e=0x7fff23bda0c0) at kernel/qapplication.cpp:3720
#6  0x00007f1251112000 in QApplication::notify (this=0x7fff23bda430, receiver=0x1751ad0, e=0x7fff23bda0c0) at kernel/qapplication.cpp:3503
#7  0x00007f1250320c2b in QCoreApplication::notifyInternal (this=0x7fff23bda430, receiver=0x1751ad0, event=event@entry=0x7fff23bda0c0) at kernel/qcoreapplication.cpp:935
#8  0x00007f1250378ae5 in sendEvent (event=0x7fff23bda0c0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#9  QTimerInfoList::activateTimers (this=0x145ac30) at kernel/qtimerinfo_unix.cpp:635
#10 0x00007f1250378f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#11 0x00007f124c776c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f124c776f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007f124c776fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#14 0x00007f1250379c57 in QEventDispatcherGlib::processEvents (this=0x13756c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#15 0x00007f125031e3e2 in QEventLoop::exec (this=this@entry=0x7fff23bda310, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#16 0x00007f125032602c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#17 0x00007f1250b4731c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#18 0x00007f12511087a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#19 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-08-02 09:27:28 UTC

*** This bug has been marked as a duplicate of bug 345675 ***