Bug 346709 - windows decoration crashes
Summary: windows decoration crashes
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-04-26 11:54 UTC by Yousef
Modified: 2015-04-28 10:40 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousef 2015-04-26 11:54:57 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-15-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
opening the windows decoration, always crashes, i have the new version of kubuntu 15.04, whe i try to open windows decoration from appliction style it always crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f0de0088780 (LWP 9319))]

Thread 4 (Thread 0x7f0dcf800700 (LWP 9320)):
#0  0x00007f0ddc7ec8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f0ddab06b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f0ddab0864f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f0dd1d4b099 in QXcbEventReader::run (this=0x22a2d60) at qxcbconnection.cpp:1105
#4  0x00007f0ddce6db0e in QThreadPrivate::start (arg=0x22a2d60) at thread/qthread_unix.cpp:337
#5  0x00007f0dd9a206aa in start_thread (arg=0x7f0dcf800700) at pthread_create.c:333
#6  0x00007f0ddc7f7eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f0dbf36d700 (LWP 9321)):
#0  0x00007f0ddc7ec8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f0dd9501ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0dd9501fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0ddd104c6c in QEventDispatcherGlib::processEvents (this=0x7f0db80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f0ddd0a93e2 in QEventLoop::exec (this=this@entry=0x7f0dbf36ce20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f0ddce68b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f0ddbe33f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f0ddce6db0e in QThreadPrivate::start (arg=0x2d25650) at thread/qthread_unix.cpp:337
#8  0x00007f0dd9a206aa in start_thread (arg=0x7f0dbf36d700) at pthread_create.c:333
#9  0x00007f0ddc7f7eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f0db7d59700 (LWP 9322)):
#0  0x00007f0dd95467a4 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f0dd95013f0 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0dd9501de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0dd9501fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f0ddd104c6c in QEventDispatcherGlib::processEvents (this=0x7f0db00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007f0ddd0a93e2 in QEventLoop::exec (this=this@entry=0x7f0db7d58e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f0ddce68b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007f0ddbe33f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f0ddce6db0e in QThreadPrivate::start (arg=0x4403410) at thread/qthread_unix.cpp:337
#9  0x00007f0dd9a206aa in start_thread (arg=0x7f0db7d59700) at pthread_create.c:333
#10 0x00007f0ddc7f7eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f0de0088780 (LWP 9319)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f0ddb8b8628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f0ddb8b7d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f0dbd838c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x54eb4f0, oldNode=0x5962020) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f0ddb90b4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f0ddb90c4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f0ddb90cd80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f0ddb8dbf05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f0ddb8dc979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f0ddde97b2c in QApplicationPrivate::notify_helper (this=0x228ab10, receiver=0x2d0f690, e=0x7ffda9874ae0) at kernel/qapplication.cpp:3720
#16 0x00007f0ddde9d000 in QApplication::notify (this=0x7ffda9874e50, receiver=0x2d0f690, e=0x7ffda9874ae0) at kernel/qapplication.cpp:3503
#17 0x00007f0ddd0abc2b in QCoreApplication::notifyInternal (this=0x7ffda9874e50, receiver=0x2d0f690, event=event@entry=0x7ffda9874ae0) at kernel/qcoreapplication.cpp:935
#18 0x00007f0ddd103ae5 in sendEvent (event=0x7ffda9874ae0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x22cc860) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f0ddd103f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f0dd9501c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f0dd9501f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f0dd9501fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f0ddd104c57 in QEventDispatcherGlib::processEvents (this=0x22d4570, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f0ddd0a93e2 in QEventLoop::exec (this=this@entry=0x7ffda9874d30, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f0ddd0b102c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f0ddd8d231c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f0ddde937a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-04-28 10:40:31 UTC

*** This bug has been marked as a duplicate of bug 345675 ***