Bug 348100 - Unfortunately, the System Configuration broke out unexpectedly.
Summary: Unfortunately, the System Configuration broke out unexpectedly.
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-22 13:04 UTC by Dyones
Modified: 2015-05-23 14:36 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dyones 2015-05-22 13:04:55 UTC
Application: systemsettings5 (5.3.0)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-18-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- Custom settings of the application: The window title appearance/Ghost - Deco 2.2
Note:. Not native new decor.

The crash can be reproduced every time.

-- Backtrace:
Application: Configuração do Sistema (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f85dbe5e780 (LWP 2086))]

Thread 4 (Thread 0x7f85cb5db700 (LWP 2087)):
#0  0x00007f85d85c88dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f85d68e2b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f85d68e464f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f85cdb26099 in QXcbEventReader::run (this=0x918520) at qxcbconnection.cpp:1105
#4  0x00007f85d8c49b0e in QThreadPrivate::start (arg=0x918520) at thread/qthread_unix.cpp:337
#5  0x00007f85d57fc6aa in start_thread (arg=0x7f85cb5db700) at pthread_create.c:333
#6  0x00007f85d85d3eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f85bb163700 (LWP 2089)):
#0  0x00007f85d52dd4f5 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f85d52ddde8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f85d52ddfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f85d8ee0c6c in QEventDispatcherGlib::processEvents (this=0x7f85b40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f85d8e853e2 in QEventLoop::exec (this=this@entry=0x7f85bb162e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f85d8c44b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f85d7c0ff65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f85d8c49b0e in QThreadPrivate::start (arg=0xcf18e0) at thread/qthread_unix.cpp:337
#8  0x00007f85d57fc6aa in start_thread (arg=0x7f85bb163700) at pthread_create.c:333
#9  0x00007f85d85d3eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f85b3b14700 (LWP 2090)):
#0  0x00007f85d85c88dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f85d52ddebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f85d52ddfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f85d8ee0c6c in QEventDispatcherGlib::processEvents (this=0x7f85ac0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f85d8e853e2 in QEventLoop::exec (this=this@entry=0x7f85b3b13e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f85d8c44b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f85d7c0ff65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f85d8c49b0e in QThreadPrivate::start (arg=0x100b960) at thread/qthread_unix.cpp:337
#8  0x00007f85d57fc6aa in start_thread (arg=0x7f85b3b14700) at pthread_create.c:333
#9  0x00007f85d85d3eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f85dbe5e780 (LWP 2086)):
[KCrash Handler]
#6  0x0000000000000070 in ?? ()
#7  0x00007f85d7694628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f85d7693d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f85b9b37c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x31da970, oldNode=0x46d7d40) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f85d76e74bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f85d76e84cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f85d76e8d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f85d76b7f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f85d76b8979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f85d9c73b2c in QApplicationPrivate::notify_helper (this=0x901b10, receiver=0xd8cfb0, e=0x7ffd2064d690) at kernel/qapplication.cpp:3720
#16 0x00007f85d9c79000 in QApplication::notify (this=0x7ffd2064da00, receiver=0xd8cfb0, e=0x7ffd2064d690) at kernel/qapplication.cpp:3503
#17 0x00007f85d8e87c2b in QCoreApplication::notifyInternal (this=0x7ffd2064da00, receiver=0xd8cfb0, event=event@entry=0x7ffd2064d690) at kernel/qcoreapplication.cpp:935
#18 0x00007f85d8edfae5 in sendEvent (event=0x7ffd2064d690, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x948fb0) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f85d8edff61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f85d52ddc3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f85d52ddf20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f85d52ddfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f85d8ee0c57 in QEventDispatcherGlib::processEvents (this=0x943ba0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f85d8e853e2 in QEventLoop::exec (this=this@entry=0x7ffd2064d8e0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f85d8e8d02c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x000000000040ef5b in main ()

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-23 14:36:27 UTC

*** This bug has been marked as a duplicate of bug 345675 ***