Bug 353408 - Crash in System Settings
Summary: Crash in System Settings
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-10-01 13:56 UTC by Norberto Altalef
Modified: 2015-10-10 21:38 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Norberto Altalef 2015-10-01 13:56:44 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-30-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
Just enter Application Style. 
Also crash a couple of time yesterday, but I didn record what I was doing.
I have install UniQ Windows Decoration

The crash can be reproduced sometimes.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f19089fd780 (LWP 4909))]

Thread 4 (Thread 0x7f18f7ec2700 (LWP 4910)):
#0  0x00007f19051628dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f190347cb72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f190347e64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f18fa40d099 in QXcbEventReader::run (this=0xa09540) at qxcbconnection.cpp:1105
#4  0x00007f19057e3b0e in QThreadPrivate::start (arg=0xa09540) at thread/qthread_unix.cpp:337
#5  0x00007f19023966aa in start_thread (arg=0x7f18f7ec2700) at pthread_create.c:333
#6  0x00007f190516deed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f18e79f6700 (LWP 4911)):
#0  0x00007f1901ebc789 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f1901e77fb8 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1905a7ac6c in QEventDispatcherGlib::processEvents (this=0x7f18e00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#3  0x00007f1905a1f3e2 in QEventLoop::exec (this=this@entry=0x7f18e79f5e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#4  0x00007f19057deb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#5  0x00007f19047a9f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#6  0x00007f19057e3b0e in QThreadPrivate::start (arg=0xd16cb0) at thread/qthread_unix.cpp:337
#7  0x00007f19023966aa in start_thread (arg=0x7f18e79f6700) at pthread_create.c:333
#8  0x00007f190516deed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f18dffff700 (LWP 4912)):
#0  0x00007f19051628dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f1901e77ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1901e77fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1905a7ac6c in QEventDispatcherGlib::processEvents (this=0x7f18d80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f1905a1f3e2 in QEventLoop::exec (this=this@entry=0x7f18dfffee20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f19057deb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f19047a9f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f19057e3b0e in QThreadPrivate::start (arg=0x113ed40) at thread/qthread_unix.cpp:337
#8  0x00007f19023966aa in start_thread (arg=0x7f18dffff700) at pthread_create.c:333
#9  0x00007f190516deed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f19089fd780 (LWP 4909)):
[KCrash Handler]
#6  0x0000000000000100 in ?? ()
#7  0x00007f190422e628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f190422dd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f18e5f34c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x31ef020, oldNode=0x3392100) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f19042814bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f19042824cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f1904282d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f1904251f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f1904252979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f190680db2c in QApplicationPrivate::notify_helper (this=0x9f0b10, receiver=0xd9ab90, e=0x7ffe6a1092b0) at kernel/qapplication.cpp:3720
#16 0x00007f1906813000 in QApplication::notify (this=0x7ffe6a109620, receiver=0xd9ab90, e=0x7ffe6a1092b0) at kernel/qapplication.cpp:3503
#17 0x00007f1905a21c2b in QCoreApplication::notifyInternal (this=0x7ffe6a109620, receiver=0xd9ab90, event=event@entry=0x7ffe6a1092b0) at kernel/qcoreapplication.cpp:935
#18 0x00007f1905a79ae5 in sendEvent (event=0x7ffe6a1092b0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0xa324d0) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f1905a79f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f1901e77c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f1901e77f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f1901e77fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f1905a7ac57 in QEventDispatcherGlib::processEvents (this=0xa34040, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f1905a1f3e2 in QEventLoop::exec (this=this@entry=0x7ffe6a109500, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f1905a2702c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f190624831c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f19068097a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-10-10 21:38:04 UTC

*** This bug has been marked as a duplicate of bug 345675 ***