Bug 347890 - Windows Decorations crash System Settings
Summary: Windows Decorations crash System Settings
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-18 09:21 UTC by Mike Lewis
Modified: 2015-05-23 14:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Lewis 2015-05-18 09:21:12 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.16.0-37-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
Start System Settings, choose Application Styles, choose Window Decorations -> CRASH

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7f6487caf780 (LWP 8662))]

Thread 5 (Thread 0x7f6475346700 (LWP 8663)):
#0  0x00007f64844208dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f648273ab72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f648273c64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f6478107099 in QXcbEventReader::run (this=0x17cdbf0) at qxcbconnection.cpp:1105
#4  0x00007f6484aa1b0e in QThreadPrivate::start (arg=0x17cdbf0) at thread/qthread_unix.cpp:337
#5  0x00007f64816546aa in start_thread (arg=0x7f6475346700) at pthread_create.c:333
#6  0x00007f648442beed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f646618f700 (LWP 8666)):
#0  0x00007f64844208dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f6481135ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6481135fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6484d38c6c in QEventDispatcherGlib::processEvents (this=0x7f64600008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f6484cdd3e2 in QEventLoop::exec (this=this@entry=0x7f646618ee20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f6484a9cb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f6483a67f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f6484aa1b0e in QThreadPrivate::start (arg=0x1c8d5a0) at thread/qthread_unix.cpp:337
#8  0x00007f64816546aa in start_thread (arg=0x7f646618f700) at pthread_create.c:333
#9  0x00007f648442beed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f645e83a700 (LWP 8667)):
#0  0x00007f648441c49d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f647d59cf45 in ?? () from /usr/lib/nvidia-346/tls/libnvidia-tls.so.346.59
#2  0x00007f64811792f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f648113596c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f6481135e60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f6481135fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f6484d38c6c in QEventDispatcherGlib::processEvents (this=0x7f64580008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#7  0x00007f6484cdd3e2 in QEventLoop::exec (this=this@entry=0x7f645e839e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#8  0x00007f6484a9cb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#9  0x00007f6483a67f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#10 0x00007f6484aa1b0e in QThreadPrivate::start (arg=0x20effc0) at thread/qthread_unix.cpp:337
#11 0x00007f64816546aa in start_thread (arg=0x7f645e83a700) at pthread_create.c:333
#12 0x00007f648442beed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f6457fff700 (LWP 8668)):
[KCrash Handler]
#6  0x0000000000000070 in ?? ()
#7  0x00007f64834ec628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f64834ebd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f64645edc9a in Plasma::FrameSvgItem::updatePaintNode (this=0x31aba70, oldNode=0x7f6450f45b80) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f648353f4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f64835404cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f6483540d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f64835121dd in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f64835130a1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f6483514360 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#16 0x00007f6484aa1b0e in QThreadPrivate::start (arg=0x205ec80) at thread/qthread_unix.cpp:337
#17 0x00007f64816546aa in start_thread (arg=0x7f6457fff700) at pthread_create.c:333
#18 0x00007f648442beed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f6487caf780 (LWP 8662)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f6484aa2c6b in wait (time=18446744073709551615, this=0x239d000) at thread/qwaitcondition_unix.cpp:128
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x205ecc0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:200
#3  0x00007f6483515c48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#4  0x00007f6483516cad in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007f6485acbb2c in QApplicationPrivate::notify_helper (this=0x17a1550, receiver=0x1b63d20, e=0x7ffe4d9adf80) at kernel/qapplication.cpp:3720
#6  0x00007f6485ad1000 in QApplication::notify (this=0x7ffe4d9ae2f0, receiver=0x1b63d20, e=0x7ffe4d9adf80) at kernel/qapplication.cpp:3503
#7  0x00007f6484cdfc2b in QCoreApplication::notifyInternal (this=0x7ffe4d9ae2f0, receiver=0x1b63d20, event=event@entry=0x7ffe4d9adf80) at kernel/qcoreapplication.cpp:935
#8  0x00007f6484d37ae5 in sendEvent (event=0x7ffe4d9adf80, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#9  QTimerInfoList::activateTimers (this=0x180f500) at kernel/qtimerinfo_unix.cpp:635
#10 0x00007f6484d37f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#11 0x00007f6481135c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f6481135f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007f6481135fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#14 0x00007f6484d38c57 in QEventDispatcherGlib::processEvents (this=0x1812f90, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#15 0x00007f6484cdd3e2 in QEventLoop::exec (this=this@entry=0x7ffe4d9ae1d0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#16 0x00007f6484ce502c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#17 0x00007f648550631c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#18 0x00007f6485ac77a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#19 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-23 14:34:32 UTC

*** This bug has been marked as a duplicate of bug 345675 ***