Bug 347186 - system settings crashed after enter window decoration
Summary: system settings crashed after enter window decoration
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Kubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-04 20:24 UTC by psilocibin
Modified: 2015-05-09 19:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description psilocibin 2015-05-04 20:24:57 UTC
Application: systemsettings5 (5.3.0)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-15-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
When open system settings> application style>window decorations it crashes
AMD driver Installed: 2:15.200-0ubuntu4
Linux pc 3.19.0-15-generic
AMD r9 290

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7ffab051e780 (LWP 2135))]

Thread 6 (Thread 0x7ffaa0d8d700 (LWP 2136)):
#0  0x00007ffaacc8b8dd in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007ffaaafa5b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007ffaaafa764f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007ffaa3b20099 in QXcbEventReader::run (this=0x12a0960) at qxcbconnection.cpp:1105
#4  0x00007ffaad30cb0e in QThreadPrivate::start (arg=0x12a0960) at thread/qthread_unix.cpp:337
#5  0x00007ffaa9ebf6aa in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#6  0x00007ffaacc96eed in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 5 (Thread 0x7ffa8e5a8700 (LWP 2137)):
#0  0x00007ffaacc8d0b7 in ioctl () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007ffa925ee919 in uki_firegl_MicroSleep () from /usr/lib/libatiuki.so.1
#2  0x00007ffa94523920 in ?? () from /usr/lib/dri/fglrx_dri.so
#3  0x00007ffa93cb4d72 in ?? () from /usr/lib/dri/fglrx_dri.so
#4  0x00007ffa93cb4dc5 in ?? () from /usr/lib/dri/fglrx_dri.so
#5  0x00007ffaa9ebf6aa in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#6  0x00007ffaacc96eed in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 4 (Thread 0x7ffa8dda7700 (LWP 2138)):
#0  0x00007ffaa99e5789 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007ffaa99a0dbd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ffaa99a0fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ffaad5a3c6c in QEventDispatcherGlib::processEvents (this=0x7ffa800008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007ffaad5483e2 in QEventLoop::exec (this=this@entry=0x7ffa8dda6e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007ffaad307b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007ffaac2d2f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007ffaad30cb0e in QThreadPrivate::start (arg=0x1750bc0) at thread/qthread_unix.cpp:337
#8  0x00007ffaa9ebf6aa in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#9  0x00007ffaacc96eed in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 3 (Thread 0x7ffa864d4700 (LWP 2139)):
#0  0x00007ffaacc8749d in read () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007ffaa99e42f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ffaa99a096c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ffaa99a0e60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007ffaa99a0fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007ffaad5a3c6c in QEventDispatcherGlib::processEvents (this=0x7ffa7c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#6  0x00007ffaad5483e2 in QEventLoop::exec (this=this@entry=0x7ffa864d3e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#7  0x00007ffaad307b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#8  0x00007ffaac2d2f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007ffaad30cb0e in QThreadPrivate::start (arg=0x1f9f6d0) at thread/qthread_unix.cpp:337
#10 0x00007ffaa9ebf6aa in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#11 0x00007ffaacc96eed in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 2 (Thread 0x7ffa7bdb7700 (LWP 2140)):
[KCrash Handler]
#6  0x0000000100000001 in ?? ()
#7  0x00007ffaabd57628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007ffaabd56d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007ffa8c7bfc9a in Plasma::FrameSvgItem::updatePaintNode (this=0x2f773b0, oldNode=0x7ffa74d08370) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007ffaabdaa4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007ffaabdab4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007ffaabdabd80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007ffaabd7d1dd in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007ffaabd7e0a1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007ffaabd7f360 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#16 0x00007ffaad30cb0e in QThreadPrivate::start (arg=0x1f90130) at thread/qthread_unix.cpp:337
#17 0x00007ffaa9ebf6aa in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#18 0x00007ffaacc96eed in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 1 (Thread 0x7ffab051e780 (LWP 2135)):
#0  0x00007ffaa9ec4da0 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007ffaad30dc6b in wait (time=18446744073709551615, this=0x1f80430) at thread/qwaitcondition_unix.cpp:128
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1f90170, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:200
#3  0x00007ffaabd80c48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#4  0x00007ffaabd81cad in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007ffaae336b2c in QApplicationPrivate::notify_helper (this=0x1287e70, receiver=0x18643d0, e=0x7ffd8610f970) at kernel/qapplication.cpp:3720
#6  0x00007ffaae33c000 in QApplication::notify (this=0x7ffd8610fce0, receiver=0x18643d0, e=0x7ffd8610f970) at kernel/qapplication.cpp:3503
#7  0x00007ffaad54ac2b in QCoreApplication::notifyInternal (this=0x7ffd8610fce0, receiver=0x18643d0, event=event@entry=0x7ffd8610f970) at kernel/qcoreapplication.cpp:935
#8  0x00007ffaad5a2ae5 in sendEvent (event=0x7ffd8610f970, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#9  QTimerInfoList::activateTimers (this=0x12d05d0) at kernel/qtimerinfo_unix.cpp:635
#10 0x00007ffaad5a2f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#11 0x00007ffaa99a0c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007ffaa99a0f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007ffaa99a0fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#14 0x00007ffaad5a3c57 in QEventDispatcherGlib::processEvents (this=0x12c7ab0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#15 0x00007ffaad5483e2 in QEventLoop::exec (this=this@entry=0x7ffd8610fbc0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#16 0x00007ffaad55002c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#17 0x00007ffaadd7131c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#18 0x00007ffaae3327a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#19 0x000000000040ef5b in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:55

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-09 19:12:27 UTC

*** This bug has been marked as a duplicate of bug 345675 ***