Bug 348164 - Adding Application Themes
Summary: Adding Application Themes
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-23 21:01 UTC by Randy
Modified: 2015-05-31 13:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Randy 2015-05-23 21:01:02 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-16-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
Adding Window Decorations via the Get New Decoration button. Had just finished selecting a second one when the crash occured. Had System Monitor displaying System Load and was watching a YouTube video in Firefox.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7fc60901c780 (LWP 3276))]

Thread 6 (Thread 0x7fc5f691a700 (LWP 3277)):
#0  0x00007fc60577f8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fc603a99b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fc603a9b64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fc5f96ad099 in QXcbEventReader::run (this=0xec01c0) at qxcbconnection.cpp:1105
#4  0x00007fc605e00b0e in QThreadPrivate::start (arg=0xec01c0) at thread/qthread_unix.cpp:337
#5  0x00007fc6029b36aa in start_thread (arg=0x7fc5f691a700) at pthread_create.c:333
#6  0x00007fc60578aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7fc5df78d700 (LWP 3363)):
#0  0x00007fc60577b49d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fc5fe907f45 in ?? () from /usr/lib/nvidia-340/tls/libnvidia-tls.so.340.76
#2  0x00007fc6024d82f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc60249496c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fc602494e60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fc602494fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007fc606097c6c in QEventDispatcherGlib::processEvents (this=0x7fc5d80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#7  0x00007fc60603c3e2 in QEventLoop::exec (this=this@entry=0x7fc5df78ce20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#8  0x00007fc605dfbb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#9  0x00007fc604dc6f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#10 0x00007fc605e00b0e in QThreadPrivate::start (arg=0x270bb00) at thread/qthread_unix.cpp:337
#11 0x00007fc6029b36aa in start_thread (arg=0x7fc5df78d700) at pthread_create.c:333
#12 0x00007fc60578aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7fc5d7d59700 (LWP 3364)):
#0  0x00007fc60577f8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fc602494ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc602494fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc606097c6c in QEventDispatcherGlib::processEvents (this=0x7fc5d00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fc60603c3e2 in QEventLoop::exec (this=this@entry=0x7fc5d7d58e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fc605dfbb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fc604dc6f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fc605e00b0e in QThreadPrivate::start (arg=0x2b45fa0) at thread/qthread_unix.cpp:337
#8  0x00007fc6029b36aa in start_thread (arg=0x7fc5d7d59700) at pthread_create.c:333
#9  0x00007fc60578aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fc5d6901700 (LWP 3365)):
[KCrash Handler]
#6  0x0000000000000070 in ?? ()
#7  0x00007fc60484b628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fc60484ad3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007fc5ddc29c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x2b51f50, oldNode=0x7fc5c878c3d0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007fc60489e4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fc60489f4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fc60489fd80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fc6048711dd in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fc6048720a1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007fc604873360 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#16 0x00007fc605e00b0e in QThreadPrivate::start (arg=0x2d64f70) at thread/qthread_unix.cpp:337
#17 0x00007fc6029b36aa in start_thread (arg=0x7fc5d6901700) at pthread_create.c:333
#18 0x00007fc60578aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fc5d538c700 (LWP 3371)):
#0  0x00007ffc28f6bc56 in clock_gettime ()
#1  0x00007fc60579938d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007fc605eb6cb6 in qt_clock_gettime (ts=0x7fc5d538bba0, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:161
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:170
#5  0x00007fc606095639 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7fc5cc002cd0) at kernel/qtimerinfo_unix.cpp:84
#6  0x00007fc606095ba5 in QTimerInfoList::timerWait (this=0x7fc5cc002cd0, tm=...) at kernel/qtimerinfo_unix.cpp:379
#7  0x00007fc60609703e in timerSourcePrepareHelper (timeout=0x7fc5d538bc74, src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:127
#8  timerSourcePrepare (source=<optimized out>, timeout=0x7fc5d538bc74) at kernel/qeventdispatcher_glib.cpp:160
#9  0x00007fc6024943fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007fc602494de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007fc602494fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007fc606097c6c in QEventDispatcherGlib::processEvents (this=0x7fc5cc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#13 0x00007fc60603c3e2 in QEventLoop::exec (this=this@entry=0x7fc5d538be40, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#14 0x00007fc605dfbb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#15 0x00007fc605e00b0e in QThreadPrivate::start (arg=0x310af70) at thread/qthread_unix.cpp:337
#16 0x00007fc6029b36aa in start_thread (arg=0x7fc5d538c700) at pthread_create.c:333
#17 0x00007fc60578aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fc60901c780 (LWP 3276)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fc605e01c6b in wait (time=18446744073709551615, this=0x2aff090) at thread/qwaitcondition_unix.cpp:128
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2d64fb0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:200
#3  0x00007fc604874c48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#4  0x00007fc604875cad in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007fc606e2ab2c in QApplicationPrivate::notify_helper (this=0xe93430, receiver=0x21806f0, e=0x7ffc28e7b700) at kernel/qapplication.cpp:3720
#6  0x00007fc606e30000 in QApplication::notify (this=0x7ffc28e7ba70, receiver=0x21806f0, e=0x7ffc28e7b700) at kernel/qapplication.cpp:3503
#7  0x00007fc60603ec2b in QCoreApplication::notifyInternal (this=0x7ffc28e7ba70, receiver=0x21806f0, event=event@entry=0x7ffc28e7b700) at kernel/qcoreapplication.cpp:935
#8  0x00007fc606096ae5 in sendEvent (event=0x7ffc28e7b700, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#9  QTimerInfoList::activateTimers (this=0xf078f0) at kernel/qtimerinfo_unix.cpp:635
#10 0x00007fc606096f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#11 0x00007fc602494c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007fc602494f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007fc602494fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#14 0x00007fc606097c57 in QEventDispatcherGlib::processEvents (this=0xf06aa0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#15 0x00007fc60603c3e2 in QEventLoop::exec (this=this@entry=0x7ffc28e7b950, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#16 0x00007fc60604402c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#17 0x00007fc60686531c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#18 0x00007fc606e267a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#19 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-31 13:51:52 UTC

*** This bug has been marked as a duplicate of bug 345675 ***