Bug 350936 - system setting crash when enter application style -> window decorations
Summary: system setting crash when enter application style -> window decorations
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-08-03 20:51 UTC by Michal Lipinski
Modified: 2015-08-13 00:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Lipinski 2015-08-03 20:51:38 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-25-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
system settings -> application style -> window decorations immidiete crash (kubuntu)

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7f1e08e2c780 (LWP 4836))]

Thread 5 (Thread 0x7f1df6529700 (LWP 4837)):
#0  0x00007f1e055928dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f1e038acb72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f1e038ae64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f1df92bc099 in QXcbEventReader::run (this=0x14299c0) at qxcbconnection.cpp:1105
#4  0x00007f1e05c13b0e in QThreadPrivate::start (arg=0x14299c0) at thread/qthread_unix.cpp:337
#5  0x00007f1e027c66aa in start_thread (arg=0x7f1df6529700) at pthread_create.c:333
#6  0x00007f1e0559deed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f1de6ff4700 (LWP 4838)):
#0  0x00007f1e055928dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f1e022a7ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1e022a7fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1e05eaac6c in QEventDispatcherGlib::processEvents (this=0x7f1de00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f1e05e4f3e2 in QEventLoop::exec (this=this@entry=0x7f1de6ff3e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f1e05c0eb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f1e04bd9f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f1e05c13b0e in QThreadPrivate::start (arg=0x1c89180) at thread/qthread_unix.cpp:337
#8  0x00007f1e027c66aa in start_thread (arg=0x7f1de6ff4700) at pthread_create.c:333
#9  0x00007f1e0559deed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f1ddf5f8700 (LWP 4839)):
[KCrash Handler]
#6  0x00007f1e0465e625 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#7  0x00007f1e0465dd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f1de599ac9a in Plasma::FrameSvgItem::updatePaintNode (this=0x27df170, oldNode=0x7f1dd8767d50) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#9  0x00007f1e046b14bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#10 0x00007f1e046b24cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f1e046b2d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f1e046841dd in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f1e046850a1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f1e04686360 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f1e05c13b0e in QThreadPrivate::start (arg=0x1dcbc60) at thread/qthread_unix.cpp:337
#16 0x00007f1e027c66aa in start_thread (arg=0x7f1ddf5f8700) at pthread_create.c:333
#17 0x00007f1e0559deed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f1ddedf7700 (LWP 4840)):
#0  QThreadData::current (createIfNecessary=createIfNecessary@entry=true) at thread/qthread_unix.cpp:213
#1  0x00007f1e05eaa1ba in postEventSourcePrepare (s=0x7f1dd00012d0, timeout=0x7f1ddedf6c54) at kernel/qeventdispatcher_glib.cpp:247
#2  0x00007f1e022a73fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1e022a7de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f1e022a7fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f1e05eaac6c in QEventDispatcherGlib::processEvents (this=0x7f1dd00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#6  0x00007f1e05e4f3e2 in QEventLoop::exec (this=this@entry=0x7f1ddedf6e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#7  0x00007f1e05c0eb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#8  0x00007f1e04bd9f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007f1e05c13b0e in QThreadPrivate::start (arg=0x2051c70) at thread/qthread_unix.cpp:337
#10 0x00007f1e027c66aa in start_thread (arg=0x7f1ddedf7700) at pthread_create.c:333
#11 0x00007f1e0559deed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f1e08e2c780 (LWP 4836)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f1e05c14c6b in wait (time=18446744073709551615, this=0x1d4b2f0) at thread/qwaitcondition_unix.cpp:128
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1dcbca0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:200
#3  0x00007f1e04687c48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#4  0x00007f1e04688cad in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007f1e06c3db2c in QApplicationPrivate::notify_helper (this=0x13fb550, receiver=0x18c8e80, e=0x7ffcf5540870) at kernel/qapplication.cpp:3720
#6  0x00007f1e06c43000 in QApplication::notify (this=0x7ffcf5540be0, receiver=0x18c8e80, e=0x7ffcf5540870) at kernel/qapplication.cpp:3503
#7  0x00007f1e05e51c2b in QCoreApplication::notifyInternal (this=0x7ffcf5540be0, receiver=0x18c8e80, event=event@entry=0x7ffcf5540870) at kernel/qcoreapplication.cpp:935
#8  0x00007f1e05ea9ae5 in sendEvent (event=0x7ffcf5540870, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#9  QTimerInfoList::activateTimers (this=0x14759b0) at kernel/qtimerinfo_unix.cpp:635
#10 0x00007f1e05ea9f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#11 0x00007f1e022a7c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f1e022a7f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007f1e022a7fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#14 0x00007f1e05eaac57 in QEventDispatcherGlib::processEvents (this=0x1474e40, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#15 0x00007f1e05e4f3e2 in QEventLoop::exec (this=this@entry=0x7ffcf5540ac0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#16 0x00007f1e05e5702c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#17 0x00007f1e0667831c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#18 0x00007f1e06c397a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#19 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-08-13 00:06:08 UTC

*** This bug has been marked as a duplicate of bug 345675 ***