Bug 348512 - System setting crashes when opening Window Decoration
Summary: System setting crashes when opening Window Decoration
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-31 18:37 UTC by Kristian Karl
Modified: 2015-06-01 11:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kristian Karl 2015-05-31 18:37:16 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.16.0-34-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
1) Open System setting
2) Select "Application Style"
3) Select "Window Decoration"

Expected result:
The "Window Decoration" is displayed

Actual result: 
System setting app crashes

Additional info:
I downloaded a couple of Decoration Themes. I belive one of these crashes the view.
Is there a way to look in som config file which themes are loaded, so I can provide exactt details?

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f687a2a5780 (LWP 20947))]

Thread 4 (Thread 0x7f6869904700 (LWP 20948)):
#0  0x00007f6876a208dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f6874d3ab72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f6874d3c64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f686be4f099 in QXcbEventReader::run (this=0x1ac15a0) at qxcbconnection.cpp:1105
#4  0x00007f68770a1b0e in QThreadPrivate::start (arg=0x1ac15a0) at thread/qthread_unix.cpp:337
#5  0x00007f6873c546aa in start_thread (arg=0x7f6869904700) at pthread_create.c:333
#6  0x00007f6876a2beed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f6858d05700 (LWP 21107)):
#0  0x00007f6877337ff3 in timerSourcePrepare (source=<optimized out>, timeout=0x7f6858d04c54) at kernel/qeventdispatcher_glib.cpp:161
#1  0x00007f68737353fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6873735de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6873735fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f6877338c6c in QEventDispatcherGlib::processEvents (this=0x7f68540008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007f68772dd3e2 in QEventLoop::exec (this=this@entry=0x7f6858d04e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f687709cb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007f6876067f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f68770a1b0e in QThreadPrivate::start (arg=0x26ab160) at thread/qthread_unix.cpp:337
#9  0x00007f6873c546aa in start_thread (arg=0x7f6858d05700) at pthread_create.c:333
#10 0x00007f6876a2beed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f68517b5700 (LWP 21108)):
#0  0x00007f6876a208dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f6873735ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6873735fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6877338c6c in QEventDispatcherGlib::processEvents (this=0x7f684c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f68772dd3e2 in QEventLoop::exec (this=this@entry=0x7f68517b4e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f687709cb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f6876067f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f68770a1b0e in QThreadPrivate::start (arg=0x2a7eeb0) at thread/qthread_unix.cpp:337
#8  0x00007f6873c546aa in start_thread (arg=0x7f68517b5700) at pthread_create.c:333
#9  0x00007f6876a2beed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f687a2a5780 (LWP 20947)):
[KCrash Handler]
#6  0x0000006500000065 in ?? ()
#7  0x00007f6875aec628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f6875aebd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f68530bdc9a in Plasma::FrameSvgItem::updatePaintNode (this=0x4da0840, oldNode=0x5d0a940) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f6875b3f4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f6875b404cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f6875b40d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f6875b0ff05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f6875b10979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f68780cbb2c in QApplicationPrivate::notify_helper (this=0x1aa9b10, receiver=0x25bcb30, e=0x7ffe08dd69d0) at kernel/qapplication.cpp:3720
#16 0x00007f68780d1000 in QApplication::notify (this=0x7ffe08dd6d40, receiver=0x25bcb30, e=0x7ffe08dd69d0) at kernel/qapplication.cpp:3503
#17 0x00007f68772dfc2b in QCoreApplication::notifyInternal (this=0x7ffe08dd6d40, receiver=0x25bcb30, event=event@entry=0x7ffe08dd69d0) at kernel/qcoreapplication.cpp:935
#18 0x00007f6877337ae5 in sendEvent (event=0x7ffe08dd69d0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x1af2140) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f6877337f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f6873735c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f6873735f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f6873735fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f6877338c57 in QEventDispatcherGlib::processEvents (this=0x1aed700, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f68772dd3e2 in QEventLoop::exec (this=this@entry=0x7ffe08dd6c20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f68772e502c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f6877b0631c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f68780c77a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-31 18:43:06 UTC

*** This bug has been marked as a duplicate of bug 345675 ***
Comment 2 Kristian Karl 2015-05-31 18:54:08 UTC
Some experimentation led to that:
If in folder $HOME/.local/share/aurorae/themes following themes are installed:
Air-black
air-oxygen
air-oxygen-color
glowglass-cupertino

The crash occurs every time for me.
Comment 3 Christoph Feck 2015-05-31 22:36:15 UTC
Why do you reopen this? It clearly is a duplicate.

*** This bug has been marked as a duplicate of bug 345675 ***
Comment 4 Kristian Karl 2015-06-01 04:39:29 UTC
I did not reopen. I added a comment. But by doing that, a [bugzilla] mid-air collision occurred. That led to the reopening, which was unintentional.
I'm fine with this bug being a duplicate of bug 345675.

But, looking at bug 345675, which in turn is a duplicate of bug 345660, the issue should have been fixed in April 8 in  kdeclarative. Should this fix not have propagated to users by now?
Comment 5 Christoph Feck 2015-06-01 08:56:10 UTC
Could you please check which version of kdeclarative you have installed? The fix is in version 5.10.
Comment 6 Kristian Karl 2015-06-01 09:13:02 UTC
Is it libkdeclarative5?

$> aptitude show libkdeclarative5                                                 
Package: libkdeclarative5                                                                                     
State: installed                                                                                              
Automatically installed: yes
Version: 4:4.14.6-4~ubuntu3.1
Priority: optional
Section: libs
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: amd64
Uncompressed Size: 275 k
Depends: libc6 (>= 2.14), libkdecore5 (= 4:4.14.6-4~ubuntu3.1), libkdeui5 (= 4:4.14.6-4~ubuntu3.1),
         libqt4-declarative (>= 4:4.8.0), libqt4-script (>= 4:4.8.0), libqtcore4 (>= 4:4.8.0), libqtgui4 (>=
         4:4.8.0), libstdc++6 (>= 4.1.1)
Conflicts: libkdeclarative5
Description: declarative library for plasma
 This library provides plasma bindings for Qt Quick 
 
 This package contains experimental software and should not be used in production environment 
 
 This package is part of the KDE Development Platform libraries module.
Homepage: http://www.kde.org/
Comment 7 Christoph Feck 2015-06-01 10:33:13 UTC
That is the KDE4 version of kdeclarative. For KF5 package names, please ask in a forum of your distribution.
Comment 8 Kristian Karl 2015-06-01 11:36:54 UTC
Oh, that is most peculiar. I'm running Kubuntu 15.04, installed from their ISO distribution.
I will ask some appropriate forum. Thanks