Bug 347531 - crash
Summary: crash
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-10 20:44 UTC by Pliachas Paschalis
Modified: 2015-05-16 17:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pliachas Paschalis 2015-05-10 20:44:46 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-16-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:was on system settings and try to edit application styles> window apearrence and when i scroll down to select a different apearrence it crashes

The crash can be reproduced sometimes.

-- Backtrace:
Application: Ρυθμίσεις συστήματος (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f0feacc0780 (LWP 7013))]

Thread 6 (Thread 0x7f0fda444700 (LWP 7014)):
#0  0x00007f0fe74318dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f0fe574bb72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f0fe574d64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f0fdc98f099 in QXcbEventReader::run (this=0x2400670) at qxcbconnection.cpp:1105
#4  0x00007f0fe7ab2b0e in QThreadPrivate::start (arg=0x2400670) at thread/qthread_unix.cpp:337
#5  0x00007f0fe46656aa in start_thread (arg=0x7f0fda444700) at pthread_create.c:333
#6  0x00007f0fe743ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f0fcf603700 (LWP 7015)):
#0  0x00007f0fe4146488 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f0fe4146de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0fe4147242 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0fd3d5fae6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f0fe416d955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f0fe46656aa in start_thread (arg=0x7f0fcf603700) at pthread_create.c:333
#6  0x00007f0fe743ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f0fcee02700 (LWP 7016)):
#0  0x00007f0fe418b7a4 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f0fe4146eb1 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0fe4146fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0fe4147009 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f0fe416d955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f0fe46656aa in start_thread (arg=0x7f0fcee02700) at pthread_create.c:333
#6  0x00007f0fe743ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f0fcde00700 (LWP 7019)):
#0  0x00007f0fe74318dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f0fe4146ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0fe4146fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0fe7d49c6c in QEventDispatcherGlib::processEvents (this=0x7f0fb40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f0fe7cee3e2 in QEventLoop::exec (this=this@entry=0x7f0fcddffe20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f0fe7aadb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f0fe6a78f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f0fe7ab2b0e in QThreadPrivate::start (arg=0x312a350) at thread/qthread_unix.cpp:337
#8  0x00007f0fe46656aa in start_thread (arg=0x7f0fcde00700) at pthread_create.c:333
#9  0x00007f0fe743ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f0fae44e700 (LWP 7020)):
#0  0x00007f0fe418b789 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f0fe4146409 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0fe4146de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0fe4146fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f0fe7d49c6c in QEventDispatcherGlib::processEvents (this=0x7f0fa80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007f0fe7cee3e2 in QEventLoop::exec (this=this@entry=0x7f0fae44de20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f0fe7aadb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007f0fe6a78f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f0fe7ab2b0e in QThreadPrivate::start (arg=0x4a97c30) at thread/qthread_unix.cpp:337
#9  0x00007f0fe46656aa in start_thread (arg=0x7f0fae44e700) at pthread_create.c:333
#10 0x00007f0fe743ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f0feacc0780 (LWP 7013)):
[KCrash Handler]
#6  0x0000000000000100 in ?? ()
#7  0x00007f0fe64fd628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f0fe64fcd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f0fb0294c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x6e35bc0, oldNode=0x70ae210) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f0fe65504bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f0fe65514cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f0fe6551d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f0fe6520f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f0fe6521979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f0fe8adcb2c in QApplicationPrivate::notify_helper (this=0x23e9b10, receiver=0x2fef510, e=0x7ffc0e568c70) at kernel/qapplication.cpp:3720
#16 0x00007f0fe8ae2000 in QApplication::notify (this=0x7ffc0e568fe0, receiver=0x2fef510, e=0x7ffc0e568c70) at kernel/qapplication.cpp:3503
#17 0x00007f0fe7cf0c2b in QCoreApplication::notifyInternal (this=0x7ffc0e568fe0, receiver=0x2fef510, event=event@entry=0x7ffc0e568c70) at kernel/qcoreapplication.cpp:935
#18 0x00007f0fe7d48ae5 in sendEvent (event=0x7ffc0e568c70, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x23e5d80) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f0fe7d48f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f0fe4146c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f0fe4146f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f0fe4146fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f0fe7d49c57 in QEventDispatcherGlib::processEvents (this=0x23e5c00, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f0fe7cee3e2 in QEventLoop::exec (this=this@entry=0x7ffc0e568ec0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f0fe7cf602c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f0fe851731c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f0fe8ad87a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-16 17:00:47 UTC

*** This bug has been marked as a duplicate of bug 345675 ***