Bug 353265 - System Settings Crash
Summary: System Settings Crash
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-09-28 08:09 UTC by Tassos Vallas
Modified: 2015-10-10 21:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tassos Vallas 2015-09-28 08:09:45 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-28-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:

In System Settings -> Application Style -> Window Decorations, when scrolling to select decorations, application terminates.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7faacabf2780 (LWP 4272))]

Thread 4 (Thread 0x7faaba36a700 (LWP 4273)):
#0  0x00007faac73568dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007faac5670b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007faac567264f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007faabc8b5099 in QXcbEventReader::run (this=0x160d320) at qxcbconnection.cpp:1105
#4  0x00007faac79d7b0e in QThreadPrivate::start (arg=0x160d320) at thread/qthread_unix.cpp:337
#5  0x00007faac458a6aa in start_thread (arg=0x7faaba36a700) at pthread_create.c:333
#6  0x00007faac7361eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7faaa9d21700 (LWP 4274)):
#0  0x00007ffcb7ad0cee in clock_gettime ()
#1  0x00007faac737038d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007faac7a8dcb6 in qt_clock_gettime (ts=0x7faaa9d20b80, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:161
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:170
#5  0x00007faac7c6c639 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7faaa4002ed0) at kernel/qtimerinfo_unix.cpp:84
#6  0x00007faac7c6cba5 in QTimerInfoList::timerWait (this=0x7faaa4002ed0, tm=...) at kernel/qtimerinfo_unix.cpp:379
#7  0x00007faac7c6e03e in timerSourcePrepareHelper (timeout=0x7faaa9d20c54, src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:127
#8  timerSourcePrepare (source=<optimized out>, timeout=0x7faaa9d20c54) at kernel/qeventdispatcher_glib.cpp:160
#9  0x00007faac406b3fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007faac406bde8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007faac406bfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007faac7c6ec6c in QEventDispatcherGlib::processEvents (this=0x7faaa40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#13 0x00007faac7c133e2 in QEventLoop::exec (this=this@entry=0x7faaa9d20e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#14 0x00007faac79d2b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#15 0x00007faac699df65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#16 0x00007faac79d7b0e in QThreadPrivate::start (arg=0x1b05420) at thread/qthread_unix.cpp:337
#17 0x00007faac458a6aa in start_thread (arg=0x7faaa9d21700) at pthread_create.c:333
#18 0x00007faac7361eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7faaa274e700 (LWP 4275)):
#0  0x00007faac406beb1 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007faac406bfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007faac7c6ec6c in QEventDispatcherGlib::processEvents (this=0x7faa9c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#3  0x00007faac7c133e2 in QEventLoop::exec (this=this@entry=0x7faaa274de20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#4  0x00007faac79d2b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#5  0x00007faac699df65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#6  0x00007faac79d7b0e in QThreadPrivate::start (arg=0x1dd6ee0) at thread/qthread_unix.cpp:337
#7  0x00007faac458a6aa in start_thread (arg=0x7faaa274e700) at pthread_create.c:333
#8  0x00007faac7361eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7faacabf2780 (LWP 4272)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007faac6422628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007faac6421d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007faaa871bc9a in Plasma::FrameSvgItem::updatePaintNode (this=0x20aa350, oldNode=0x48eaa40) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007faac64754bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007faac64764cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007faac6476d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007faac6445f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007faac6446979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007faac8a01b2c in QApplicationPrivate::notify_helper (this=0x15f5b10, receiver=0x1affef0, e=0x7ffcb7a97f50) at kernel/qapplication.cpp:3720
#16 0x00007faac8a07000 in QApplication::notify (this=0x7ffcb7a982c0, receiver=0x1affef0, e=0x7ffcb7a97f50) at kernel/qapplication.cpp:3503
#17 0x00007faac7c15c2b in QCoreApplication::notifyInternal (this=0x7ffcb7a982c0, receiver=0x1affef0, event=event@entry=0x7ffcb7a97f50) at kernel/qcoreapplication.cpp:935
#18 0x00007faac7c6dae5 in sendEvent (event=0x7ffcb7a97f50, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x1638260) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007faac7c6df61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007faac406bc3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007faac406bf20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007faac406bfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007faac7c6ec57 in QEventDispatcherGlib::processEvents (this=0x1625850, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007faac7c133e2 in QEventLoop::exec (this=this@entry=0x7ffcb7a981a0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007faac7c1b02c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007faac843c31c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007faac89fd7a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-10-10 21:37:40 UTC

*** This bug has been marked as a duplicate of bug 345675 ***