Bug 348028 - KDE-Control Center crashes after theme and window activation change
Summary: KDE-Control Center crashes after theme and window activation change
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-20 21:03 UTC by stef_eck
Modified: 2015-05-23 14:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stef_eck 2015-05-20 21:03:06 UTC
Application: kdeinit5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-16-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
I wanted to start it by clicking on the "further actions..." option, appearing when clicking the header of any window header.

- Unusual behavior I noticed:
I needed to try this, as K-Menu doesn't open as well.
When clicking on it, a window seems toopen, but doens't appear completey. Stays trsnaparent for just a second and disappears again.

- Custom settings of the application:
Before this happended I downloaded and installed the FormaN (or something like this) theme to change my window decoration.
And I switched the level of how sharp it should be hindered to activate a window accidentally to 'Extreme' instaed of 'Medium' before.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE-Kontrollmodul (kdeinit5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f6496d61780 (LWP 2031))]

Thread 5 (Thread 0x7f6482001700 (LWP 2032)):
#0  0x00007f64954578dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f649394eb72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f649395064f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f6483f25099 in QXcbEventReader::run (this=0x8a6e90) at qxcbconnection.cpp:1105
#4  0x00007f64957c9b0e in QThreadPrivate::start (arg=0x8a6e90) at thread/qthread_unix.cpp:337
#5  0x00007f64930a26aa in start_thread (arg=0x7f6482001700) at pthread_create.c:333
#6  0x00007f6495462eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f6477b80700 (LWP 2033)):
#0  0x00007ffe6d920c2e in clock_gettime ()
#1  0x00007f649547138d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007f649587fcb6 in qt_clock_gettime (ts=0x7f6477b7fb80, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:161
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:170
#5  0x00007f6495a5e639 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f6470002ed0) at kernel/qtimerinfo_unix.cpp:84
#6  0x00007f6495a5eba5 in QTimerInfoList::timerWait (this=0x7f6470002ed0, tm=...) at kernel/qtimerinfo_unix.cpp:379
#7  0x00007f6495a6003e in timerSourcePrepareHelper (timeout=0x7f6477b7fc54, src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:127
#8  timerSourcePrepare (source=<optimized out>, timeout=0x7f6477b7fc54) at kernel/qeventdispatcher_glib.cpp:160
#9  0x00007f64926453fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f6492645de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f6492645fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f6495a60c6c in QEventDispatcherGlib::processEvents (this=0x7f64700008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#13 0x00007f6495a053e2 in QEventLoop::exec (this=this@entry=0x7f6477b7fe20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#14 0x00007f64957c4b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#15 0x00007f64864adf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#16 0x00007f64957c9b0e in QThreadPrivate::start (arg=0xa36c50) at thread/qthread_unix.cpp:337
#17 0x00007f64930a26aa in start_thread (arg=0x7f6477b80700) at pthread_create.c:333
#18 0x00007f6495462eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f646f991700 (LWP 2034)):
#0  0x00007ffe6d920c2e in clock_gettime ()
#1  0x00007f649547138d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007f649587fcb6 in qt_clock_gettime (ts=0x7f646f990b80, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:161
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:170
#5  0x00007f6495a5e639 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f6468002cd0) at kernel/qtimerinfo_unix.cpp:84
#6  0x00007f6495a5eba5 in QTimerInfoList::timerWait (this=0x7f6468002cd0, tm=...) at kernel/qtimerinfo_unix.cpp:379
#7  0x00007f6495a6003e in timerSourcePrepareHelper (timeout=0x7f646f990c54, src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:127
#8  timerSourcePrepare (source=<optimized out>, timeout=0x7f646f990c54) at kernel/qeventdispatcher_glib.cpp:160
#9  0x00007f64926453fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f6492645de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f6492645fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f6495a60c6c in QEventDispatcherGlib::processEvents (this=0x7f64680008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#13 0x00007f6495a053e2 in QEventLoop::exec (this=this@entry=0x7f646f990e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#14 0x00007f64957c4b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#15 0x00007f64864adf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#16 0x00007f64957c9b0e in QThreadPrivate::start (arg=0x1046ad0) at thread/qthread_unix.cpp:337
#17 0x00007f64930a26aa in start_thread (arg=0x7f646f991700) at pthread_create.c:333
#18 0x00007f6495462eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f646cddb700 (LWP 2035)):
#0  0x00007ffe6d920c2e in clock_gettime ()
#1  0x00007f649547138d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007f649587fcb6 in qt_clock_gettime (ts=0x7f646cddab80, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:161
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:170
#5  0x00007f6495a5e639 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f6460002ed0) at kernel/qtimerinfo_unix.cpp:84
#6  0x00007f6495a5eba5 in QTimerInfoList::timerWait (this=0x7f6460002ed0, tm=...) at kernel/qtimerinfo_unix.cpp:379
#7  0x00007f6495a6003e in timerSourcePrepareHelper (timeout=0x7f646cddac54, src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:127
#8  timerSourcePrepare (source=<optimized out>, timeout=0x7f646cddac54) at kernel/qeventdispatcher_glib.cpp:160
#9  0x00007f64926453fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f6492645de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f6492645fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f6495a60c6c in QEventDispatcherGlib::processEvents (this=0x7f64600008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#13 0x00007f6495a053e2 in QEventLoop::exec (this=this@entry=0x7f646cddae20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#14 0x00007f64957c4b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#15 0x00007f64864adf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#16 0x00007f64957c9b0e in QThreadPrivate::start (arg=0x13d2c10) at thread/qthread_unix.cpp:337
#17 0x00007f64930a26aa in start_thread (arg=0x7f646cddb700) at pthread_create.c:333
#18 0x00007f6495462eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f6496d61780 (LWP 2031)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f6485f32628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f6485f31d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f647662ac9a in Plasma::FrameSvgItem::updatePaintNode (this=0x36048a0, oldNode=0x38875a0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f6485f854bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f6485f864cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f6485f86d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f6485f55f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f6485f56979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f6493ec5b2c in QApplicationPrivate::notify_helper (this=0x8928f0, receiver=0xa2c940, e=0x7ffe6d8ff590) at kernel/qapplication.cpp:3720
#16 0x00007f6493ecb000 in QApplication::notify (this=0x7ffe6d8ff960, receiver=0xa2c940, e=0x7ffe6d8ff590) at kernel/qapplication.cpp:3503
#17 0x00007f6495a07c2b in QCoreApplication::notifyInternal (this=0x7ffe6d8ff960, receiver=0xa2c940, event=event@entry=0x7ffe6d8ff590) at kernel/qcoreapplication.cpp:935
#18 0x00007f6495a5fae5 in sendEvent (event=0x7ffe6d8ff590, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x8c20a0) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f6495a5ff61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f6492645c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f6492645f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f6492645fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f6495a60c57 in QEventDispatcherGlib::processEvents (this=0x8d4bb0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f6495a053e2 in QEventLoop::exec (this=this@entry=0x7ffe6d8ff7f0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f64940c74b5 in QDialog::exec (this=0x9b4460) at dialogs/qdialog.cpp:541
#27 0x00007f64858869cb in kdemain (_argc=<optimized out>, _argv=<optimized out>) at ../../kcmshell/main.cpp:307
#28 0x0000000000408716 in launch (argc=argc@entry=14, _name=_name@entry=0x878908 "kcmshell5", args=<optimized out>, args@entry=0x878912 "--icon", cwd=cwd@entry=0x0, envc=envc@entry=0, envs=<optimized out>, envs@entry=0x8789c6 "", reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40b710 "0") at ../../../src/kdeinit/kinit.cpp:741
#29 0x000000000040a132 in handle_launcher_request (sock=7, who=who@entry=0x40b6c6 "launcher") at ../../../src/kdeinit/kinit.cpp:1180
#30 0x000000000040a6ee in handle_requests (waitForPid=waitForPid@entry=0) at ../../../src/kdeinit/kinit.cpp:1369
#31 0x000000000040501b in main (argc=1, argv=<optimized out>) at ../../../src/kdeinit/kinit.cpp:1860

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-23 14:35:59 UTC

*** This bug has been marked as a duplicate of bug 345675 ***