Bug 353979 - Executable: systemsettings5 PID: 14128 Signal: Segmentation fault (11) Time: 16.10.15 21:33:38
Summary: Executable: systemsettings5 PID: 14128 Signal: Segmentation fault (11) Time: ...
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-10-16 18:41 UTC by amfabc
Modified: 2015-10-21 20:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description amfabc 2015-10-16 18:41:33 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-30-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
when you start the system settings> application design> window decoration

The crash can be reproduced every time.

-- Backtrace:
Application: Параметры системы (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7f00d109e780 (LWP 13282))]

Thread 5 (Thread 0x7f00be84a700 (LWP 13283)):
#0  0x00007f00cd80b8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f00cbb25b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f00cbb2764f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f00c1607099 in QXcbEventReader::run (this=0xd6e190) at qxcbconnection.cpp:1105
#4  0x00007f00cde8cb0e in QThreadPrivate::start (arg=0xd6e190) at thread/qthread_unix.cpp:337
#5  0x00007f00caa3f6aa in start_thread (arg=0x7f00be84a700) at pthread_create.c:333
#6  0x00007f00cd816eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f00af65f700 (LWP 13286)):
#0  0x00007f00ca5657a4 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f00ca520d6d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f00ca520fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f00ce123c6c in QEventDispatcherGlib::processEvents (this=0x7f00a80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f00ce0c83e2 in QEventLoop::exec (this=this@entry=0x7f00af65ee20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f00cde87b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f00cce52f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f00cde8cb0e in QThreadPrivate::start (arg=0x14177e0) at thread/qthread_unix.cpp:337
#8  0x00007f00caa3f6aa in start_thread (arg=0x7f00af65f700) at pthread_create.c:333
#9  0x00007f00cd816eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f00a7b16700 (LWP 13287)):
#0  0x00007f00cd80b8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f00ca520ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f00ca520fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f00ce123c6c in QEventDispatcherGlib::processEvents (this=0x7f00a00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f00ce0c83e2 in QEventLoop::exec (this=this@entry=0x7f00a7b15e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f00cde87b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f00cce52f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f00cde8cb0e in QThreadPrivate::start (arg=0x1685000) at thread/qthread_unix.cpp:337
#8  0x00007f00caa3f6aa in start_thread (arg=0x7f00a7b16700) at pthread_create.c:333
#9  0x00007f00cd816eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f00a584d700 (LWP 13288)):
[KCrash Handler]
#6  0x0000000000000070 in ?? ()
#7  0x00007f00cc8d7628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f00cc8d6d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f00ae004c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x29d84c0, oldNode=0x7f00999beb70) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f00cc92a4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f00cc92b4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f00cc92bd80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f00cc8fd1dd in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f00cc8fe0a1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f00cc8ff360 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#16 0x00007f00cde8cb0e in QThreadPrivate::start (arg=0x1e5a590) at thread/qthread_unix.cpp:337
#17 0x00007f00caa3f6aa in start_thread (arg=0x7f00a584d700) at pthread_create.c:333
#18 0x00007f00cd816eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f00d109e780 (LWP 13282)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f00cde8dc6b in wait (time=18446744073709551615, this=0x19cd170) at thread/qwaitcondition_unix.cpp:128
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1e5a5d0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:200
#3  0x00007f00cc900c48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#4  0x00007f00cc901cad in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007f00ceeb6b2c in QApplicationPrivate::notify_helper (this=0xd41430, receiver=0x116b7b0, e=0x7ffd13fa5710) at kernel/qapplication.cpp:3720
#6  0x00007f00ceebc000 in QApplication::notify (this=0x7ffd13fa5a80, receiver=0x116b7b0, e=0x7ffd13fa5710) at kernel/qapplication.cpp:3503
#7  0x00007f00ce0cac2b in QCoreApplication::notifyInternal (this=0x7ffd13fa5a80, receiver=0x116b7b0, event=event@entry=0x7ffd13fa5710) at kernel/qcoreapplication.cpp:935
#8  0x00007f00ce122ae5 in sendEvent (event=0x7ffd13fa5710, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#9  QTimerInfoList::activateTimers (this=0xdb8990) at kernel/qtimerinfo_unix.cpp:635
#10 0x00007f00ce122f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#11 0x00007f00ca520c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f00ca520f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007f00ca520fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#14 0x00007f00ce123c57 in QEventDispatcherGlib::processEvents (this=0xdb1f10, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#15 0x00007f00ce0c83e2 in QEventLoop::exec (this=this@entry=0x7ffd13fa5960, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#16 0x00007f00ce0d002c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#17 0x00007f00ce8f131c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#18 0x00007f00ceeb27a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#19 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-10-21 20:29:22 UTC

*** This bug has been marked as a duplicate of bug 345675 ***