Bug 349716 - KDE Settings crash when changing window decorations
Summary: KDE Settings crash when changing window decorations
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-06-29 14:50 UTC by Danas
Modified: 2015-07-10 14:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Danas 2015-06-29 14:50:28 UTC
Application: systemsettings5 (5.3.1)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-21-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
Hello! 

I installed Forma-N window decoration and activated it. Now whenever I enter window decoration settings, it crashes.

 Forma-N decoration work well though. 

Kind regards.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7f1fa7dfe780 (LWP 20989))]

Thread 5 (Thread 0x7f1f954d8700 (LWP 20990)):
#0  0x00007f1fa45698dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f1fa2883b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f1fa288564f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f1f98293099 in QXcbEventReader::run (this=0x19209b0) at qxcbconnection.cpp:1105
#4  0x00007f1fa4beab0e in QThreadPrivate::start (arg=0x19209b0) at thread/qthread_unix.cpp:337
#5  0x00007f1fa179d6aa in start_thread (arg=0x7f1f954d8700) at pthread_create.c:333
#6  0x00007f1fa4574eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f1f86032700 (LWP 20995)):
#0  0x00007f1fa45698dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f1fa127eebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1fa127efcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1fa4e81c6c in QEventDispatcherGlib::processEvents (this=0x7f1f800008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f1fa4e263e2 in QEventLoop::exec (this=this@entry=0x7f1f86031e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f1fa4be5b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f1fa3bb0f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f1fa4beab0e in QThreadPrivate::start (arg=0x1cec3b0) at thread/qthread_unix.cpp:337
#8  0x00007f1fa179d6aa in start_thread (arg=0x7f1f86032700) at pthread_create.c:333
#9  0x00007f1fa4574eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f1f7e3a1700 (LWP 20996)):
#0  0x00007f1fa456549d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f1f9d6e5f45 in ?? () from /usr/lib/nvidia-346/tls/libnvidia-tls.so.346.59
#2  0x00007f1fa12c22f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1fa127e96c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f1fa127ee60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f1fa127efcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f1fa4e81c6c in QEventDispatcherGlib::processEvents (this=0x7f1f780008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#7  0x00007f1fa4e263e2 in QEventLoop::exec (this=this@entry=0x7f1f7e3a0e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#8  0x00007f1fa4be5b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#9  0x00007f1fa3bb0f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#10 0x00007f1fa4beab0e in QThreadPrivate::start (arg=0x2298ae0) at thread/qthread_unix.cpp:337
#11 0x00007f1fa179d6aa in start_thread (arg=0x7f1f7e3a1700) at pthread_create.c:333
#12 0x00007f1fa4574eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f1f675c6700 (LWP 21014)):
[KCrash Handler]
#6  0x0000000000000070 in ?? ()
#7  0x00007f1fa3635628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f1fa3634d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f1f84494c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x3577290, oldNode=0x7f1f591078c0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f1fa36884bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f1fa36894cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f1fa3689d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f1fa365b1dd in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f1fa365c0a1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f1fa365d360 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#16 0x00007f1fa4beab0e in QThreadPrivate::start (arg=0x28e7d00) at thread/qthread_unix.cpp:337
#17 0x00007f1fa179d6aa in start_thread (arg=0x7f1f675c6700) at pthread_create.c:333
#18 0x00007f1fa4574eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f1fa7dfe780 (LWP 20989)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f1fa4bebc6b in wait (time=18446744073709551615, this=0x21bfa30) at thread/qwaitcondition_unix.cpp:128
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x28e7d40, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:200
#3  0x00007f1fa365ec48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#4  0x00007f1fa365fcad in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007f1fa5c14b2c in QApplicationPrivate::notify_helper (this=0x18f2550, receiver=0x1b2dee0, e=0x7ffc8332c910) at kernel/qapplication.cpp:3720
#6  0x00007f1fa5c1a000 in QApplication::notify (this=0x7ffc8332cc80, receiver=0x1b2dee0, e=0x7ffc8332c910) at kernel/qapplication.cpp:3503
#7  0x00007f1fa4e28c2b in QCoreApplication::notifyInternal (this=0x7ffc8332cc80, receiver=0x1b2dee0, event=event@entry=0x7ffc8332c910) at kernel/qcoreapplication.cpp:935
#8  0x00007f1fa4e80ae5 in sendEvent (event=0x7ffc8332c910, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#9  QTimerInfoList::activateTimers (this=0x195f680) at kernel/qtimerinfo_unix.cpp:635
#10 0x00007f1fa4e80f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#11 0x00007f1fa127ec3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f1fa127ef20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007f1fa127efcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#14 0x00007f1fa4e81c57 in QEventDispatcherGlib::processEvents (this=0x1964a40, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#15 0x00007f1fa4e263e2 in QEventLoop::exec (this=this@entry=0x7ffc8332cb60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#16 0x00007f1fa4e2e02c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#17 0x00007f1fa564f31c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#18 0x00007f1fa5c107a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#19 0x000000000040ef6b in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:55

Reported using DrKonqi
Comment 1 Christoph Feck 2015-07-10 14:16:17 UTC

*** This bug has been marked as a duplicate of bug 345675 ***