Bug 348291 - Settings crashed after downloading new "window style"
Summary: Settings crashed after downloading new "window style"
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-27 07:48 UTC by Jungchu Hsu
Modified: 2015-05-31 13:52 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jungchu Hsu 2015-05-27 07:48:24 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-18-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:

1. Launch "Window Style"
2. Choose "Get new ..."
3. Try to download new window styles (I download 5 actually)
4. Click close.
5. Crashed.

After downloaded, you can simply select one of the window style, and click "Apply". It will crashed, too.

The crash can be reproduced every time.

-- Backtrace:
Application: 系統設定 (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9ba8cc7780 (LWP 6610))]

Thread 4 (Thread 0x7f9b98405700 (LWP 6612)):
#0  0x00007f9ba54318dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f9ba374bb72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f9ba374d64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f9b9a950099 in QXcbEventReader::run (this=0x1eec4d0) at qxcbconnection.cpp:1105
#4  0x00007f9ba5ab2b0e in QThreadPrivate::start (arg=0x1eec4d0) at thread/qthread_unix.cpp:337
#5  0x00007f9ba26656aa in start_thread (arg=0x7f9b98405700) at pthread_create.c:333
#6  0x00007f9ba543ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f9b87a21700 (LWP 6647)):
#0  0x00007f9ba5aaae0f in testAndSetRelaxed<QMutexData*> (currentValue=<synthetic pointer>, newValue=0x0, expectedValue=0x1, _q_value=@0x22b5d18: 0x0) at ../../include/QtCore/../../src/corelib/arch/qatomic_x86.h:259
#1  testAndSetRelease<QMutexData*, QMutexData*> (currentValue=<synthetic pointer>, newValue=0x0, expectedValue=0x1, _q_value=@0x22b5d18: 0x0) at ../../include/QtCore/../../src/corelib/thread/qgenericatomic.h:175
#2  testAndSetRelease (currentValue=<synthetic pointer>, newValue=0x0, expectedValue=0x1, this=this@entry=0x22b5d18) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:272
#3  fastTryUnlock (current=<synthetic pointer>, this=this@entry=0x22b5d18) at thread/qmutex.h:85
#4  QMutex::unlock (this=this@entry=0x22b5d18) at thread/qmutex.cpp:264
#5  0x00007f9ba5d491ed in unlock (this=<synthetic pointer>) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:138
#6  ~QMutexLocker (this=<synthetic pointer>, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:132
#7  canWaitLocked (this=0x22b5cf0) at ../../include/QtCore/5.4.1/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:244
#8  postEventSourcePrepare (s=0x7f9b800012d0, timeout=0x7f9b87a20c54) at kernel/qeventdispatcher_glib.cpp:254
#9  0x00007f9ba21463fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f9ba2146de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f9ba2146fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f9ba5d49c6c in QEventDispatcherGlib::processEvents (this=0x7f9b800008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#13 0x00007f9ba5cee3e2 in QEventLoop::exec (this=this@entry=0x7f9b87a20e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#14 0x00007f9ba5aadb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#15 0x00007f9ba4a78f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#16 0x00007f9ba5ab2b0e in QThreadPrivate::start (arg=0x22a8e30) at thread/qthread_unix.cpp:337
#17 0x00007f9ba26656aa in start_thread (arg=0x7f9b87a21700) at pthread_create.c:333
#18 0x00007f9ba543ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f9b7ffff700 (LWP 6648)):
#0  0x00007f9ba5aaa9ca in testAndSetRelaxed<QMutexData*> (currentValue=<synthetic pointer>, newValue=0x1, expectedValue=0x0, _q_value=@0x25e8398: 0x1) at ../../include/QtCore/../../src/corelib/arch/qatomic_x86.h:259
#1  testAndSetAcquire<QMutexData*, QMutexData*> (currentValue=<synthetic pointer>, newValue=0x1, expectedValue=0x0, _q_value=@0x25e8398: 0x1) at ../../include/QtCore/../../src/corelib/thread/qgenericatomic.h:166
#2  testAndSetAcquire (currentValue=<synthetic pointer>, newValue=0x1, expectedValue=0x0, this=0x25e8398, this@entry=0x1) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:270
#3  fastTryLock (current=<synthetic pointer>, this=0x25e8398, this@entry=0x1) at thread/qmutex.h:82
#4  QMutex::lock (this=this@entry=0x25e8398) at thread/qmutex.cpp:212
#5  0x00007f9ba5d491db in QMutexLocker (m=0x25e8398, this=<synthetic pointer>) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:128
#6  canWaitLocked (this=0x25e8370) at ../../include/QtCore/5.4.1/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:243
#7  postEventSourcePrepare (s=0x7f9b780012d0, timeout=0x7f9b7fffec54) at kernel/qeventdispatcher_glib.cpp:254
#8  0x00007f9ba21463fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f9ba2146de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f9ba2146fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f9ba5d49c6c in QEventDispatcherGlib::processEvents (this=0x7f9b780008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#12 0x00007f9ba5cee3e2 in QEventLoop::exec (this=this@entry=0x7f9b7fffee20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#13 0x00007f9ba5aadb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#14 0x00007f9ba4a78f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#15 0x00007f9ba5ab2b0e in QThreadPrivate::start (arg=0x25f8ca0) at thread/qthread_unix.cpp:337
#16 0x00007f9ba26656aa in start_thread (arg=0x7f9b7ffff700) at pthread_create.c:333
#17 0x00007f9ba543ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f9ba8cc7780 (LWP 6610)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f9ba44fd628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f9ba44fcd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f9b863fbc9a in Plasma::FrameSvgItem::updatePaintNode (this=0x2a46550, oldNode=0x5044f70) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f9ba45504bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f9ba45514cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f9ba4551d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f9ba4520f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f9ba4522016 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f9ba65287b5 in QWindow::event (this=0x22a7c50, ev=<optimized out>) at kernel/qwindow.cpp:2051
#16 0x00007f9ba455bdd3 in QQuickWindow::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#17 0x00007f9ba6adcb2c in QApplicationPrivate::notify_helper (this=0x1ed5b10, receiver=0x22a7c50, e=0x7fffa69972d0) at kernel/qapplication.cpp:3720
#18 0x00007f9ba6ae2000 in QApplication::notify (this=0x7fffa69976d0, receiver=0x22a7c50, e=0x7fffa69972d0) at kernel/qapplication.cpp:3503
#19 0x00007f9ba5cf0c2b in QCoreApplication::notifyInternal (this=0x7fffa69976d0, receiver=receiver@entry=0x22a7c50, event=event@entry=0x7fffa69972d0) at kernel/qcoreapplication.cpp:935
#20 0x00007f9ba6520e86 in sendSpontaneousEvent (event=0x7fffa69972d0, receiver=0x22a7c50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#21 QGuiApplicationPrivate::processExposeEvent (e=0x5b47ac0) at kernel/qguiapplication.cpp:2613
#22 0x00007f9ba6521bbd in QGuiApplicationPrivate::processWindowSystemEvent (e=e@entry=0x5b47ac0) at kernel/qguiapplication.cpp:1638
#23 0x00007f9ba650634f in QWindowSystemInterface::sendWindowSystemEvents (flags=...) at kernel/qwindowsysteminterface.cpp:572
#24 0x00007f9b9a97a590 in userEventSourceDispatch (source=<optimized out>) at eventdispatchers/qeventdispatcher_glib.cpp:70
#25 0x00007f9ba2146c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f9ba2146f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f9ba2146fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f9ba5d49c57 in QEventDispatcherGlib::processEvents (this=0x1f11d90, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#29 0x00007f9ba5cee3e2 in QEventLoop::exec (this=this@entry=0x7fffa69975b0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#30 0x00007f9ba5cf602c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#31 0x00007f9ba651731c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#32 0x00007f9ba6ad87a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#33 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-31 13:52:14 UTC

*** This bug has been marked as a duplicate of bug 345675 ***