Bug 352606 - windows decorations constant crashes
Summary: windows decorations constant crashes
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-09-12 08:36 UTC by Lint
Modified: 2015-09-14 09:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lint 2015-09-12 08:36:43 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-28-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
Installing new window decorations, one decoration must triggering constant crashes now
- Custom settings of the application:
was modifying decorations.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa3cd216780 (LWP 1892))]

Thread 4 (Thread 0x7fa3bc98e700 (LWP 1893)):
#0  0x00007fa3c99798dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fa3c7c93b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fa3c7c9564f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fa3beed9099 in QXcbEventReader::run (this=0x7d2350) at qxcbconnection.cpp:1105
#4  0x00007fa3c9ffab0e in QThreadPrivate::start (arg=0x7d2350) at thread/qthread_unix.cpp:337
#5  0x00007fa3c6bad6aa in start_thread (arg=0x7fa3bc98e700) at pthread_create.c:333
#6  0x00007fa3c9984eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fa3ac5dc700 (LWP 1894)):
#0  QElapsedTimer::clockType () at tools/qelapsedtimer_unix.cpp:155
#1  0x00007fa3ca0b0c79 in QElapsedTimer::isMonotonic () at tools/qelapsedtimer_unix.cpp:150
#2  0x00007fa3ca28fb3e in QTimerInfoList::repairTimersIfNeeded (this=0x7fa3a4002ed0) at kernel/qtimerinfo_unix.cpp:155
#3  0x00007fa3ca28fbb3 in QTimerInfoList::timerWait (this=0x7fa3a4002ed0, tm=...) at kernel/qtimerinfo_unix.cpp:380
#4  0x00007fa3ca29103e in timerSourcePrepareHelper (timeout=0x7fa3ac5dbc54, src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:127
#5  timerSourcePrepare (source=<optimized out>, timeout=0x7fa3ac5dbc54) at kernel/qeventdispatcher_glib.cpp:160
#6  0x00007fa3c668e3fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007fa3c668ede8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007fa3c668efcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007fa3ca291c6c in QEventDispatcherGlib::processEvents (this=0x7fa3a40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#10 0x00007fa3ca2363e2 in QEventLoop::exec (this=this@entry=0x7fa3ac5dbe20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#11 0x00007fa3c9ff5b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#12 0x00007fa3c8fc0f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#13 0x00007fa3c9ffab0e in QThreadPrivate::start (arg=0x11fc260) at thread/qthread_unix.cpp:337
#14 0x00007fa3c6bad6aa in start_thread (arg=0x7fa3ac5dc700) at pthread_create.c:333
#15 0x00007fa3c9984eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fa3a9106700 (LWP 1895)):
#0  0x00007fa3c99798dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fa3c668eebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa3c668efcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa3ca291c6c in QEventDispatcherGlib::processEvents (this=0x7fa39c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fa3ca2363e2 in QEventLoop::exec (this=this@entry=0x7fa3a9105e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fa3c9ff5b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fa3c8fc0f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fa3c9ffab0e in QThreadPrivate::start (arg=0x2b37f20) at thread/qthread_unix.cpp:337
#8  0x00007fa3c6bad6aa in start_thread (arg=0x7fa3a9106700) at pthread_create.c:333
#9  0x00007fa3c9984eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fa3cd216780 (LWP 1892)):
[KCrash Handler]
#6  0x0000000000000070 in ?? ()
#7  0x00007fa3c8a45628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fa3c8a44d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007fa3aaff6c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x4158300, oldNode=0x4279f00) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007fa3c8a984bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fa3c8a994cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fa3c8a99d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fa3c8a68f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fa3c8a69979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007fa3cb024b2c in QApplicationPrivate::notify_helper (this=0x7b9b10, receiver=0x11d3640, e=0x7ffd8959eec0) at kernel/qapplication.cpp:3720
#16 0x00007fa3cb02a000 in QApplication::notify (this=0x7ffd8959f230, receiver=0x11d3640, e=0x7ffd8959eec0) at kernel/qapplication.cpp:3503
#17 0x00007fa3ca238c2b in QCoreApplication::notifyInternal (this=0x7ffd8959f230, receiver=0x11d3640, event=event@entry=0x7ffd8959eec0) at kernel/qcoreapplication.cpp:935
#18 0x00007fa3ca290ae5 in sendEvent (event=0x7ffd8959eec0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x7f9ae0) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007fa3ca290f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007fa3c668ec3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fa3c668ef20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fa3c668efcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fa3ca291c57 in QEventDispatcherGlib::processEvents (this=0x7f8e20, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007fa3ca2363e2 in QEventLoop::exec (this=this@entry=0x7ffd8959f110, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007fa3ca23e02c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007fa3caa5f31c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007fa3cb0207a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-09-14 09:44:49 UTC

*** This bug has been marked as a duplicate of bug 345675 ***