Bug 349518 - permanent crash after download of windows decorations
Summary: permanent crash after download of windows decorations
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-06-23 08:39 UTC by Robert KOFLER
Modified: 2015-06-23 22:33 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert KOFLER 2015-06-23 08:39:26 UTC
Application: systemsettings5 (5.3.1)

Qt Version: 5.4.1
Operating System: Linux 4.0.5-040005-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
I want to open window decoration.

- Custom settings of the application:
before I download new windows decorations (sorry, as it crashes everytime I cannot provide name of downloaded decoration files, I selected the 6 top downloaded ones)

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7f5898cba780 (LWP 5529))]

Thread 7 (Thread 0x7f58865c2700 (LWP 5530)):
#0  0x00007f58954318dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f589374bb72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f589374d64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f5889389099 in QXcbEventReader::run (this=0x145a390) at qxcbconnection.cpp:1105
#4  0x00007f5895ab2b0e in QThreadPrivate::start (arg=0x145a390) at thread/qthread_unix.cpp:337
#5  0x00007f58926656aa in start_thread (arg=0x7f58865c2700) at pthread_create.c:333
#6  0x00007f589543ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 6 (Thread 0x7f5878c21700 (LWP 5533)):
#0  0x00007f589542d49d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f588e5d6f75 in ?? () from /usr/lib/x86_64-linux-gnu/tls/libnvidia-tls.so.352.21
#2  0x00007f589218a2f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f589214696c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f5892146e60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f5892147242 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f587fd5fae6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#7  0x00007f589216d955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f58926656aa in start_thread (arg=0x7f5878c21700) at pthread_create.c:333
#9  0x00007f589543ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f5873fff700 (LWP 5534)):
#0  0x00007f589542d49d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f588e5d6f75 in ?? () from /usr/lib/x86_64-linux-gnu/tls/libnvidia-tls.so.352.21
#2  0x00007f589218a2f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f589214696c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f5892146e60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f5892146fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f5892147009 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f589216d955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f58926656aa in start_thread (arg=0x7f5873fff700) at pthread_create.c:333
#9  0x00007f589543ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f5865cc9700 (LWP 5536)):
#0  0x00007f58921463fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f5892146de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5892146fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5895d49c6c in QEventDispatcherGlib::processEvents (this=0x7f58600008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f5895cee3e2 in QEventLoop::exec (this=this@entry=0x7f5865cc8e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f5895aadb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f5894a78f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f5895ab2b0e in QThreadPrivate::start (arg=0x1b7e050) at thread/qthread_unix.cpp:337
#8  0x00007f58926656aa in start_thread (arg=0x7f5865cc9700) at pthread_create.c:333
#9  0x00007f589543ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f585ea2a700 (LWP 5537)):
[KCrash Handler]
#6  0x0000000000000070 in ?? ()
#7  0x00007f58944fd628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f58944fcd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f58941acd9e in ManagedTextureNode::setTexture (this=<optimized out>, texture=...) at ../../../src/quickaddons/managedtexturenode.cpp:28
#10 0x00007f5864681c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x2c0fce0, oldNode=0x7f5858cc63c0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#11 0x00007f58945504bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f58945514cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f5894551d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f58945231dd in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f58945240a1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#16 0x00007f5894525360 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#17 0x00007f5895ab2b0e in QThreadPrivate::start (arg=0x2003900) at thread/qthread_unix.cpp:337
#18 0x00007f58926656aa in start_thread (arg=0x7f585ea2a700) at pthread_create.c:333
#19 0x00007f589543ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f585e229700 (LWP 5538)):
#0  0x00007f58954318dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f5892146ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5892146fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5895d49c6c in QEventDispatcherGlib::processEvents (this=0x7f58500008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f5895cee3e2 in QEventLoop::exec (this=this@entry=0x7f585e228e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f5895aadb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f5894a78f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f5895ab2b0e in QThreadPrivate::start (arg=0x232f2d0) at thread/qthread_unix.cpp:337
#8  0x00007f58926656aa in start_thread (arg=0x7f585e229700) at pthread_create.c:333
#9  0x00007f589543ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f5898cba780 (LWP 5529)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f5895ab3c6b in wait (time=18446744073709551615, this=0x20039e0) at thread/qwaitcondition_unix.cpp:128
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2003940, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:200
#3  0x00007f5894526c48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#4  0x00007f5894527cad in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007f5896adcb2c in QApplicationPrivate::notify_helper (this=0x142d9d0, receiver=0x1f360e0, e=0x7fffc09de120) at kernel/qapplication.cpp:3720
#6  0x00007f5896ae2000 in QApplication::notify (this=0x7fffc09de490, receiver=0x1f360e0, e=0x7fffc09de120) at kernel/qapplication.cpp:3503
#7  0x00007f5895cf0c2b in QCoreApplication::notifyInternal (this=0x7fffc09de490, receiver=0x1f360e0, event=event@entry=0x7fffc09de120) at kernel/qcoreapplication.cpp:935
#8  0x00007f5895d48ae5 in sendEvent (event=0x7fffc09de120, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#9  QTimerInfoList::activateTimers (this=0x1429c70) at kernel/qtimerinfo_unix.cpp:635
#10 0x00007f5895d48f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#11 0x00007f5892146c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f5892146f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007f5892146fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#14 0x00007f5895d49c57 in QEventDispatcherGlib::processEvents (this=0x1429af0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#15 0x00007f5895cee3e2 in QEventLoop::exec (this=this@entry=0x7fffc09de370, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#16 0x00007f5895cf602c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#17 0x00007f589651731c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#18 0x00007f5896ad87a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#19 0x000000000040ef6b in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:55

Reported using DrKonqi
Comment 1 Christoph Feck 2015-06-23 22:33:49 UTC

*** This bug has been marked as a duplicate of bug 345675 ***