Bug 349649 - systems settings - application style - Window decoration crash
Summary: systems settings - application style - Window decoration crash
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-06-27 10:31 UTC by Lee
Modified: 2015-07-10 14:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lee 2015-06-27 10:31:29 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-21-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
i was viewing systems settings - application style - Window decoration so that i could select a new decoration but it would crash before i could select anything

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7f615a408780 (LWP 14982))]

Thread 5 (Thread 0x7f6147c13700 (LWP 14984)):
#0  0x00007f6156b818dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f6154e9bb72 in poll (__timeout=-1, __nfds=1, __fds=0x7f6147c12d40) at /usr/include/x86_64-linux-gnu/bits/poll2.h:46
#2  _xcb_conn_wait (c=c@entry=0xae57d0, cond=cond@entry=0xae5810, vector=vector@entry=0x0, count=count@entry=0x0) at ../../src/xcb_conn.c:447
#3  0x00007f6154e9d64f in xcb_wait_for_event (c=0xae57d0) at ../../src/xcb_in.c:622
#4  0x00007f614a9dc099 in QXcbEventReader::run (this=0xaf3a30) at qxcbconnection.cpp:1105
#5  0x00007f6157202b0e in QThreadPrivate::start (arg=0xaf3a30) at thread/qthread_unix.cpp:337
#6  0x00007f6153db56aa in start_thread (arg=0x7f6147c13700) at pthread_create.c:333
#7  0x00007f6156b8ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f6138249700 (LWP 14992)):
#0  0x00007f6156b818dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f6153896ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6153896fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6157499c6c in QEventDispatcherGlib::processEvents (this=0x7f61300008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f615743e3e2 in QEventLoop::exec (this=this@entry=0x7f6138248e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f61571fdb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f61561c8f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f6157202b0e in QThreadPrivate::start (arg=0xdbb030) at thread/qthread_unix.cpp:337
#8  0x00007f6153db56aa in start_thread (arg=0x7f6138249700) at pthread_create.c:333
#9  0x00007f6156b8ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f6134918700 (LWP 14993)):
#0  0x00007f6156b818dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f6153896ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6153896fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6157499c6c in QEventDispatcherGlib::processEvents (this=0x7f61280008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f615743e3e2 in QEventLoop::exec (this=this@entry=0x7f6134917e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f61571fdb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f61561c8f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f6157202b0e in QThreadPrivate::start (arg=0x1505db0) at thread/qthread_unix.cpp:337
#8  0x00007f6153db56aa in start_thread (arg=0x7f6134918700) at pthread_create.c:333
#9  0x00007f6156b8ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f612e23e700 (LWP 14994)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f6155c4d628 in QSGOpaqueTextureMaterial::setTexture (this=this@entry=0x7f6124451428, texture=texture@entry=0x7f61243a0280) at scenegraph/util/qsgtexturematerial.cpp:195
#8  0x00007f6155c4cd3c in QSGSimpleTextureNode::setTexture (this=0x7f61244512f0, texture=0x7f61243a0280) at scenegraph/util/qsgsimpletexturenode.cpp:187
#9  0x00007f6136699c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x1901000, oldNode=0x7f61244512f0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f6155ca04bf in QQuickWindowPrivate::updateDirtyNode (this=this@entry=0xf59cd0, item=item@entry=0x1901000) at items/qquickwindow.cpp:2821
#11 0x00007f6155ca14cb in QQuickWindowPrivate::updateDirtyNodes (this=this@entry=0xf59cd0) at items/qquickwindow.cpp:2646
#12 0x00007f6155ca1d80 in QQuickWindowPrivate::syncSceneGraph (this=this@entry=0xf59cd0) at items/qquickwindow.cpp:338
#13 0x00007f6155c731dd in QSGRenderThread::sync (this=this@entry=0x18a3520, inExpose=<optimized out>) at scenegraph/qsgthreadedrenderloop.cpp:510
#14 0x00007f6155c740a1 in QSGRenderThread::syncAndRender (this=this@entry=0x18a3520) at scenegraph/qsgthreadedrenderloop.cpp:553
#15 0x00007f6155c75360 in QSGRenderThread::run (this=0x18a3520) at scenegraph/qsgthreadedrenderloop.cpp:663
#16 0x00007f6157202b0e in QThreadPrivate::start (arg=0x18a3520) at thread/qthread_unix.cpp:337
#17 0x00007f6153db56aa in start_thread (arg=0x7f612e23e700) at pthread_create.c:333
#18 0x00007f6156b8ceed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f615a408780 (LWP 14982)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f6157203c6b in wait (time=18446744073709551615, this=0xf52360) at thread/qwaitcondition_unix.cpp:128
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x18a3560, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:200
#3  0x00007f6155c76c48 in QSGThreadedRenderLoop::polishAndSync (this=this@entry=0xeb77f0, w=<optimized out>, inExpose=inExpose@entry=false) at scenegraph/qsgthreadedrenderloop.cpp:1128
#4  0x00007f6155c77cad in QSGThreadedRenderLoop::event (this=0xeb77f0, e=0x7ffc7e54cb80) at scenegraph/qsgthreadedrenderloop.cpp:1190
#5  0x00007f615822cb2c in QApplicationPrivate::notify_helper (this=0xac6550, receiver=0xeb77f0, e=0x7ffc7e54cb80) at kernel/qapplication.cpp:3720
#6  0x00007f6158232000 in QApplication::notify (this=0x7ffc7e54cef0, receiver=0xeb77f0, e=0x7ffc7e54cb80) at kernel/qapplication.cpp:3503
#7  0x00007f6157440c2b in QCoreApplication::notifyInternal (this=0x7ffc7e54cef0, receiver=0xeb77f0, event=event@entry=0x7ffc7e54cb80) at kernel/qcoreapplication.cpp:935
#8  0x00007f6157498ae5 in sendEvent (event=0x7ffc7e54cb80, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#9  QTimerInfoList::activateTimers (this=0xb3b000) at kernel/qtimerinfo_unix.cpp:635
#10 0x00007f6157498f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#11 0x00007f6153896c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f6153896f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007f6153896fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#14 0x00007f6157499c57 in QEventDispatcherGlib::processEvents (this=0xb31830, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#15 0x00007f615743e3e2 in QEventLoop::exec (this=this@entry=0x7ffc7e54cdd0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#16 0x00007f615744602c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#17 0x00007f6157c6731c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#18 0x00007f61582287a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#19 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-07-10 14:15:41 UTC

*** This bug has been marked as a duplicate of bug 345675 ***