Bug 352646 - ststemsettings5
Summary: ststemsettings5
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-09-13 09:36 UTC by Thomas
Modified: 2015-09-14 09:45 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas 2015-09-13 09:36:09 UTC
Application: systemsettings5 (5.2.2)
 (Compiled from sources)
Qt Version: 5.4.1
Operating System: Linux 3.19.0-28-lowlatency x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
    Running system settings > Appearance > Application style > Window Decorations
    Simply scrolling through available decorations crashes system settings

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7f45d12e5780 (LWP 2884))]

Thread 5 (Thread 0x7f45beaf0700 (LWP 2885)):
#0  0x00007f45cda508dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f45cbd6ab72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f45cbd6c64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f45c18ab099 in QXcbEventReader::run (this=0x1162a50) at qxcbconnection.cpp:1105
#4  0x00007f45ce0d1b0e in QThreadPrivate::start (arg=0x1162a50) at thread/qthread_unix.cpp:337
#5  0x00007f45cac846aa in start_thread (arg=0x7f45beaf0700) at pthread_create.c:333
#6  0x00007f45cda5beed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f45af225700 (LWP 2887)):
#0  0x00007f45cda4c49d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f45c6bccf45 in ?? () from /usr/lib/nvidia-346/tls/libnvidia-tls.so.346.59
#2  0x00007f45ca7a92f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f45ca76596c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f45ca765e60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f45ca765fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f45ce368c6c in QEventDispatcherGlib::processEvents (this=0x7f45a80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#7  0x00007f45ce30d3e2 in QEventLoop::exec (this=this@entry=0x7f45af224e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#8  0x00007f45ce0ccb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#9  0x00007f45cd097f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#10 0x00007f45ce0d1b0e in QThreadPrivate::start (arg=0x1a21c00) at thread/qthread_unix.cpp:337
#11 0x00007f45cac846aa in start_thread (arg=0x7f45af225700) at pthread_create.c:333
#12 0x00007f45cda5beed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f45a7830700 (LWP 2888)):
#0  0x00007f45ce0c9a26 in QMutex::lock (this=this@entry=0x1d79ea8) at thread/qmutex.cpp:218
#1  0x00007f45ce3681db in QMutexLocker (m=0x1d79ea8, this=<synthetic pointer>) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:128
#2  canWaitLocked (this=0x1d79e80) at ../../include/QtCore/5.4.1/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:243
#3  postEventSourcePrepare (s=0x7f45a00012d0, timeout=0x7f45a782fc54) at kernel/qeventdispatcher_glib.cpp:254
#4  0x00007f45ca7653fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f45ca765de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f45ca765fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f45ce368c6c in QEventDispatcherGlib::processEvents (this=0x7f45a00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#8  0x00007f45ce30d3e2 in QEventLoop::exec (this=this@entry=0x7f45a782fe20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#9  0x00007f45ce0ccb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#10 0x00007f45cd097f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#11 0x00007f45ce0d1b0e in QThreadPrivate::start (arg=0x1d890c0) at thread/qthread_unix.cpp:337
#12 0x00007f45cac846aa in start_thread (arg=0x7f45a7830700) at pthread_create.c:333
#13 0x00007f45cda5beed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f45a543d700 (LWP 2889)):
[KCrash Handler]
#6  0x00007f45ccb1c625 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#7  0x00007f45ccb1bd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f45adbcfc9a in Plasma::FrameSvgItem::updatePaintNode (this=0x34bea00, oldNode=0x7f459934f1f0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#9  0x00007f45ccb6f4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#10 0x00007f45ccb704cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f45ccb70d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f45ccb421dd in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f45ccb430a1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f45ccb44360 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f45ce0d1b0e in QThreadPrivate::start (arg=0x20dbdc0) at thread/qthread_unix.cpp:337
#16 0x00007f45cac846aa in start_thread (arg=0x7f45a543d700) at pthread_create.c:333
#17 0x00007f45cda5beed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f45d12e5780 (LWP 2884)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f45ce0d2c6b in wait (time=18446744073709551615, this=0x192db30) at thread/qwaitcondition_unix.cpp:128
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x20dbe00, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:200
#3  0x00007f45ccb45c48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#4  0x00007f45ccb46cad in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007f45cf0fbb2c in QApplicationPrivate::notify_helper (this=0x1135550, receiver=0x13faa30, e=0x7fffd5603590) at kernel/qapplication.cpp:3720
#6  0x00007f45cf101000 in QApplication::notify (this=0x7fffd5603900, receiver=0x13faa30, e=0x7fffd5603590) at kernel/qapplication.cpp:3503
#7  0x00007f45ce30fc2b in QCoreApplication::notifyInternal (this=0x7fffd5603900, receiver=0x13faa30, event=event@entry=0x7fffd5603590) at kernel/qcoreapplication.cpp:935
#8  0x00007f45ce367ae5 in sendEvent (event=0x7fffd5603590, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#9  QTimerInfoList::activateTimers (this=0x11a31b0) at kernel/qtimerinfo_unix.cpp:635
#10 0x00007f45ce367f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#11 0x00007f45ca765c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f45ca765f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007f45ca765fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#14 0x00007f45ce368c57 in QEventDispatcherGlib::processEvents (this=0x11a1bd0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#15 0x00007f45ce30d3e2 in QEventLoop::exec (this=this@entry=0x7fffd56037e0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#16 0x00007f45ce31502c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#17 0x00007f45ceb3631c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#18 0x00007f45cf0f77a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#19 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-09-14 09:45:22 UTC

*** This bug has been marked as a duplicate of bug 345675 ***