Bug 351419 - systemsettings5 crashed after installing a new window-themes and trying to apply them
Summary: systemsettings5 crashed after installing a new window-themes and trying to ap...
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-08-18 03:15 UTC by Sergio Kurilla
Modified: 2015-08-22 14:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergio Kurilla 2015-08-18 03:15:10 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-25-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- I installed some new themes using internal tool, one of them was "OS X", that apparently led to the crash. I was able to apply this theme, then application crashes everytime when I try to open page with theme preview window.

The crash can be reproduced every time.

-- Backtrace:
Application: Параметры системы (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb7be031780 (LWP 27277))]

Thread 4 (Thread 0x7fb7ad67f700 (LWP 27278)):
#0  0x00007fb7ba79c8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fb7b8ab6b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fb7b8ab864f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fb7afbca099 in QXcbEventReader::run (this=0x24a65a0) at qxcbconnection.cpp:1105
#4  0x00007fb7bae1db0e in QThreadPrivate::start (arg=0x24a65a0) at thread/qthread_unix.cpp:337
#5  0x00007fb7b79d06aa in start_thread (arg=0x7fb7ad67f700) at pthread_create.c:333
#6  0x00007fb7ba7a7eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fb79d03b700 (LWP 27279)):
#0  __libc_disable_asynccancel () at ../sysdeps/unix/sysv/linux/x86_64/cancellation.S:98
#1  0x00007fb7ba79c8e9 in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0x00007fb7b74b1ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb7b74b1fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fb7bb0b4c6c in QEventDispatcherGlib::processEvents (this=0x7fb7980008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007fb7bb0593e2 in QEventLoop::exec (this=this@entry=0x7fb79d03ae20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007fb7bae18b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007fb7b9de3f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007fb7bae1db0e in QThreadPrivate::start (arg=0x26ff810) at thread/qthread_unix.cpp:337
#9  0x00007fb7b79d06aa in start_thread (arg=0x7fb79d03b700) at pthread_create.c:333
#10 0x00007fb7ba7a7eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fb795b74700 (LWP 27280)):
#0  0x00007fb7ba79c8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fb7b74b1ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb7b74b1fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb7bb0b4c6c in QEventDispatcherGlib::processEvents (this=0x7fb7900008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fb7bb0593e2 in QEventLoop::exec (this=this@entry=0x7fb795b73e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fb7bae18b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fb7b9de3f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fb7bae1db0e in QThreadPrivate::start (arg=0x2c0d8e0) at thread/qthread_unix.cpp:337
#8  0x00007fb7b79d06aa in start_thread (arg=0x7fb795b74700) at pthread_create.c:333
#9  0x00007fb7ba7a7eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fb7be031780 (LWP 27277)):
[KCrash Handler]
#6  0x00007fb7b9868625 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#7  0x00007fb7b9867d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fb7974e8c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x5b73390, oldNode=0x650e9b0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#9  0x00007fb7b98bb4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#10 0x00007fb7b98bc4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fb7b98bcd80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fb7b988bf05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fb7b988c979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fb7bbe47b2c in QApplicationPrivate::notify_helper (this=0x248fb10, receiver=0x28accf0, e=0x7ffdea02b800) at kernel/qapplication.cpp:3720
#15 0x00007fb7bbe4d000 in QApplication::notify (this=0x7ffdea02bb70, receiver=0x28accf0, e=0x7ffdea02b800) at kernel/qapplication.cpp:3503
#16 0x00007fb7bb05bc2b in QCoreApplication::notifyInternal (this=0x7ffdea02bb70, receiver=0x28accf0, event=event@entry=0x7ffdea02b800) at kernel/qcoreapplication.cpp:935
#17 0x00007fb7bb0b3ae5 in sendEvent (event=0x7ffdea02b800, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#18 QTimerInfoList::activateTimers (this=0x24cbd90) at kernel/qtimerinfo_unix.cpp:635
#19 0x00007fb7bb0b3f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#20 0x00007fb7b74b1c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007fb7b74b1f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fb7b74b1fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fb7bb0b4c57 in QEventDispatcherGlib::processEvents (this=0x24da950, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#24 0x00007fb7bb0593e2 in QEventLoop::exec (this=this@entry=0x7ffdea02ba50, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#25 0x00007fb7bb06102c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#26 0x00007fb7bb88231c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#27 0x00007fb7bbe437a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#28 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Sergio Kurilla 2015-08-18 07:52:55 UTC
I was able to fix the problem only manual editing of the file ~/.config/kwinrc and deleting 'osx' folder from ~/.local/share/aurorae/themes .
In addition, a similar problem was seen with the theme "Seven-Blue".
Comment 2 Christoph Feck 2015-08-22 14:39:48 UTC

*** This bug has been marked as a duplicate of bug 345675 ***