Bug 350064 - Window Decoration Switching
Summary: Window Decoration Switching
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-07-09 20:55 UTC by Tweak
Modified: 2015-07-10 14:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tweak 2015-07-09 20:55:22 UTC
Application: kcmshell5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-22-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
Attempting to change window decorations using the system settings manager.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE Control Module (kcmshell5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1a4a819800 (LWP 21224))]

Thread 5 (Thread 0x7f1a36208700 (LWP 21225)):
#0  0x00007f1a4a3038dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f1a429f1b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f1a429f364f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f1a3812c099 in QXcbEventReader::run (this=0x208c3a0) at qxcbconnection.cpp:1105
#4  0x00007f1a48386b0e in QThreadPrivate::start (arg=0x208c3a0) at thread/qthread_unix.cpp:337
#5  0x00007f1a47dbd6aa in start_thread (arg=0x7f1a36208700) at pthread_create.c:333
#6  0x00007f1a4a30eeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f1a29768700 (LWP 21237)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f1a2c7a54fb in ?? () from /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#2  0x00007f1a2c7a4c87 in ?? () from /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#3  0x00007f1a47dbd6aa in start_thread (arg=0x7f1a29768700) at pthread_create.c:333
#4  0x00007f1a4a30eeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f1a28d2f700 (LWP 21238)):
#0  0x00007f1a4a2ff49d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f1a423112f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1a422cd96c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1a422cde60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f1a422cdfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f1a4861dc6c in QEventDispatcherGlib::processEvents (this=0x7f1a240008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#6  0x00007f1a485c23e2 in QEventLoop::exec (this=this@entry=0x7f1a28d2eda0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#7  0x00007f1a48381b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#8  0x00007f1a477c7f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007f1a48386b0e in QThreadPrivate::start (arg=0x22fb8b0) at thread/qthread_unix.cpp:337
#10 0x00007f1a47dbd6aa in start_thread (arg=0x7f1a28d2f700) at pthread_create.c:333
#11 0x00007f1a4a30eeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f1a21793700 (LWP 21239)):
#0  0x00007f1a4a2ff49d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f1a423112f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1a422cd96c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1a422cde60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f1a422cdfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f1a4861dc6c in QEventDispatcherGlib::processEvents (this=0x7f1a1c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#6  0x00007f1a485c23e2 in QEventLoop::exec (this=this@entry=0x7f1a21792da0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#7  0x00007f1a48381b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#8  0x00007f1a477c7f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007f1a48386b0e in QThreadPrivate::start (arg=0x25d4fa0) at thread/qthread_unix.cpp:337
#10 0x00007f1a47dbd6aa in start_thread (arg=0x7f1a21793700) at pthread_create.c:333
#11 0x00007f1a4a30eeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f1a4a819800 (LWP 21224)):
[KCrash Handler]
#6  0x0000006500000065 in ?? ()
#7  0x00007f1a4724c628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f1a4724bd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f1a235d9c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x42d1a80, oldNode=0x4b70e10) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f1a4729f4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f1a472a04cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f1a472a0d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f1a4726ff05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f1a47270979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f1a48981b2c in QApplicationPrivate::notify_helper (this=0x2072410, receiver=0x2201450, e=0x7ffeb1066920) at kernel/qapplication.cpp:3720
#16 0x00007f1a48987000 in QApplication::notify (this=0x7ffeb1066cf0, receiver=0x2201450, e=0x7ffeb1066920) at kernel/qapplication.cpp:3503
#17 0x00007f1a485c4c2b in QCoreApplication::notifyInternal (this=0x7ffeb1066cf0, receiver=0x2201450, event=event@entry=0x7ffeb1066920) at kernel/qcoreapplication.cpp:935
#18 0x00007f1a4861cae5 in sendEvent (event=0x7ffeb1066920, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x20b7560) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f1a4861cf61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f1a422cdc3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f1a422cdf20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f1a422cdfcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f1a4861dc57 in QEventDispatcherGlib::processEvents (this=0x20ae730, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f1a485c23e2 in QEventLoop::exec (this=this@entry=0x7ffeb1066b80, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f1a48b834b5 in QDialog::exec (this=0x2145c70) at dialogs/qdialog.cpp:541
#27 0x00007f1a4a5da9cb in kdemain (_argc=<optimized out>, _argv=<optimized out>) at ../../kcmshell/main.cpp:307
#28 0x00007f1a4a228a40 in __libc_start_main (main=0x400730 <main(int, char**)>, argc=2, argv=0x7ffeb1066e38, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffeb1066e28) at libc-start.c:289
#29 0x0000000000400769 in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2015-07-10 14:17:09 UTC

*** This bug has been marked as a duplicate of bug 345675 ***