Bug 346334 - System Settings -> Window Decorations crashed
Summary: System Settings -> Window Decorations crashed
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kwin
Classification: Unclassified
Component: decorations (show other bugs)
Version: 5.2.2
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-04-18 12:19 UTC by Oleg
Modified: 2015-04-18 15:23 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oleg 2015-04-18 12:19:25 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.3-200.fc21.x86_64 x86_64
Distribution: "Fedora release 21 (Twenty One)"

-- Information about the crash:
- What I was doing when the application crashed:

Opened System Settings -> Window Decorations, downloaded custom window decorations theme, applied one and logged out. 
After logging in I was trying to change window decoration again, and it's crashed while I scrolled list with available decoration themes.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fabfa927880 (LWP 2360))]

Thread 5 (Thread 0x7fabe2cc9700 (LWP 2361)):
#0  0x00007fabf5b79c8d in poll () from /lib64/libc.so.6
#1  0x00007fabf4eb0182 in _xcb_conn_wait () from /lib64/libxcb.so.1
#2  0x00007fabf4eb1cff in xcb_wait_for_event () from /lib64/libxcb.so.1
#3  0x00007fabe54ba959 in QXcbEventReader::run() () from /usr/lib64/qt5/plugins/platforms/libqxcb.so
#4  0x00007fabf67130ce in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#5  0x00007fabf3eb352a in start_thread () from /lib64/libpthread.so.0
#6  0x00007fabf5b8522d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fabd481d700 (LWP 2371)):
#0  0x00007fabf313e199 in g_mutex_lock () from /lib64/libglib-2.0.so.0
#1  0x00007fabf30f9109 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#2  0x00007fabf30f9a5b in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#3  0x00007fabf30f9c4c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#4  0x00007fabf69567dc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#5  0x00007fabf68fbf82 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#6  0x00007fabf670e2f4 in QThread::exec() () from /lib64/libQt5Core.so.5
#7  0x00007fabf67130ce in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#8  0x00007fabf3eb352a in start_thread () from /lib64/libpthread.so.0
#9  0x00007fabf5b8522d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fabb7ffe700 (LWP 2413)):
#0  0x00007fabf5b92d8f in __libc_enable_asynccancel () from /lib64/libc.so.6
#1  0x00007fabf5b79c82 in poll () from /lib64/libc.so.6
#2  0x00007fabf30f9b34 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#3  0x00007fabf30f9c4c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#4  0x00007fabf69567dc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#5  0x00007fabf68fbf82 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#6  0x00007fabf670e2f4 in QThread::exec() () from /lib64/libQt5Core.so.5
#7  0x00007fabc1abb195 in QQmlThreadPrivate::run() () from /lib64/libQt5Qml.so.5
#8  0x00007fabf67130ce in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#9  0x00007fabf3eb352a in start_thread () from /lib64/libpthread.so.0
#10 0x00007fabf5b8522d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fabc2e29700 (LWP 2414)):
#0  0x00007fabf313e199 in g_mutex_lock () from /lib64/libglib-2.0.so.0
#1  0x00007fabf30f8ae0 in g_main_context_acquire () from /lib64/libglib-2.0.so.0
#2  0x00007fabf30f99e5 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#3  0x00007fabf30f9c4c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#4  0x00007fabf69567dc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#5  0x00007fabf68fbf82 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#6  0x00007fabf670e2f4 in QThread::exec() () from /lib64/libQt5Core.so.5
#7  0x00007fabc1abb195 in QQmlThreadPrivate::run() () from /lib64/libQt5Qml.so.5
#8  0x00007fabf67130ce in QThreadPrivate::start(void*) () from /lib64/libQt5Core.so.5
#9  0x00007fabf3eb352a in start_thread () from /lib64/libpthread.so.0
#10 0x00007fabf5b8522d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fabfa927880 (LWP 2360)):
[KCrash Handler]
#5  0x00007fabc153dfd5 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /lib64/libQt5Quick.so.5
#6  0x00007fabc153d6ec in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /lib64/libQt5Quick.so.5
#7  0x00007fabbb6baf22 in Plasma::FrameSvgItem::updatePaintNode(QSGNode*, QQuickItem::UpdatePaintNodeData*) () from /usr/lib64/qt5/qml/org/kde/plasma/core/libcorebindingsplugin.so
#8  0x00007fabc159073f in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /lib64/libQt5Quick.so.5
#9  0x00007fabc159173b in QQuickWindowPrivate::updateDirtyNodes() () from /lib64/libQt5Quick.so.5
#10 0x00007fabc1591fe0 in QQuickWindowPrivate::syncSceneGraph() () from /lib64/libQt5Quick.so.5
#11 0x00007fabc15615f5 in QSGGuiThreadRenderLoop::renderWindow(QQuickWindow*) () from /lib64/libQt5Quick.so.5
#12 0x00007fabc1562061 in QSGGuiThreadRenderLoop::event(QEvent*) () from /lib64/libQt5Quick.so.5
#13 0x00007fabf776895c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#14 0x00007fabf776dda0 in QApplication::notify(QObject*, QEvent*) () from /lib64/libQt5Widgets.so.5
#15 0x00007fabf68fe6eb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /lib64/libQt5Core.so.5
#16 0x00007fabf69556f5 in QTimerInfoList::activateTimers() () from /lib64/libQt5Core.so.5
#17 0x00007fabf6955b21 in timerSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib64/libQt5Core.so.5
#18 0x00007fabf30f97fb in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#19 0x00007fabf30f9b98 in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#20 0x00007fabf30f9c4c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#21 0x00007fabf69567c7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#22 0x00007fabf68fbf82 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQt5Core.so.5
#23 0x00007fabf6903a2c in QCoreApplication::exec() () from /lib64/libQt5Core.so.5
#24 0x000000000040e9fc in main ()

Reported using DrKonqi
Comment 1 Thomas Lübking 2015-04-18 15:23:38 UTC

*** This bug has been marked as a duplicate of bug 345675 ***