Bug 347081 - System Settings crashes after viewing installed window decorations
Summary: System Settings crashes after viewing installed window decorations
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-02 18:26 UTC by John Lund-Molfese
Modified: 2015-05-02 23:52 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Lund-Molfese 2015-05-02 18:26:40 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-15-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
I went to System Settings, then Window Decorations. The application crashes as soon as I open it.

- Custom settings of the application:
I downloaded several (about 5) window decorations from the list

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7f7fdb6e1780 (LWP 6862))]

Thread 5 (Thread 0x7f7fc8eec700 (LWP 6863)):
#0  0x00007f7fd7e4d8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f7fd6167b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f7fd616964f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f7fcbca8099 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqxcb.so
#4  0x00007f7fd84ceb0e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f7fd50816aa in start_thread (arg=0x7f7fc8eec700) at pthread_create.c:333
#6  0x00007f7fd7e58eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f7fb99d5700 (LWP 6864)):
#0  0x00007f7fd4ba77a4 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f7fd4b62490 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7fd4b62de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7fd4b62fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f7fd8765c6c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f7fd870a3e2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f7fd84c9b44 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f7fd7494f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f7fd84ceb0e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f7fd50816aa in start_thread (arg=0x7f7fb99d5700) at pthread_create.c:333
#10 0x00007f7fd7e58eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f7fb207f700 (LWP 6865)):
#0  0x00007f7fd4b89df7 in g_thread_self () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f7fd4b62fbd in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7fd8765c6c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007f7fd870a3e2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f7fd84c9b44 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f7fd7494f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#6  0x00007f7fd84ceb0e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f7fd50816aa in start_thread (arg=0x7f7fb207f700) at pthread_create.c:333
#8  0x00007f7fd7e58eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f7fb0d07700 (LWP 6866)):
[KCrash Handler]
#6  0x0000000000000070 in ?? ()
#7  0x00007f7fd6f19628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f7fd6f18d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f7fb3dd9c9a in ?? () from /usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/plasma/core/libcorebindingsplugin.so
#10 0x00007f7fd6f6c4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f7fd6f6d4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f7fd6f6dd80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f7fd6f3f1dd in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f7fd6f400a1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f7fd6f41360 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#16 0x00007f7fd84ceb0e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#17 0x00007f7fd50816aa in start_thread (arg=0x7f7fb0d07700) at pthread_create.c:333
#18 0x00007f7fd7e58eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f7fdb6e1780 (LWP 6862)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f7fd84cfc6b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#2  0x00007f7fd6f42c48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#3  0x00007f7fd6f45a8b in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#4  0x00007f7fd6f4630a in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007f7fd8f447b5 in QWindow::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#6  0x00007f7fd6f77dd3 in QQuickWindow::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#7  0x00007f7fd94f8b2c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#8  0x00007f7fd94fe000 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#9  0x00007f7fd870cc2b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#10 0x00007f7fd8f3ce86 in QGuiApplicationPrivate::processExposeEvent(QWindowSystemInterfacePrivate::ExposeEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#11 0x00007f7fd8f3dbbd in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#12 0x00007f7fd8f2234f in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5
#13 0x00007f7fcbcd2590 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqxcb.so
#14 0x00007f7fd4b62c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#15 0x00007f7fd4b62f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#16 0x00007f7fd4b62fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#17 0x00007f7fd8765c57 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#18 0x00007f7fd870a3e2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#19 0x00007f7fd871202c in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#20 0x000000000040eebc in main ()

Reported using DrKonqi
Comment 1 John Lund-Molfese 2015-05-02 18:36:33 UTC
The problem remains after I reboot. Could someone tell me where window decorations are stored, so I can test decorations individually, and see if there's a particular one which is causing the problem?
Comment 2 Christoph Feck 2015-05-02 23:52:38 UTC

*** This bug has been marked as a duplicate of bug 345675 ***