Bug 353493 - System Settings Crashing
Summary: System Settings Crashing
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-10-03 15:14 UTC by Jonathan Jones
Modified: 2015-10-10 21:38 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Jones 2015-10-03 15:14:31 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-30-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
I was attempting to change my windows decorations but everytime I click on windows decorations system settings crashes every time!

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4e6ecb9780 (LWP 2087))]

Thread 4 (Thread 0x7f4e5e431700 (LWP 2088)):
#0  0x00007f4e6b41c8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f4e69736b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f4e6973864f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f4e6097c099 in QXcbEventReader::run (this=0x10efc90) at qxcbconnection.cpp:1105
#4  0x00007f4e6ba9db0e in QThreadPrivate::start (arg=0x10efc90) at thread/qthread_unix.cpp:337
#5  0x00007f4e686506aa in start_thread (arg=0x7f4e5e431700) at pthread_create.c:333
#6  0x00007f4e6b427eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f4e4e153700 (LWP 2090)):
#0  0x00007ffec1d1ecee in clock_gettime ()
#1  0x00007f4e6b43638d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007f4e6bb53cb6 in qt_clock_gettime (ts=0x7f4e4e152b80, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:161
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:170
#5  0x00007f4e6bd32639 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f4e48002ed0) at kernel/qtimerinfo_unix.cpp:84
#6  0x00007f4e6bd32ba5 in QTimerInfoList::timerWait (this=0x7f4e48002ed0, tm=...) at kernel/qtimerinfo_unix.cpp:379
#7  0x00007f4e6bd3403e in timerSourcePrepareHelper (timeout=0x7f4e4e152c54, src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:127
#8  timerSourcePrepare (source=<optimized out>, timeout=0x7f4e4e152c54) at kernel/qeventdispatcher_glib.cpp:160
#9  0x00007f4e681313fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f4e68131de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f4e68131fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f4e6bd34c6c in QEventDispatcherGlib::processEvents (this=0x7f4e480008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#13 0x00007f4e6bcd93e2 in QEventLoop::exec (this=this@entry=0x7f4e4e152e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#14 0x00007f4e6ba98b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#15 0x00007f4e6aa63f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#16 0x00007f4e6ba9db0e in QThreadPrivate::start (arg=0x1b2b2b0) at thread/qthread_unix.cpp:337
#17 0x00007f4e686506aa in start_thread (arg=0x7f4e4e153700) at pthread_create.c:333
#18 0x00007f4e6b427eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f4e46b9b700 (LWP 2091)):
#0  0x00007ffec1d1ecee in clock_gettime ()
#1  0x00007f4e6b43638d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007f4e6bb53cb6 in qt_clock_gettime (ts=0x7f4e46b9ab80, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:161
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:170
#5  0x00007f4e6bd32639 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f4e40002cd0) at kernel/qtimerinfo_unix.cpp:84
#6  0x00007f4e6bd32ba5 in QTimerInfoList::timerWait (this=0x7f4e40002cd0, tm=...) at kernel/qtimerinfo_unix.cpp:379
#7  0x00007f4e6bd3403e in timerSourcePrepareHelper (timeout=0x7f4e46b9ac54, src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:127
#8  timerSourcePrepare (source=<optimized out>, timeout=0x7f4e46b9ac54) at kernel/qeventdispatcher_glib.cpp:160
#9  0x00007f4e681313fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f4e68131de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f4e68131fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f4e6bd34c6c in QEventDispatcherGlib::processEvents (this=0x7f4e400008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#13 0x00007f4e6bcd93e2 in QEventLoop::exec (this=this@entry=0x7f4e46b9ae20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#14 0x00007f4e6ba98b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#15 0x00007f4e6aa63f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#16 0x00007f4e6ba9db0e in QThreadPrivate::start (arg=0x1e1acb0) at thread/qthread_unix.cpp:337
#17 0x00007f4e686506aa in start_thread (arg=0x7f4e46b9b700) at pthread_create.c:333
#18 0x00007f4e6b427eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f4e6ecb9780 (LWP 2087)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f4e6a4e8628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f4e6a4e7d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f4e4cb3dc9a in Plasma::FrameSvgItem::updatePaintNode (this=0x2207ab0, oldNode=0x3e39c80) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f4e6a53b4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f4e6a53c4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f4e6a53cd80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f4e6a50bf05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f4e6a50c979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f4e6cac7b2c in QApplicationPrivate::notify_helper (this=0x10d8b10, receiver=0x1af7430, e=0x7ffec1cb8490) at kernel/qapplication.cpp:3720
#16 0x00007f4e6cacd000 in QApplication::notify (this=0x7ffec1cb8800, receiver=0x1af7430, e=0x7ffec1cb8490) at kernel/qapplication.cpp:3503
#17 0x00007f4e6bcdbc2b in QCoreApplication::notifyInternal (this=0x7ffec1cb8800, receiver=0x1af7430, event=event@entry=0x7ffec1cb8490) at kernel/qcoreapplication.cpp:935
#18 0x00007f4e6bd33ae5 in sendEvent (event=0x7ffec1cb8490, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x111b5f0) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f4e6bd33f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f4e68131c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f4e68131f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f4e68131fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f4e6bd34c57 in QEventDispatcherGlib::processEvents (this=0x1116e30, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f4e6bcd93e2 in QEventLoop::exec (this=this@entry=0x7ffec1cb86e0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f4e6bce102c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f4e6c50231c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f4e6cac37a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-10-10 21:38:33 UTC

*** This bug has been marked as a duplicate of bug 345675 ***