Bug 350443 - system settings crashes on viewing window decorations properties
Summary: system settings crashes on viewing window decorations properties
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-07-21 08:04 UTC by robert marshall
Modified: 2015-07-28 11:38 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description robert marshall 2015-07-21 08:04:28 UTC
Application: systemsettings5 (5.3.1)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-22-generic i686
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
selcted window decorations and crashes immediately, maybe related to a theme I recently downloaded (not seen the crash before then but now it happens everytime). The new theme is Black Square http://kde-look.org/content/show.php/BlackSquare?content=161323

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb046cac0 (LWP 7065))]

Thread 6 (Thread 0xaffd0b40 (LWP 7066)):
#0  0xb77c8be0 in __kernel_vsyscall ()
#1  0xb5d713db in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0xb502a3a8 in ?? () from /usr/lib/i386-linux-gnu/libxcb.so.1
#3  0xb502c394 in xcb_wait_for_event () from /usr/lib/i386-linux-gnu/libxcb.so.1
#4  0xb017e7d3 in QXcbEventReader::run (this=0x8d3d550) at qxcbconnection.cpp:1105
#5  0xb5fcc7eb in QThreadPrivate::start (arg=0x8d3d550) at thread/qthread_unix.cpp:337
#6  0xb4c351aa in start_thread (arg=0xaffd0b40) at pthread_create.c:333
#7  0xb5d7bfde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 5 (Thread 0xab44ab40 (LWP 7075)):
#0  0xb4b37a1d in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb4af07c7 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb4af0faa in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4af1439 in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xaedf8335 in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#5  0xb4b1840a in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb4c351aa in start_thread (arg=0xab44ab40) at pthread_create.c:333
#7  0xb5d7bfde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 4 (Thread 0xaa5f7b40 (LWP 7076)):
#0  0xb4aedcc0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb4af087b in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb4af0faa in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4af1156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb62539fc in QEventDispatcherGlib::processEvents (this=0xa9c00468, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#5  0xb61f4d93 in QEventLoop::processEvents (this=0xaa5f72d4, flags=...) at kernel/qeventloop.cpp:128
#6  0xb61f51fa in QEventLoop::exec (this=0xaa5f72d4, flags=...) at kernel/qeventloop.cpp:204
#7  0xb5fc740d in QThread::exec (this=0x9395ea0) at thread/qthread.cpp:503
#8  0xb593050f in ?? () from /usr/lib/i386-linux-gnu/libQt5Qml.so.5
#9  0xb5fcc7eb in QThreadPrivate::start (arg=0x9395ea0) at thread/qthread_unix.cpp:337
#10 0xb4c351aa in start_thread (arg=0xaa5f7b40) at pthread_create.c:333
#11 0xb5d7bfde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 3 (Thread 0xa8a66b40 (LWP 7078)):
#0  0xb4b37a48 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb4af040b in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb4af0f24 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4af1156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb62539fc in QEventDispatcherGlib::processEvents (this=0x94e47c0, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#5  0xb61f4d93 in QEventLoop::processEvents (this=0xa8a662d4, flags=...) at kernel/qeventloop.cpp:128
#6  0xb61f51fa in QEventLoop::exec (this=0xa8a662d4, flags=...) at kernel/qeventloop.cpp:204
#7  0xb5fc740d in QThread::exec (this=0x94eaad0) at thread/qthread.cpp:503
#8  0xb593050f in ?? () from /usr/lib/i386-linux-gnu/libQt5Qml.so.5
#9  0xb5fcc7eb in QThreadPrivate::start (arg=0x94eaad0) at thread/qthread_unix.cpp:337
#10 0xb4c351aa in start_thread (arg=0xa8a66b40) at pthread_create.c:333
#11 0xb5d7bfde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 2 (Thread 0xa68c4b40 (LWP 7079)):
[KCrash Handler]
#7  0x00000000 in ?? ()
#8  0xb5355f0a in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#9  0xb53554c7 in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#10 0xb524a188 in ManagedTextureNode::setTexture(QSharedPointer<QSGTexture>) () from /usr/lib/i386-linux-gnu/libKF5QuickAddons.so.5
#11 0xa9250a5e in Plasma::FrameSvgItem::updatePaintNode (this=0x9d618d8, oldNode=0xa5392138) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#12 0xb53ad8e5 in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#13 0xb53ae7dd in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#14 0xb53af0c3 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#15 0xb537dc65 in ?? () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#16 0xb537ec8b in ?? () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#17 0xb537fffa in ?? () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#18 0xb5fcc7eb in QThreadPrivate::start (arg=0x8de7718) at thread/qthread_unix.cpp:337
#19 0xb4c351aa in start_thread (arg=0xa68c4b40) at pthread_create.c:333
#20 0xb5d7bfde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 1 (Thread 0xb046cac0 (LWP 7065)):
#0  0xb77c8be0 in __kernel_vsyscall ()
#1  0xb4c3a25c in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:187
#2  0xb5d88cf6 in __pthread_cond_wait (cond=0x97d2720, mutex=0x97d2708) at forward.c:149
#3  0xb5fcd86c in wait (time=<optimized out>, this=<optimized out>) at thread/qwaitcondition_unix.cpp:128
#4  QWaitCondition::wait (this=0x97d2708, mutex=0x8de773c, time=4294967295) at thread/qwaitcondition_unix.cpp:200
#5  0xb5381a24 in ?? () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#6  0xb5382aa4 in ?? () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#7  0xb6c7982a in QApplicationPrivate::notify_helper (this=0x8d1dbf8, receiver=0x92c2cb0, e=0xbfd3078c) at kernel/qapplication.cpp:3720
#8  0xb6c7f081 in QApplication::notify (this=0xbfd30a90, receiver=0x92c2cb0, e=0xbfd3078c) at kernel/qapplication.cpp:3503
#9  0xb61f7b8a in QCoreApplication::notifyInternal (this=0xbfd30a90, receiver=0x92c2cb0, event=0xbfd3078c) at kernel/qcoreapplication.cpp:935
#10 0xb6252808 in sendEvent (event=0xbfd3078c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#11 QTimerInfoList::activateTimers (this=0x8ddf374) at kernel/qtimerinfo_unix.cpp:635
#12 0xb6252cd9 in timerSourceDispatch (source=0x8ddf340) at kernel/qeventdispatcher_glib.cpp:177
#13 0xb4af0d64 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#14 0xb4af1089 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#15 0xb4af1156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#16 0xb62539e4 in QEventDispatcherGlib::processEvents (this=0x8de0808, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#17 0xb01ab611 in QPAEventDispatcherGlib::processEvents (this=0x8de0808, flags=...) at eventdispatchers/qeventdispatcher_glib.cpp:115
#18 0xb61f4d93 in QEventLoop::processEvents (this=0xbfd309c8, flags=...) at kernel/qeventloop.cpp:128
#19 0xb61f51fa in QEventLoop::exec (this=0xbfd309c8, flags=...) at kernel/qeventloop.cpp:204
#20 0xb61fd315 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#21 0xb66b0a41 in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#22 0xb6c74da4 in QApplication::exec () at kernel/qapplication.cpp:2956
#23 0x08054010 in main (argc=1, argv=0xbfd30b64) at ../../app/main.cpp:55

Reported using DrKonqi
Comment 1 Christoph Feck 2015-07-28 11:38:28 UTC

*** This bug has been marked as a duplicate of bug 345675 ***