Bug 349560 - System Settings Application Style crash
Summary: System Settings Application Style crash
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-06-24 09:38 UTC by garethic
Modified: 2015-07-10 14:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description garethic 2015-06-24 09:38:48 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-21-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
Ihad opened Application Style then clicked on Window Decorations.
- Custom settings of the application:
I had changed style from Fusion (awful) to Oxygen
My machine is just getting back from a hefty system crash caused (in part?) by a large application upgrade which hung. When I eventually restarted X wouldn't load, I even didn't have network. From there I upgraded from 14.04 to 15.04, but keeping my /home partition. Haven't so far downloaded upgrades. 
BTW can I just say, I really liked the default 14.04 appearance, the 15.04 flatland appearance is really ugly, like working in an airport or a toilet. Also the clock, on which I rely for London time, is almost too small to read - it needs more customisation options.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f5bf6e44780 (LWP 22921))]

Thread 4 (Thread 0x7f5be65be700 (LWP 22922)):
#0  0x00007f5bf35a98dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f5bf18c3b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f5bf18c564f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f5be8b09099 in QXcbEventReader::run (this=0x9f7510) at qxcbconnection.cpp:1105
#4  0x00007f5bf3c2ab0e in QThreadPrivate::start (arg=0x9f7510) at thread/qthread_unix.cpp:337
#5  0x00007f5bf07dd6aa in start_thread (arg=0x7f5be65be700) at pthread_create.c:333
#6  0x00007f5bf35b4eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f5bd6055700 (LWP 22931)):
#0  0x00007f5bf35a98dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f5bf02beebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5bf02befcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5bf3ec1c6c in QEventDispatcherGlib::processEvents (this=0x7f5bd00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f5bf3e663e2 in QEventLoop::exec (this=this@entry=0x7f5bd6054e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f5bf3c25b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f5bf2bf0f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f5bf3c2ab0e in QThreadPrivate::start (arg=0xf5e0e0) at thread/qthread_unix.cpp:337
#8  0x00007f5bf07dd6aa in start_thread (arg=0x7f5bd6055700) at pthread_create.c:333
#9  0x00007f5bf35b4eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f5bceb5d700 (LWP 22932)):
#0  0x00007ffc9b8e0d18 in clock_gettime ()
#1  0x00007f5bf35c338d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#2  0x00007f5bf3ce0cb6 in qt_clock_gettime (ts=0x7f5bceb5cb80, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#3  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:161
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:170
#5  0x00007f5bf3ebf639 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f5bc8002cd0) at kernel/qtimerinfo_unix.cpp:84
#6  0x00007f5bf3ebfba5 in QTimerInfoList::timerWait (this=0x7f5bc8002cd0, tm=...) at kernel/qtimerinfo_unix.cpp:379
#7  0x00007f5bf3ec103e in timerSourcePrepareHelper (timeout=0x7f5bceb5cc54, src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:127
#8  timerSourcePrepare (source=<optimized out>, timeout=0x7f5bceb5cc54) at kernel/qeventdispatcher_glib.cpp:160
#9  0x00007f5bf02be3fd in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f5bf02bede8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f5bf02befcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f5bf3ec1c6c in QEventDispatcherGlib::processEvents (this=0x7f5bc80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#13 0x00007f5bf3e663e2 in QEventLoop::exec (this=this@entry=0x7f5bceb5ce20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#14 0x00007f5bf3c25b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#15 0x00007f5bf2bf0f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#16 0x00007f5bf3c2ab0e in QThreadPrivate::start (arg=0x122db00) at thread/qthread_unix.cpp:337
#17 0x00007f5bf07dd6aa in start_thread (arg=0x7f5bceb5d700) at pthread_create.c:333
#18 0x00007f5bf35b4eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f5bf6e44780 (LWP 22921)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f5bf2675628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f5bf2674d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f5bd4a3fc9a in Plasma::FrameSvgItem::updatePaintNode (this=0x2f7c790, oldNode=0x302eec0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f5bf26c84bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f5bf26c94cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f5bf26c9d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f5bf2698f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f5bf2699979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f5bf4c54b2c in QApplicationPrivate::notify_helper (this=0x9e0b10, receiver=0xf5b940, e=0x7ffc9b8a3200) at kernel/qapplication.cpp:3720
#16 0x00007f5bf4c5a000 in QApplication::notify (this=0x7ffc9b8a3570, receiver=0xf5b940, e=0x7ffc9b8a3200) at kernel/qapplication.cpp:3503
#17 0x00007f5bf3e68c2b in QCoreApplication::notifyInternal (this=0x7ffc9b8a3570, receiver=0xf5b940, event=event@entry=0x7ffc9b8a3200) at kernel/qcoreapplication.cpp:935
#18 0x00007f5bf3ec0ae5 in sendEvent (event=0x7ffc9b8a3200, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0xa1f0e0) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f5bf3ec0f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f5bf02bec3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f5bf02bef20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f5bf02befcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f5bf3ec1c57 in QEventDispatcherGlib::processEvents (this=0xa2be70, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f5bf3e663e2 in QEventLoop::exec (this=this@entry=0x7ffc9b8a3450, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f5bf3e6e02c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f5bf468f31c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f5bf4c507a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-07-10 14:15:22 UTC

*** This bug has been marked as a duplicate of bug 345675 ***