Bug 346596 - System settings crashed
Summary: System settings crashed
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-04-24 22:45 UTC by John Moore
Modified: 2015-04-25 08:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Moore 2015-04-24 22:45:59 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-15-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
I had downloaded a new set of window decorations, and had switched to a new decoration.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fdc6f4f5780 (LWP 12991))]

Thread 5 (Thread 0x7fdc5ec74700 (LWP 12992)):
#0  0x00007fdc6bc5f8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fdc69f79b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fdc69f7b64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fdc611bf099 in QXcbEventReader::run (this=0xaf44b0) at qxcbconnection.cpp:1105
#4  0x00007fdc6c2e0b0e in QThreadPrivate::start (arg=0xaf44b0) at thread/qthread_unix.cpp:337
#5  0x00007fdc68e936aa in start_thread (arg=0x7fdc5ec74700) at pthread_create.c:333
#6  0x00007fdc6bc6aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7fdc3dfa5700 (LWP 13032)):
#0  0x00007fdc689b9789 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fdc68974fb8 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fdc6c577c6c in QEventDispatcherGlib::processEvents (this=0x7fdc2c001a50, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#3  0x00007fdc6c51c3e2 in QEventLoop::exec (this=this@entry=0x7fdc3dfa4e40, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#4  0x00007fdc6c2dbb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#5  0x00007fdc6c2e0b0e in QThreadPrivate::start (arg=0x2ffb530) at thread/qthread_unix.cpp:337
#6  0x00007fdc68e936aa in start_thread (arg=0x7fdc3dfa5700) at pthread_create.c:333
#7  0x00007fdc6bc6aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fdc4d23a700 (LWP 13084)):
#0  0x00007fdc689b97a4 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fdc689743f0 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fdc68974de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fdc68974fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fdc6c577c6c in QEventDispatcherGlib::processEvents (this=0x7fdc480a43d0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007fdc6c51c3e2 in QEventLoop::exec (this=this@entry=0x7fdc4d239e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007fdc6c2dbb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007fdc6b2a6f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007fdc6c2e0b0e in QThreadPrivate::start (arg=0x2fc9d50) at thread/qthread_unix.cpp:337
#9  0x00007fdc68e936aa in start_thread (arg=0x7fdc4d23a700) at pthread_create.c:333
#10 0x00007fdc6bc6aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fdc3d110700 (LWP 13085)):
#0  0x00007fdc689b97a4 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fdc689743f0 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fdc68974de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fdc68974fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fdc6c577c6c in QEventDispatcherGlib::processEvents (this=0x7fdc240a2360, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#5  0x00007fdc6c51c3e2 in QEventLoop::exec (this=this@entry=0x7fdc3d10fe20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007fdc6c2dbb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#7  0x00007fdc6b2a6f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007fdc6c2e0b0e in QThreadPrivate::start (arg=0xe21760) at thread/qthread_unix.cpp:337
#9  0x00007fdc68e936aa in start_thread (arg=0x7fdc3d110700) at pthread_create.c:333
#10 0x00007fdc6bc6aeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fdc6f4f5780 (LWP 12991)):
[KCrash Handler]
#6  0x00007fdc6ad2b625 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#7  0x00007fdc6ad2ad3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fdc47baac9a in Plasma::FrameSvgItem::updatePaintNode (this=0x493da70, oldNode=0x39f11a0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#9  0x00007fdc6ad7e4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#10 0x00007fdc6ad7f4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fdc6ad7fd80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fdc6ad4ef05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fdc6ad50016 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fdc6cd567b5 in QWindow::event (this=0xadf5b0, ev=<optimized out>) at kernel/qwindow.cpp:2051
#15 0x00007fdc6ad89dd3 in QQuickWindow::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#16 0x00007fdc6d30ab2c in QApplicationPrivate::notify_helper (this=0xaddb10, receiver=0xadf5b0, e=0x7ffdc70b3d20) at kernel/qapplication.cpp:3720
#17 0x00007fdc6d310000 in QApplication::notify (this=0x7ffdc70b4120, receiver=0xadf5b0, e=0x7ffdc70b3d20) at kernel/qapplication.cpp:3503
#18 0x00007fdc6c51ec2b in QCoreApplication::notifyInternal (this=0x7ffdc70b4120, receiver=receiver@entry=0xadf5b0, event=event@entry=0x7ffdc70b3d20) at kernel/qcoreapplication.cpp:935
#19 0x00007fdc6cd4ee86 in sendSpontaneousEvent (event=0x7ffdc70b3d20, receiver=0xadf5b0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#20 QGuiApplicationPrivate::processExposeEvent (e=0x3181560) at kernel/qguiapplication.cpp:2613
#21 0x00007fdc6cd4fbbd in QGuiApplicationPrivate::processWindowSystemEvent (e=e@entry=0x3181560) at kernel/qguiapplication.cpp:1638
#22 0x00007fdc6cd3434f in QWindowSystemInterface::sendWindowSystemEvents (flags=...) at kernel/qwindowsysteminterface.cpp:572
#23 0x00007fdc611e9590 in userEventSourceDispatch (source=<optimized out>) at eventdispatchers/qeventdispatcher_glib.cpp:70
#24 0x00007fdc68974c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007fdc68974f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007fdc68974fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007fdc6c577c57 in QEventDispatcherGlib::processEvents (this=0xb17130, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#28 0x00007fdc6c51c3e2 in QEventLoop::exec (this=this@entry=0x7ffdc70b4000, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#29 0x00007fdc6c52402c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#30 0x00007fdc6cd4531c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#31 0x00007fdc6d3067a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#32 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-04-25 08:34:36 UTC

*** This bug has been marked as a duplicate of bug 345675 ***