Bug 346863 - After installing some Window Decorations System Settings crashes when reselecting Window Decorations in 5.2
Summary: After installing some Window Decorations System Settings crashes when reselec...
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
: 347044 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-04-28 19:49 UTC by Oliver Maurhart
Modified: 2015-05-02 23:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Maurhart 2015-04-28 19:49:11 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-15-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
This is Kubuntu 15.04.

I've installed some Window Decorations within the System Settings. After adding some and closing "Get New Stuff" dialog the System Settings dialog crashes on redisplaying the Window Decorations.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7fa4d03e5780 (LWP 3058))]

Thread 6 (Thread 0x7fa4bdbd1700 (LWP 3059)):
#0  0x00007fa4ccb498dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fa4cae63b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fa4cae6564f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fa4c0964099 in QXcbEventReader::run (this=0x1959a30) at qxcbconnection.cpp:1105
#4  0x00007fa4cd1cab0e in QThreadPrivate::start (arg=0x1959a30) at thread/qthread_unix.cpp:337
#5  0x00007fa4c9d7d6aa in start_thread (arg=0x7fa4bdbd1700) at pthread_create.c:333
#6  0x00007fa4ccb54eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7fa4a4820700 (LWP 3072)):
#0  0x00007fa4ccb4549d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fa4c5cc5f45 in ?? () from /usr/lib/nvidia-346/tls/libnvidia-tls.so.346.59
#2  0x00007fa4c98a22f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa4c985e96c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fa4c985ee60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fa4c985efcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007fa4cd461c6c in QEventDispatcherGlib::processEvents (this=0x7fa4940008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#7  0x00007fa4cd4063e2 in QEventLoop::exec (this=this@entry=0x7fa4a481fe40, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#8  0x00007fa4cd1c5b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#9  0x00007fa4cd1cab0e in QThreadPrivate::start (arg=0x23412f0) at thread/qthread_unix.cpp:337
#10 0x00007fa4c9d7d6aa in start_thread (arg=0x7fa4a4820700) at pthread_create.c:333
#11 0x00007fa4ccb54eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7fa4ad914700 (LWP 3506)):
#0  0x00007fa4ccb4549d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fa4c5cc5f45 in ?? () from /usr/lib/nvidia-346/tls/libnvidia-tls.so.346.59
#2  0x00007fa4c98a22f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa4c985e96c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fa4c985ee60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fa4c985efcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007fa4cd461c6c in QEventDispatcherGlib::processEvents (this=0x7fa4a06dd5c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#7  0x00007fa4cd4063e2 in QEventLoop::exec (this=this@entry=0x7fa4ad913e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#8  0x00007fa4cd1c5b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#9  0x00007fa4cc190f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#10 0x00007fa4cd1cab0e in QThreadPrivate::start (arg=0x1eb62f0) at thread/qthread_unix.cpp:337
#11 0x00007fa4c9d7d6aa in start_thread (arg=0x7fa4ad914700) at pthread_create.c:333
#12 0x00007fa4ccb54eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fa4a643a700 (LWP 3507)):
[KCrash Handler]
#6  0x0000000000000100 in ?? ()
#7  0x00007fa4cbc15628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fa4cbc14d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007fa4a7dd9c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x3a62450, oldNode=0x7fa49cacb850) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007fa4cbc684bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fa4cbc694cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fa4cbc69d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fa4cbc3b1dd in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fa4cbc3c0a1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007fa4cbc3d360 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#16 0x00007fa4cd1cab0e in QThreadPrivate::start (arg=0x3454250) at thread/qthread_unix.cpp:337
#17 0x00007fa4c9d7d6aa in start_thread (arg=0x7fa4a643a700) at pthread_create.c:333
#18 0x00007fa4ccb54eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fa499cfd700 (LWP 3508)):
#0  0x00007fa4ccb498dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fa4c985eebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa4c985efcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa4cd461c6c in QEventDispatcherGlib::processEvents (this=0x7fa4900008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fa4cd4063e2 in QEventLoop::exec (this=this@entry=0x7fa499cfce20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fa4cd1c5b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fa4cc190f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fa4cd1cab0e in QThreadPrivate::start (arg=0x3475720) at thread/qthread_unix.cpp:337
#8  0x00007fa4c9d7d6aa in start_thread (arg=0x7fa499cfd700) at pthread_create.c:333
#9  0x00007fa4ccb54eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fa4d03e5780 (LWP 3058)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fa4cd1cbc6b in wait (time=18446744073709551615, this=0x2319990) at thread/qwaitcondition_unix.cpp:128
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x3454290, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:200
#3  0x00007fa4cbc3ec48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#4  0x00007fa4cbc41a8b in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007fa4cbc4230a in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#6  0x00007fa4cdc407b5 in QWindow::event (this=0x1e3b680, ev=<optimized out>) at kernel/qwindow.cpp:2051
#7  0x00007fa4cbc73dd3 in QQuickWindow::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fa4ce1f4b2c in QApplicationPrivate::notify_helper (this=0x192b550, receiver=0x1e3b680, e=0x7fff2ef60fd0) at kernel/qapplication.cpp:3720
#9  0x00007fa4ce1fa000 in QApplication::notify (this=0x7fff2ef613d0, receiver=0x1e3b680, e=0x7fff2ef60fd0) at kernel/qapplication.cpp:3503
#10 0x00007fa4cd408c2b in QCoreApplication::notifyInternal (this=0x7fff2ef613d0, receiver=receiver@entry=0x1e3b680, event=event@entry=0x7fff2ef60fd0) at kernel/qcoreapplication.cpp:935
#11 0x00007fa4cdc38e86 in sendSpontaneousEvent (event=0x7fff2ef60fd0, receiver=0x1e3b680) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#12 QGuiApplicationPrivate::processExposeEvent (e=0x3b514a0) at kernel/qguiapplication.cpp:2613
#13 0x00007fa4cdc39bbd in QGuiApplicationPrivate::processWindowSystemEvent (e=e@entry=0x3b514a0) at kernel/qguiapplication.cpp:1638
#14 0x00007fa4cdc1e34f in QWindowSystemInterface::sendWindowSystemEvents (flags=...) at kernel/qwindowsysteminterface.cpp:572
#15 0x00007fa4c098e590 in userEventSourceDispatch (source=<optimized out>) at eventdispatchers/qeventdispatcher_glib.cpp:70
#16 0x00007fa4c985ec3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#17 0x00007fa4c985ef20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007fa4c985efcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007fa4cd461c57 in QEventDispatcherGlib::processEvents (this=0x199e5d0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#20 0x00007fa4cd4063e2 in QEventLoop::exec (this=this@entry=0x7fff2ef612b0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#21 0x00007fa4cd40e02c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#22 0x00007fa4cdc2f31c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#23 0x00007fa4ce1f07a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#24 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Philip Collins 2015-05-02 14:18:55 UTC
*** Bug 347044 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Feck 2015-05-02 23:50:18 UTC

*** This bug has been marked as a duplicate of bug 345675 ***