Bug 348707 - system settings window decorations crash
Summary: system settings window decorations crash
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-06-04 17:05 UTC by Gwizo
Modified: 2015-06-07 09:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gwizo 2015-06-04 17:05:22 UTC
Application: systemsettings5 (5.3.1)

Qt Version: 5.4.1
Operating System: Linux 4.1.0-040100rc2-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:

I was accessing System Settings > Windows Decorations Menu.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fd5dc743780 (LWP 3606))]

Thread 6 (Thread 0x7fd5cbaa5700 (LWP 3607)):
#0  0x00007fd5d8ec28dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fd5d71dcb72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fd5d71de64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fd5cdff0099 in QXcbEventReader::run (this=0xce4980) at qxcbconnection.cpp:1105
#4  0x00007fd5d9543b0e in QThreadPrivate::start (arg=0xce4980) at thread/qthread_unix.cpp:337
#5  0x00007fd5d60f66aa in start_thread (arg=0x7fd5cbaa5700) at pthread_create.c:333
#6  0x00007fd5d8ecdeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7fd5bdf78700 (LWP 3611)):
#0  0x00007fd5d8ec28dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fd5d5bd7ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd5d5bd8242 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd5c9525ae6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007fd5d5bfe955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fd5d60f66aa in start_thread (arg=0x7fd5bdf78700) at pthread_create.c:333
#6  0x00007fd5d8ecdeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7fd5bd124700 (LWP 3612)):
#0  0x00007fd5d5c1c789 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fd5d5bd7ea2 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd5d5bd7fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd5d5bd8009 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fd5d5bfe955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fd5d60f66aa in start_thread (arg=0x7fd5bd124700) at pthread_create.c:333
#6  0x00007fd5d8ecdeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fd5bc923700 (LWP 3615)):
#0  0x00007fd5d8ebe49d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fd5d5c1b2f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd5d5bd796c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd5d5bd7e60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fd5d5bd7fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fd5d97dac6c in QEventDispatcherGlib::processEvents (this=0x7fd5b4001390, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#6  0x00007fd5d977f3e2 in QEventLoop::exec (this=this@entry=0x7fd5bc922e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#7  0x00007fd5d953eb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#8  0x00007fd5d8509f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007fd5d9543b0e in QThreadPrivate::start (arg=0x19df250) at thread/qthread_unix.cpp:337
#10 0x00007fd5d60f66aa in start_thread (arg=0x7fd5bc923700) at pthread_create.c:333
#11 0x00007fd5d8ecdeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fd59db54700 (LWP 3616)):
#0  0x00007fd5d8ec28dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fd5d5bd7ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd5d5bd7fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd5d97dac6c in QEventDispatcherGlib::processEvents (this=0x7fd5980008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fd5d977f3e2 in QEventLoop::exec (this=this@entry=0x7fd59db53e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fd5d953eb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fd5d8509f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fd5d9543b0e in QThreadPrivate::start (arg=0x1e64490) at thread/qthread_unix.cpp:337
#8  0x00007fd5d60f66aa in start_thread (arg=0x7fd59db54700) at pthread_create.c:333
#9  0x00007fd5d8ecdeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fd5dc743780 (LWP 3606)):
[KCrash Handler]
#6  0x00007fd5d7f8e625 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#7  0x00007fd5d7f8dd3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fd59fa4ec9a in Plasma::FrameSvgItem::updatePaintNode (this=0x45c20a0, oldNode=0x4f2d580) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#9  0x00007fd5d7fe14bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#10 0x00007fd5d7fe24cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fd5d7fe2d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fd5d7fb1f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fd5d7fb2979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fd5da56db2c in QApplicationPrivate::notify_helper (this=0xccdb10, receiver=0x1a02510, e=0x7fff9060bae0) at kernel/qapplication.cpp:3720
#15 0x00007fd5da573000 in QApplication::notify (this=0x7fff9060be50, receiver=0x1a02510, e=0x7fff9060bae0) at kernel/qapplication.cpp:3503
#16 0x00007fd5d9781c2b in QCoreApplication::notifyInternal (this=0x7fff9060be50, receiver=0x1a02510, event=event@entry=0x7fff9060bae0) at kernel/qcoreapplication.cpp:935
#17 0x00007fd5d97d9ae5 in sendEvent (event=0x7fff9060bae0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#18 QTimerInfoList::activateTimers (this=0xdafc20) at kernel/qtimerinfo_unix.cpp:635
#19 0x00007fd5d97d9f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#20 0x00007fd5d5bd7c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007fd5d5bd7f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fd5d5bd7fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fd5d97dac57 in QEventDispatcherGlib::processEvents (this=0xdafaa0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#24 0x00007fd5d977f3e2 in QEventLoop::exec (this=this@entry=0x7fff9060bd30, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#25 0x00007fd5d978702c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#26 0x00007fd5d9fa831c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#27 0x00007fd5da5697a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#28 0x000000000040ef6b in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:55

Reported using DrKonqi
Comment 1 Christoph Feck 2015-06-07 09:54:56 UTC

*** This bug has been marked as a duplicate of bug 345675 ***