Bug 346707 - System Settings (application style)
Summary: System Settings (application style)
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-04-26 11:28 UTC by Pedro S.
Modified: 2015-04-28 10:40 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro S. 2015-04-26 11:28:18 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-15-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
I was in application style in Look and Feel of Window Titles when it crashed. Looks like it only crahses when im using scroll bar to see more.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb9f6c95780 (LWP 1666))]

Thread 4 (Thread 0x7fb9e640f700 (LWP 1667)):
#0  0x00007fb9f33fb8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fb9f1715b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fb9f171764f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fb9e895a099 in QXcbEventReader::run (this=0xa30590) at qxcbconnection.cpp:1105
#4  0x00007fb9f3a7cb0e in QThreadPrivate::start (arg=0xa30590) at thread/qthread_unix.cpp:337
#5  0x00007fb9f062f6aa in start_thread (arg=0x7fb9e640f700) at pthread_create.c:333
#6  0x00007fb9f3406eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fb9d600f700 (LWP 1668)):
#0  0x00007fb9f33fb8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fb9f0110ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb9f0110fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb9f3d13c6c in QEventDispatcherGlib::processEvents (this=0x7fb9d00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fb9f3cb83e2 in QEventLoop::exec (this=this@entry=0x7fb9d600ee20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fb9f3a77b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fb9f2a42f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fb9f3a7cb0e in QThreadPrivate::start (arg=0x100bbd0) at thread/qthread_unix.cpp:337
#8  0x00007fb9f062f6aa in start_thread (arg=0x7fb9d600f700) at pthread_create.c:333
#9  0x00007fb9f3406eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fb9ce9bb700 (LWP 1669)):
#0  0x00007fb9f33fb8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fb9f0110ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb9f0110fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb9f3d13c6c in QEventDispatcherGlib::processEvents (this=0x7fb9c80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fb9f3cb83e2 in QEventLoop::exec (this=this@entry=0x7fb9ce9bae20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fb9f3a77b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fb9f2a42f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fb9f3a7cb0e in QThreadPrivate::start (arg=0x2c621f0) at thread/qthread_unix.cpp:337
#8  0x00007fb9f062f6aa in start_thread (arg=0x7fb9ce9bb700) at pthread_create.c:333
#9  0x00007fb9f3406eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fb9f6c95780 (LWP 1666)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007fb9f24c7628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fb9f24c6d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007fb9d449cc9a in Plasma::FrameSvgItem::updatePaintNode (this=0x4f5c3e0, oldNode=0x50811c0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007fb9f251a4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fb9f251b4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fb9f251bd80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fb9f24eaf05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fb9f24eb979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007fb9f4aa6b2c in QApplicationPrivate::notify_helper (this=0xa18b10, receiver=0x1017f50, e=0x7ffc406433f0) at kernel/qapplication.cpp:3720
#16 0x00007fb9f4aac000 in QApplication::notify (this=0x7ffc40643760, receiver=0x1017f50, e=0x7ffc406433f0) at kernel/qapplication.cpp:3503
#17 0x00007fb9f3cbac2b in QCoreApplication::notifyInternal (this=0x7ffc40643760, receiver=0x1017f50, event=event@entry=0x7ffc406433f0) at kernel/qcoreapplication.cpp:935
#18 0x00007fb9f3d12ae5 in sendEvent (event=0x7ffc406433f0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0xa604b0) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007fb9f3d12f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007fb9f0110c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fb9f0110f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fb9f0110fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fb9f3d13c57 in QEventDispatcherGlib::processEvents (this=0xa64560, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007fb9f3cb83e2 in QEventLoop::exec (this=this@entry=0x7ffc40643640, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007fb9f3cc002c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007fb9f44e131c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007fb9f4aa27a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-04-28 10:40:09 UTC

*** This bug has been marked as a duplicate of bug 345675 ***