Bug 346965 - System settings crashe after opening Application Style
Summary: System settings crashe after opening Application Style
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-04-30 16:11 UTC by yassine
Modified: 2015-05-02 23:50 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description yassine 2015-04-30 16:11:53 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.5-200.fc21.x86_64 x86_64
Distribution: "Fedora release 21 (Twenty One)"

-- Information about the crash:
- What I was doing when the application crashed:
Exploring settings on plasma 5, it crached on some sub-menus. so nothing special.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
185	62:	movl	(%rsp), %edi
[Current thread is 1 (Thread 0x7f377a5cc880 (LWP 11730))]

Thread 4 (Thread 0x7f376ba1b700 (LWP 12027)):
#0  0x0000003b790f08fd in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x0000003b88401f45 in  () at /lib64/tls/libnvidia-tls.so.340.76
#2  0x0000003b7c08cd00 in g_wakeup_acknowledge (__nbytes=16, __buf=0x7f376ba1ab10, __fd=<optimized out>) at /usr/include/bits/unistd.h:44
#3  0x0000003b7c08cd00 in g_wakeup_acknowledge (wakeup=0x7f376c0015b0) at gwakeup.c:210
#4  0x0000003b7c0495fc in g_main_context_check (context=context@entry=0x7f3764000990, max_priority=2147483647, fds=fds@entry=0x7f3764003070, n_fds=n_fds@entry=1) at gmain.c:3579
#5  0x0000003b7c049ad3 in g_main_context_iterate (context=context@entry=0x7f3764000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3778
#6  0x0000003b7c049c4c in g_main_context_iteration (context=0x7f3764000990, may_block=1) at gmain.c:3842
#7  0x00000035090e67dc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f37640008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#8  0x000000350908bf82 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f376ba1ad20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#9  0x0000003508e9e2f4 in QThread::exec() (this=this@entry=0x2835ef0) at thread/qthread.cpp:503
#10 0x00000035146d7195 in QQmlThreadPrivate::run() (this=0x2835ef0) at /usr/src/debug/qtdeclarative-opensource-src-5.4.1/src/qml/qml/ftw/qqmlthread.cpp:141
#11 0x0000003508ea30ce in QThreadPrivate::start(void*) (arg=0x2835ef0) at thread/qthread_unix.cpp:337
#12 0x0000003b7940752a in start_thread (arg=0x7f376ba1b700) at pthread_create.c:310
#13 0x0000003b7910022d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f37699a9700 (LWP 12028)):
[KCrash Handler]
#6  0x0000003514b49fd5 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) (this=this@entry=0x7f375c64e5d8, texture=texture@entry=0x7f375cabeee0) at /usr/src/debug/qtdeclarative-opensource-src-5.4.1/src/quick/scenegraph/util/qsgtexturematerial.cpp:195
#7  0x0000003514b496ec in QSGSimpleTextureNode::setTexture(QSGTexture*) (this=this@entry=0x7f375c64e4a0, texture=0x7f375cabeee0) at /usr/src/debug/qtdeclarative-opensource-src-5.4.1/src/quick/scenegraph/util/qsgsimpletexturenode.cpp:187
#8  0x00000035158056de in ManagedTextureNode::setTexture(QSharedPointer<QSGTexture>) (this=this@entry=0x7f375c64e4a0, texture=...) at ../../../src/quickaddons/managedtexturenode.cpp:28
#9  0x00007f376a3c1bb2 in Plasma::FrameSvgItem::updatePaintNode(QSGNode*, QQuickItem::UpdatePaintNodeData*) (this=0x38d1050, oldNode=0x7f375c64e4a0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x0000003514b9c73f in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) (this=this@entry=0x2924d80, item=item@entry=0x38d1050) at /usr/src/debug/qtdeclarative-opensource-src-5.4.1/src/quick/items/qquickwindow.cpp:2821
#11 0x0000003514b9d73b in QQuickWindowPrivate::updateDirtyNodes() (this=this@entry=0x2924d80) at /usr/src/debug/qtdeclarative-opensource-src-5.4.1/src/quick/items/qquickwindow.cpp:2646
#12 0x0000003514b9dfe0 in QQuickWindowPrivate::syncSceneGraph() (this=this@entry=0x2924d80) at /usr/src/debug/qtdeclarative-opensource-src-5.4.1/src/quick/items/qquickwindow.cpp:338
#13 0x0000003514b6f8ad in QSGRenderThread::sync(bool) (this=this@entry=0x2d2b400, inExpose=<optimized out>) at /usr/src/debug/qtdeclarative-opensource-src-5.4.1/src/quick/scenegraph/qsgthreadedrenderloop.cpp:510
#14 0x0000003514b70771 in QSGRenderThread::syncAndRender() (this=this@entry=0x2d2b400) at /usr/src/debug/qtdeclarative-opensource-src-5.4.1/src/quick/scenegraph/qsgthreadedrenderloop.cpp:553
#15 0x0000003514b719c0 in QSGRenderThread::run() (this=0x2d2b400) at /usr/src/debug/qtdeclarative-opensource-src-5.4.1/src/quick/scenegraph/qsgthreadedrenderloop.cpp:663
#16 0x0000003508ea30ce in QThreadPrivate::start(void*) (arg=0x2d2b400) at thread/qthread_unix.cpp:337
#17 0x0000003b7940752a in start_thread (arg=0x7f37699a9700) at pthread_create.c:310
#18 0x0000003b7910022d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f3769188700 (LWP 12029)):
#0  0x0000003b790f08fd in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x0000003b88401f45 in  () at /lib64/tls/libnvidia-tls.so.340.76
#2  0x0000003b7c08cd00 in g_wakeup_acknowledge (__nbytes=16, __buf=0x7f3769187b10, __fd=<optimized out>) at /usr/include/bits/unistd.h:44
#3  0x0000003b7c08cd00 in g_wakeup_acknowledge (wakeup=0x7f375c002390) at gwakeup.c:210
#4  0x0000003b7c0495fc in g_main_context_check (context=context@entry=0x7f3760000990, max_priority=2147483647, fds=fds@entry=0x7f3760003070, n_fds=n_fds@entry=1) at gmain.c:3579
#5  0x0000003b7c049ad3 in g_main_context_iterate (context=context@entry=0x7f3760000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3778
#6  0x0000003b7c049c4c in g_main_context_iteration (context=0x7f3760000990, may_block=1) at gmain.c:3842
#7  0x00000035090e67dc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x7f37600008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#8  0x000000350908bf82 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7f3769187d20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#9  0x0000003508e9e2f4 in QThread::exec() (this=this@entry=0x2f351c0) at thread/qthread.cpp:503
#10 0x00000035146d7195 in QQmlThreadPrivate::run() (this=0x2f351c0) at /usr/src/debug/qtdeclarative-opensource-src-5.4.1/src/qml/qml/ftw/qqmlthread.cpp:141
#11 0x0000003508ea30ce in QThreadPrivate::start(void*) (arg=0x2f351c0) at thread/qthread_unix.cpp:337
#12 0x0000003b7940752a in start_thread (arg=0x7f3769188700) at pthread_create.c:310
#13 0x0000003b7910022d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f377a5cc880 (LWP 11730)):
#0  0x0000003b7940c590 in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x0000003508ea421b in QWaitCondition::wait(QMutex*, unsigned long) (time=18446744073709551615, this=0x2894fe0) at thread/qwaitcondition_unix.cpp:128
#2  0x0000003508ea421b in QWaitCondition::wait(QMutex*, unsigned long) (this=<optimized out>, mutex=0x2d2b440, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:200
#3  0x0000003514b73278 in QSGThreadedRenderLoop::polishAndSync(QSGThreadedRenderLoop::Window*, bool) (this=this@entry=0x285c760, w=<optimized out>, inExpose=inExpose@entry=false) at /usr/src/debug/qtdeclarative-opensource-src-5.4.1/src/quick/scenegraph/qsgthreadedrenderloop.cpp:1128
#4  0x0000003514b742dd in QSGThreadedRenderLoop::event(QEvent*) (this=0x285c760, e=0x7ffddfe014e0) at /usr/src/debug/qtdeclarative-opensource-src-5.4.1/src/quick/scenegraph/qsgthreadedrenderloop.cpp:1190
#5  0x000000350a15b95c in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=this@entry=0x23a53f0, receiver=receiver@entry=0x285c760, e=e@entry=0x7ffddfe014e0) at kernel/qapplication.cpp:3720
#6  0x000000350a160da0 in QApplication::notify(QObject*, QEvent*) (this=0x7ffddfe01850, receiver=0x285c760, e=0x7ffddfe014e0) at kernel/qapplication.cpp:3503
#7  0x000000350908e6eb in QCoreApplication::notifyInternal(QObject*, QEvent*) (this=0x7ffddfe01850, receiver=0x285c760, event=event@entry=0x7ffddfe014e0) at kernel/qcoreapplication.cpp:935
#8  0x00000035090e56f5 in QTimerInfoList::activateTimers() (event=0x7ffddfe014e0, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:228
#9  0x00000035090e56f5 in QTimerInfoList::activateTimers() (this=0x2429060) at kernel/qtimerinfo_unix.cpp:635
#10 0x00000035090e5b21 in timerSourceDispatch(GSource*, GSourceFunc, gpointer) (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#11 0x0000003b7c0497fb in g_main_context_dispatch (context=0x7f376c001710) at gmain.c:3111
#12 0x0000003b7c0497fb in g_main_context_dispatch (context=context@entry=0x7f376c001710) at gmain.c:3710
#13 0x0000003b7c049b98 in g_main_context_iterate (context=context@entry=0x7f376c001710, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3781
#14 0x0000003b7c049c4c in g_main_context_iteration (context=0x7f376c001710, may_block=1) at gmain.c:3842
#15 0x00000035090e67c7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x24347e0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#16 0x000000350908bf82 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7ffddfe01730, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#17 0x0000003509093a2c in QCoreApplication::exec() () at kernel/qcoreapplication.cpp:1188
#18 0x00000035094e2f9c in QGuiApplication::exec() () at kernel/qguiapplication.cpp:1507
#19 0x000000350a157645 in QApplication::exec() () at kernel/qapplication.cpp:2956
#20 0x000000000040e9fc in main(int, char**) (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-02 23:50:53 UTC

*** This bug has been marked as a duplicate of bug 345675 ***