Bug 348011 - System Settings persistent crashing.
Summary: System Settings persistent crashing.
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-20 14:28 UTC by John Hunter
Modified: 2015-05-23 14:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Hunter 2015-05-20 14:28:41 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-16-generic i686
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:

I was in "Window Decoations" browsing through a collection of alternative styles. The System Settings crashed consitently as I tried to scroll from the second window full to the third. This is an Lenovo Flex 14 laptop with a 1920x1080 screen. There is 6GB ram, so I do not think that it was running out of primary memory.

I have just installed Kubuntu 15.04 over Debian 8 (which was rather user hostile!). By all means contact me at jmdh01@btinternet.com.

John Hunter

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb293d700 (LWP 6147))]

Thread 4 (Thread 0xb2537b40 (LWP 6148)):
#0  0xb770bbe0 in __kernel_vsyscall ()
#1  0xb5cd13db in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0xb4f8a3a8 in ?? () from /usr/lib/i386-linux-gnu/libxcb.so.1
#3  0xb4f8c394 in xcb_wait_for_event () from /usr/lib/i386-linux-gnu/libxcb.so.1
#4  0xb268f7d3 in QXcbEventReader::run (this=0x9b7ed58) at qxcbconnection.cpp:1105
#5  0xb5f2c7eb in QThreadPrivate::start (arg=0x9b7ed58) at thread/qthread_unix.cpp:337
#6  0xb4b951aa in start_thread (arg=0xb2537b40) at pthread_create.c:333
#7  0xb5cdbfde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 3 (Thread 0xaebfbb40 (LWP 6159)):
#0  0xb770bbe0 in __kernel_vsyscall ()
#1  0xb5ccb75b in read () at ../sysdeps/unix/syscall-template.S:81
#2  0xb4a96515 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4a50a82 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4a50faa in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb4a51156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb61b39fc in QEventDispatcherGlib::processEvents (this=0xae200468, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#7  0xb6154d93 in QEventLoop::processEvents (this=0xaebfb2d4, flags=...) at kernel/qeventloop.cpp:128
#8  0xb61551fa in QEventLoop::exec (this=0xaebfb2d4, flags=...) at kernel/qeventloop.cpp:204
#9  0xb5f2740d in QThread::exec (this=0xa41a148) at thread/qthread.cpp:503
#10 0xb589050f in ?? () from /usr/lib/i386-linux-gnu/libQt5Qml.so.5
#11 0xb5f2c7eb in QThreadPrivate::start (arg=0xa41a148) at thread/qthread_unix.cpp:337
#12 0xb4b951aa in start_thread (arg=0xaebfbb40) at pthread_create.c:333
#13 0xb5cdbfde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 2 (Thread 0xad0c1b40 (LWP 6160)):
#0  0xb770bbe0 in __kernel_vsyscall ()
#1  0xb5cd13db in poll () at ../sysdeps/unix/syscall-template.S:81
#2  0xb4a60120 in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4a51014 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4a51156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb61b39fc in QEventDispatcherGlib::processEvents (this=0xac700468, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#6  0xb6154d93 in QEventLoop::processEvents (this=0xad0c12d4, flags=...) at kernel/qeventloop.cpp:128
#7  0xb61551fa in QEventLoop::exec (this=0xad0c12d4, flags=...) at kernel/qeventloop.cpp:204
#8  0xb5f2740d in QThread::exec (this=0xa686dd0) at thread/qthread.cpp:503
#9  0xb589050f in ?? () from /usr/lib/i386-linux-gnu/libQt5Qml.so.5
#10 0xb5f2c7eb in QThreadPrivate::start (arg=0xa686dd0) at thread/qthread_unix.cpp:337
#11 0xb4b951aa in start_thread (arg=0xad0c1b40) at pthread_create.c:333
#12 0xb5cdbfde in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 1 (Thread 0xb293d700 (LWP 6147)):
[KCrash Handler]
#7  0x00000000 in ?? ()
#8  0xb52b5f0a in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#9  0xb52b54c7 in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#10 0xb51aa188 in ManagedTextureNode::setTexture(QSharedPointer<QSGTexture>) () from /usr/lib/i386-linux-gnu/libKF5QuickAddons.so.5
#11 0xad8e7a5e in Plasma::FrameSvgItem::updatePaintNode (this=0xac4cba8, oldNode=0xaa8ad60) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#12 0xb530d8e5 in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#13 0xb530e7dd in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#14 0xb530f0c3 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#15 0xb52db667 in ?? () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#16 0xb52dc2a8 in ?? () from /usr/lib/i386-linux-gnu/libQt5Quick.so.5
#17 0xb6bd982a in QApplicationPrivate::notify_helper (this=0x9b6d390, receiver=0xa4b6430, e=0xbf8d0bfc) at kernel/qapplication.cpp:3720
#18 0xb6bdf081 in QApplication::notify (this=0xbf8d0f00, receiver=0xa4b6430, e=0xbf8d0bfc) at kernel/qapplication.cpp:3503
#19 0xb6157b8a in QCoreApplication::notifyInternal (this=0xbf8d0f00, receiver=0xa4b6430, event=0xbf8d0bfc) at kernel/qcoreapplication.cpp:935
#20 0xb61b2808 in sendEvent (event=0xbf8d0bfc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#21 QTimerInfoList::activateTimers (this=0x9b9c25c) at kernel/qtimerinfo_unix.cpp:635
#22 0xb61b2cd9 in timerSourceDispatch (source=0x9b9c228) at kernel/qeventdispatcher_glib.cpp:177
#23 0xb4a50d64 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0xb4a51089 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#25 0xb4a51156 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#26 0xb61b39fc in QEventDispatcherGlib::processEvents (this=0x9b99b00, flags=...) at kernel/qeventdispatcher_glib.cpp:420
#27 0xb26bc611 in QPAEventDispatcherGlib::processEvents (this=0x9b99b00, flags=...) at eventdispatchers/qeventdispatcher_glib.cpp:115
#28 0xb6154d93 in QEventLoop::processEvents (this=0xbf8d0e38, flags=...) at kernel/qeventloop.cpp:128
#29 0xb61551fa in QEventLoop::exec (this=0xbf8d0e38, flags=...) at kernel/qeventloop.cpp:204
#30 0xb615d315 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#31 0xb6610a41 in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#32 0xb6bd4da4 in QApplication::exec () at kernel/qapplication.cpp:2956
#33 0x08053f85 in main (argc=1, argv=0xbf8d0fd4) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-23 14:35:42 UTC

*** This bug has been marked as a duplicate of bug 345675 ***