Bug 354992 - crash of systemsettings on entering window border setting
Summary: crash of systemsettings on entering window border setting
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-11-07 14:09 UTC by jimy byerley
Modified: 2015-11-16 01:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jimy byerley 2015-11-07 14:09:24 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-32-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
I was in the main menu of system settings, switching to window appearance and directly to window border, after few seconds (1-10) systemsettings crashes. Even if I come from an other tab of the window appearance menu, when I switch to window border it crashes.
I recently installed a window border theme I don't remember, but I can't have its name because I can't use this menu

The crash can be reproduced every time.

-- Backtrace:
Application: Configuration du système (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7f3c1ef7c780 (LWP 2610))]

Thread 6 (Thread 0x7f3c0f7e6700 (LWP 2611)):
#0  0x00007f3c1b6ea8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f3c19a04b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f3c19a0664f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f3c12579099 in QXcbEventReader::run (this=0x14ad910) at qxcbconnection.cpp:1105
#4  0x00007f3c1bd6bb0e in QThreadPrivate::start (arg=0x14ad910) at thread/qthread_unix.cpp:337
#5  0x00007f3c1891e6aa in start_thread (arg=0x7f3c0f7e6700) at pthread_create.c:333
#6  0x00007f3c1b6f5eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f3bfcd6a700 (LWP 2612)):
#0  0x00007f3c1b6b9c4d in nanosleep () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f3c1b6ece84 in usleep (useconds=<optimized out>) at ../sysdeps/unix/sysv/linux/usleep.c:32
#2  0x00007f3c02e39d00 in ?? () from /usr/lib/dri/fglrx_dri.so
#3  0x00007f3c0253a332 in ?? () from /usr/lib/dri/fglrx_dri.so
#4  0x00007f3c0253a385 in ?? () from /usr/lib/dri/fglrx_dri.so
#5  0x00007f3c1891e6aa in start_thread (arg=0x7f3bfcd6a700) at pthread_create.c:333
#6  0x00007f3c1b6f5eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f3bf7fff700 (LWP 2613)):
#0  0x00007f3c1b6ea8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f3c183ffebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f3c183fffcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f3c1c002c6c in QEventDispatcherGlib::processEvents (this=0x7f3bf00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f3c1bfa73e2 in QEventLoop::exec (this=this@entry=0x7f3bf7ffee20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f3c1bd66b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f3c1ad31f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f3c1bd6bb0e in QThreadPrivate::start (arg=0x19b27d0) at thread/qthread_unix.cpp:337
#8  0x00007f3c1891e6aa in start_thread (arg=0x7f3bf7fff700) at pthread_create.c:333
#9  0x00007f3c1b6f5eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f3bf4ba0700 (LWP 2614)):
#0  0x00007f3c183ff9f2 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f3c183fff20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f3c183fffcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f3c1c002c6c in QEventDispatcherGlib::processEvents (this=0x7f3be80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f3c1bfa73e2 in QEventLoop::exec (this=this@entry=0x7f3bf4b9fe20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f3c1bd66b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f3c1ad31f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f3c1bd6bb0e in QThreadPrivate::start (arg=0x1e92310) at thread/qthread_unix.cpp:337
#8  0x00007f3c1891e6aa in start_thread (arg=0x7f3bf4ba0700) at pthread_create.c:333
#9  0x00007f3c1b6f5eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f3bef5f7700 (LWP 2615)):
[KCrash Handler]
#6  0x0000000000000070 in ?? ()
#7  0x00007f3c1a7b6628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f3c1a7b5d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f3c1a465d9e in ManagedTextureNode::setTexture (this=<optimized out>, texture=...) at ../../../src/quickaddons/managedtexturenode.cpp:28
#10 0x00007f3bf68bac9a in Plasma::FrameSvgItem::updatePaintNode (this=0x2b89190, oldNode=0x7f3be44beea0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#11 0x00007f3c1a8094bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f3c1a80a4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f3c1a80ad80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f3c1a7dc1dd in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f3c1a7dd0a1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#16 0x00007f3c1a7de360 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#17 0x00007f3c1bd6bb0e in QThreadPrivate::start (arg=0x19d9180) at thread/qthread_unix.cpp:337
#18 0x00007f3c1891e6aa in start_thread (arg=0x7f3bef5f7700) at pthread_create.c:333
#19 0x00007f3c1b6f5eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f3c1ef7c780 (LWP 2610)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f3c1bd6cc6b in wait (time=18446744073709551615, this=0x1ba6000) at thread/qwaitcondition_unix.cpp:128
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x19d91c0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:200
#3  0x00007f3c1a7dfc48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#4  0x00007f3c1a7e0cad in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#5  0x00007f3c1cd95b2c in QApplicationPrivate::notify_helper (this=0x1494e70, receiver=0x1982dd0, e=0x7ffd9822df60) at kernel/qapplication.cpp:3720
#6  0x00007f3c1cd9b000 in QApplication::notify (this=0x7ffd9822e2d0, receiver=0x1982dd0, e=0x7ffd9822df60) at kernel/qapplication.cpp:3503
#7  0x00007f3c1bfa9c2b in QCoreApplication::notifyInternal (this=0x7ffd9822e2d0, receiver=0x1982dd0, event=event@entry=0x7ffd9822df60) at kernel/qcoreapplication.cpp:935
#8  0x00007f3c1c001ae5 in sendEvent (event=0x7ffd9822df60, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#9  QTimerInfoList::activateTimers (this=0x14e2430) at kernel/qtimerinfo_unix.cpp:635
#10 0x00007f3c1c001f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#11 0x00007f3c183ffc3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#12 0x00007f3c183fff20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#13 0x00007f3c183fffcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#14 0x00007f3c1c002c57 in QEventDispatcherGlib::processEvents (this=0x14e71a0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#15 0x00007f3c1bfa73e2 in QEventLoop::exec (this=this@entry=0x7ffd9822e1b0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#16 0x00007f3c1bfaf02c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#17 0x00007f3c1c7d031c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#18 0x00007f3c1cd917a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#19 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-11-16 01:15:16 UTC

*** This bug has been marked as a duplicate of bug 345675 ***