Bug 348849 - kdeinit5 crashed when using Evanos Window Decoration
Summary: kdeinit5 crashed when using Evanos Window Decoration
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-06-07 16:15 UTC by Micha
Modified: 2015-06-16 17:23 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Micha 2015-06-07 16:15:30 UTC
Application: kdeinit5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-18-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- I installed Evanos window decoration
- I did not find it good, so i wanted to switch back to default
- I right-clicked on the titlebar of the terminal and tried to change it that way.
- The Settings opened, and even before i could click on it, it crashed. (segmentation fault: 11)
I was able repeat this, but after disabling that Evanos (It worked via the Settings Program) it worked again.

The crash can be reproduced every time.

-- Backtrace:
Application: KDE-Kontrollmodul (kdeinit5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7faa212d2780 (LWP 19881))]

Thread 5 (Thread 0x7faa0c57a700 (LWP 19882)):
#0  0x00007faa1f9cc8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007faa1dec3b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007faa1dec564f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007faa0e49e099 in QXcbEventReader::run (this=0x1383d70) at qxcbconnection.cpp:1105
#4  0x00007faa1fd3eb0e in QThreadPrivate::start (arg=0x1383d70) at thread/qthread_unix.cpp:337
#5  0x00007faa1d6176aa in start_thread (arg=0x7faa0c57a700) at pthread_create.c:333
#6  0x00007faa1f9d7eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7faa01feb700 (LWP 19884)):
#0  0x00007faa1f9c849d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007faa1cbfe2f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007faa1cbba96c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007faa1cbbae60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007faa1cbbafcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007faa1ffd5c6c in QEventDispatcherGlib::processEvents (this=0x7fa9fc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#6  0x00007faa1ff7a3e2 in QEventLoop::exec (this=this@entry=0x7faa01feae20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#7  0x00007faa1fd39b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#8  0x00007faa10a24f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007faa1fd3eb0e in QThreadPrivate::start (arg=0x1515530) at thread/qthread_unix.cpp:337
#10 0x00007faa1d6176aa in start_thread (arg=0x7faa01feb700) at pthread_create.c:333
#11 0x00007faa1f9d7eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fa9f9df7700 (LWP 19885)):
#0  0x00007faa1f9cc8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007faa1cbbaebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007faa1cbbafcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007faa1ffd5c6c in QEventDispatcherGlib::processEvents (this=0x7fa9f40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007faa1ff7a3e2 in QEventLoop::exec (this=this@entry=0x7fa9f9df6e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007faa1fd39b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007faa10a24f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007faa1fd3eb0e in QThreadPrivate::start (arg=0x1b10d10) at thread/qthread_unix.cpp:337
#8  0x00007faa1d6176aa in start_thread (arg=0x7fa9f9df7700) at pthread_create.c:333
#9  0x00007faa1f9d7eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fa9f2fe6700 (LWP 19886)):
#0  0x00007faa1cbff7a4 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007faa1cbbaeb1 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007faa1cbbafcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007faa1ffd5c6c in QEventDispatcherGlib::processEvents (this=0x7fa9ec0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007faa1ff7a3e2 in QEventLoop::exec (this=this@entry=0x7fa9f2fe5e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007faa1fd39b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007faa10a24f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007faa1fd3eb0e in QThreadPrivate::start (arg=0x1e61f40) at thread/qthread_unix.cpp:337
#8  0x00007faa1d6176aa in start_thread (arg=0x7fa9f2fe6700) at pthread_create.c:333
#9  0x00007faa1f9d7eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7faa212d2780 (LWP 19881)):
[KCrash Handler]
#6  0x0000006500000065 in ?? ()
#7  0x00007faa104a9628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007faa104a8d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007faa00ab1c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x4a38db0, oldNode=0x4b65300) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007faa104fc4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007faa104fd4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007faa104fdd80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007faa104ccf05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007faa104cd979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007faa1e43ab2c in QApplicationPrivate::notify_helper (this=0x136f590, receiver=0x15842e0, e=0x7ffdec7c7c60) at kernel/qapplication.cpp:3720
#16 0x00007faa1e440000 in QApplication::notify (this=0x7ffdec7c8030, receiver=0x15842e0, e=0x7ffdec7c7c60) at kernel/qapplication.cpp:3503
#17 0x00007faa1ff7cc2b in QCoreApplication::notifyInternal (this=0x7ffdec7c8030, receiver=0x15842e0, event=event@entry=0x7ffdec7c7c60) at kernel/qcoreapplication.cpp:935
#18 0x00007faa1ffd4ae5 in sendEvent (event=0x7ffdec7c7c60, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x13a8200) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007faa1ffd4f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007faa1cbbac3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007faa1cbbaf20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007faa1cbbafcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007faa1ffd5c57 in QEventDispatcherGlib::processEvents (this=0x139fe30, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007faa1ff7a3e2 in QEventLoop::exec (this=this@entry=0x7ffdec7c7ec0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007faa1e63c4b5 in QDialog::exec (this=0x1448fe0) at dialogs/qdialog.cpp:541
#27 0x00007faa0fdfd9cb in kdemain (_argc=<optimized out>, _argv=<optimized out>) at ../../kcmshell/main.cpp:307
#28 0x0000000000408716 in launch (argc=argc@entry=14, _name=_name@entry=0x1356098 "kcmshell5", args=<optimized out>, args@entry=0x13560a2 "--icon", cwd=cwd@entry=0x0, envc=envc@entry=0, envs=<optimized out>, envs@entry=0x1356156 "", reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40b710 "0") at ../../../src/kdeinit/kinit.cpp:741
#29 0x000000000040a132 in handle_launcher_request (sock=8, who=who@entry=0x40b6c6 "launcher") at ../../../src/kdeinit/kinit.cpp:1180
#30 0x000000000040a6ee in handle_requests (waitForPid=waitForPid@entry=0) at ../../../src/kdeinit/kinit.cpp:1369
#31 0x000000000040501b in main (argc=5, argv=<optimized out>) at ../../../src/kdeinit/kinit.cpp:1860

Reported using DrKonqi
Comment 1 Christoph Feck 2015-06-16 17:23:23 UTC

*** This bug has been marked as a duplicate of bug 345675 ***