Bug 348706 - System Settings window crashes
Summary: System Settings window crashes
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-06-04 17:05 UTC by jerrykar
Modified: 2015-06-07 09:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jerrykar 2015-06-04 17:05:21 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-18-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
failure of system settings by clicking style and design programs windows system settings window closes and wświetla message: Executable file systemsettings5 PID: 5438Sygnał: Segmentation fault (11) Time: 6/4/2015 6:00:47 p.m.

-- Backtrace:
Application: Ustawienia systemowe (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f769ea22780 (LWP 5101))]

Thread 5 (Thread 0x7f768e071700 (LWP 5102)):
#0  0x00007f769b18d8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f76994a7b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f76994a964f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f76905bc099 in QXcbEventReader::run (this=0x19f3300) at qxcbconnection.cpp:1105
#4  0x00007f769b80eb0e in QThreadPrivate::start (arg=0x19f3300) at thread/qthread_unix.cpp:337
#5  0x00007f76983c16aa in start_thread (arg=0x7f768e071700) at pthread_create.c:333
#6  0x00007f769b198eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f76786e9700 (LWP 5107)):
#0  0x00007f769b18d8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f7697ea2ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7697ea3242 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7684740ae6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f7697ec9955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f76983c16aa in start_thread (arg=0x7f76786e9700) at pthread_create.c:333
#6  0x00007f769b198eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f76773e5700 (LWP 5108)):
#0  0x00007f769b18949d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f7697ee62f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7697ea296c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7697ea2e60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f7697ea2fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f769baa5c6c in QEventDispatcherGlib::processEvents (this=0x7f76680008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#6  0x00007f769ba4a3e2 in QEventLoop::exec (this=this@entry=0x7f76773e4e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#7  0x00007f769b809b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#8  0x00007f769a7d4f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007f769b80eb0e in QThreadPrivate::start (arg=0x2295a40) at thread/qthread_unix.cpp:337
#10 0x00007f76983c16aa in start_thread (arg=0x7f76773e5700) at pthread_create.c:333
#11 0x00007f769b198eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f766fd59700 (LWP 5109)):
#0  0x00007f769b18d8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f7697ea2ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7697ea2fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f769baa5c6c in QEventDispatcherGlib::processEvents (this=0x7f76640008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f769ba4a3e2 in QEventLoop::exec (this=this@entry=0x7f766fd58e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f769b809b44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f769a7d4f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f769b80eb0e in QThreadPrivate::start (arg=0x2519770) at thread/qthread_unix.cpp:337
#8  0x00007f76983c16aa in start_thread (arg=0x7f766fd59700) at pthread_create.c:333
#9  0x00007f769b198eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f769ea22780 (LWP 5101)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f769a259628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f769a258d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f7675ddfc9a in Plasma::FrameSvgItem::updatePaintNode (this=0x443f9d0, oldNode=0x4d334f0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f769a2ac4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f769a2ad4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f769a2add80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f769a27cf05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f769a27d979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f769c838b2c in QApplicationPrivate::notify_helper (this=0x19dbb10, receiver=0x1f87da0, e=0x7ffe65f85390) at kernel/qapplication.cpp:3720
#16 0x00007f769c83e000 in QApplication::notify (this=0x7ffe65f85700, receiver=0x1f87da0, e=0x7ffe65f85390) at kernel/qapplication.cpp:3503
#17 0x00007f769ba4cc2b in QCoreApplication::notifyInternal (this=0x7ffe65f85700, receiver=0x1f87da0, event=event@entry=0x7ffe65f85390) at kernel/qcoreapplication.cpp:935
#18 0x00007f769baa4ae5 in sendEvent (event=0x7ffe65f85390, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x1a26630) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f769baa4f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f7697ea2c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f7697ea2f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f7697ea2fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f769baa5c57 in QEventDispatcherGlib::processEvents (this=0x1a1ebb0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f769ba4a3e2 in QEventLoop::exec (this=this@entry=0x7ffe65f855e0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f769ba5202c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f769c27331c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f769c8347a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-06-07 09:54:37 UTC

*** This bug has been marked as a duplicate of bug 345675 ***