Bug 347953 - System setting crashes
Summary: System setting crashes
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-19 14:26 UTC by Pragalathan
Modified: 2015-05-23 14:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pragalathan 2015-05-19 14:26:10 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-16-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
Trying to install new window decoration. After installing new docorations, the window started crashing permanently.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8222b05780 (LWP 3059))]

Thread 6 (Thread 0x7f8212288700 (LWP 3060)):
#0  0x00007f821f2738dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f821d58db72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f821d58f64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f82147d3099 in QXcbEventReader::run (this=0x165e660) at qxcbconnection.cpp:1105
#4  0x00007f821f8f4b0e in QThreadPrivate::start (arg=0x165e660) at thread/qthread_unix.cpp:337
#5  0x00007f821c4a76aa in start_thread (arg=0x7f8212288700) at pthread_create.c:333
#6  0x00007f821f27eeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f82074c1700 (LWP 3061)):
#0  0x00007f821f2738dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f821bf88ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f821bf89242 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f820bb3dae6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f821bfaf955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f821c4a76aa in start_thread (arg=0x7f82074c1700) at pthread_create.c:333
#6  0x00007f821f27eeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f8206cc0700 (LWP 3062)):
#0  0x00007f821bfcd789 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f821bf882d7 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f821bf88de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f821bf88fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f821bf89009 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f821bfaf955 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f821c4a76aa in start_thread (arg=0x7f8206cc0700) at pthread_create.c:333
#7  0x00007f821f27eeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f82064bf700 (LWP 3065)):
#0  0x00007f821f26f49d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f821bfcc2f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f821bf8896c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f821bf88e60 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f821bf88fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f821fb8bc6c in QEventDispatcherGlib::processEvents (this=0x7f81fc001390, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#6  0x00007f821fb303e2 in QEventLoop::exec (this=this@entry=0x7f82064bee20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#7  0x00007f821f8efb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#8  0x00007f821e8baf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007f821f8f4b0e in QThreadPrivate::start (arg=0x254e6d0) at thread/qthread_unix.cpp:337
#10 0x00007f821c4a76aa in start_thread (arg=0x7f82064bf700) at pthread_create.c:333
#11 0x00007f821f27eeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f81e6cd9700 (LWP 3066)):
#0  0x00007f821f2738dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f821bf88ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f821bf88fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f821fb8bc6c in QEventDispatcherGlib::processEvents (this=0x7f81e00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f821fb303e2 in QEventLoop::exec (this=this@entry=0x7f81e6cd8e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f821f8efb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f821e8baf65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f821f8f4b0e in QThreadPrivate::start (arg=0x26700d0) at thread/qthread_unix.cpp:337
#8  0x00007f821c4a76aa in start_thread (arg=0x7f81e6cd9700) at pthread_create.c:333
#9  0x00007f821f27eeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f8222b05780 (LWP 3059)):
[KCrash Handler]
#6  0x0000000000000070 in ?? ()
#7  0x00007f821e33f628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f821e33ed3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f81e8663c9a in Plasma::FrameSvgItem::updatePaintNode (this=0x4df4bb0, oldNode=0x4f21550) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f821e3924bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f821e3934cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f821e393d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f821e362f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f821e363979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f822091eb2c in QApplicationPrivate::notify_helper (this=0x1647b10, receiver=0x254e080, e=0x7ffe8087a600) at kernel/qapplication.cpp:3720
#16 0x00007f8220924000 in QApplication::notify (this=0x7ffe8087a970, receiver=0x254e080, e=0x7ffe8087a600) at kernel/qapplication.cpp:3503
#17 0x00007f821fb32c2b in QCoreApplication::notifyInternal (this=0x7ffe8087a970, receiver=0x254e080, event=event@entry=0x7ffe8087a600) at kernel/qcoreapplication.cpp:935
#18 0x00007f821fb8aae5 in sendEvent (event=0x7ffe8087a600, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x16dd670) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f821fb8af61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f821bf88c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f821bf88f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f821bf88fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f821fb8bc57 in QEventDispatcherGlib::processEvents (this=0x16dd470, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f821fb303e2 in QEventLoop::exec (this=this@entry=0x7ffe8087a850, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f821fb3802c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f822035931c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f822091a7a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-23 14:35:08 UTC

*** This bug has been marked as a duplicate of bug 345675 ***