Bug 346708 - 'System settings' crashes on selection of selector for 'window decoration'
Summary: 'System settings' crashes on selection of selector for 'window decoration'
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-04-26 11:37 UTC by Mark
Modified: 2015-04-28 10:41 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark 2015-04-26 11:37:37 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-15-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed:
1. Opened 'system settings'
2. Double clicked 'Application Style'
3. Selected 'window decoration' by single click
=> crash of application window 'system settings'

This behaviour is reproducable on my machine.
Shortly after system start-up I was able to view this setting, but never again after.

Right after Step 3 I get a short glimpse on the selectable items before the application window disappears because of the crash.

-- Backtrace:
Application: Systemeinstellungen (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7f6bf2af0780 (LWP 4864))]

Thread 6 (Thread 0x7f6be0185700 (LWP 4865)):
#0  0x00007f6bef25b8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f6bed575b72 in  () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f6bed57764f in xcb_wait_for_event () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f6be2f40099 in  () at /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms/libqxcb.so
#4  0x00007f6bef8dcb0e in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f6bec48f6aa in start_thread (arg=0x7f6be0185700) at pthread_create.c:333
#6  0x00007f6bef266eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f6bbe1f7700 (LWP 4873)):
#0  0x00007f6bef25b8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f6bebf70ebc in g_main_context_iterate (priority=2147483647, n_fds=1, fds=0x7f6bb0003070, timeout=-1, context=0x7f6bb0000990) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:4103
#2  0x00007f6bebf70ebc in g_main_context_iterate (context=context@entry=0x7f6bb0000990, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:3803
#3  0x00007f6bebf70fcc in g_main_context_iteration (context=0x7f6bb0000990, may_block=1) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:3869
#4  0x00007f6befb73c6c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f6befb183e2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f6bef8d7b44 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f6bef8dcb0e in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f6bec48f6aa in start_thread (arg=0x7f6bbe1f7700) at pthread_create.c:333
#9  0x00007f6bef266eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f6bafdf7700 (LWP 5150)):
#0  0x00007f6bef25b8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f6bebf70ebc in g_main_context_iterate (priority=2147483647, n_fds=1, fds=0x7f6ba8003860, timeout=-1, context=0x7f6ba8150830) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:4103
#2  0x00007f6bebf70ebc in g_main_context_iterate (context=context@entry=0x7f6ba8150830, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:3803
#3  0x00007f6bebf70fcc in g_main_context_iteration (context=0x7f6ba8150830, may_block=1) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:3869
#4  0x00007f6befb73c6c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f6befb183e2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f6bef8d7b44 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f6bee8a2f65 in  () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f6bef8dcb0e in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f6bec48f6aa in start_thread (arg=0x7f6bafdf7700) at pthread_create.c:333
#10 0x00007f6bef266eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f6bbd12a700 (LWP 5151)):
[KCrash Handler]
#6  0x00007f6bee327625 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#7  0x00007f6bee326d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f6bcb2f3c9a in  () at /usr/lib/x86_64-linux-gnu/qt5/qml/org/kde/plasma/core/libcorebindingsplugin.so
#9  0x00007f6bee37a4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#10 0x00007f6bee37b4cb in QQuickWindowPrivate::updateDirtyNodes() () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f6bee37bd80 in QQuickWindowPrivate::syncSceneGraph() () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f6bee34d1dd in  () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f6bee34e0a1 in  () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f6bee34f360 in  () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f6bef8dcb0e in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#16 0x00007f6bec48f6aa in start_thread (arg=0x7f6bbd12a700) at pthread_create.c:333
#17 0x00007f6bef266eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f6bc9954700 (LWP 5152)):
#0  0x00007f6bebf6dec7 in g_source_iter_next (iter=iter@entry=0x7f6bc9953c60, source=source@entry=0x7f6bc9953c58) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:902
#1  0x00007f6bebf7039b in g_main_context_prepare (context=context@entry=0x7f6bc411ea70, priority=priority@entry=0x7f6bc9953ce0) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:3388
#2  0x00007f6bebf70de8 in g_main_context_iterate (context=context@entry=0x7f6bc411ea70, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:3788
#3  0x00007f6bebf70fcc in g_main_context_iteration (context=0x7f6bc411ea70, may_block=1) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:3869
#4  0x00007f6befb73c6c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f6befb183e2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f6bef8d7b44 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f6bee8a2f65 in  () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f6bef8dcb0e in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f6bec48f6aa in start_thread (arg=0x7f6bc9954700) at pthread_create.c:333
#10 0x00007f6bef266eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f6bf2af0780 (LWP 4864)):
#0  0x00007f6bec494da0 in pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f6bef8ddc6b in QWaitCondition::wait(QMutex*, unsigned long) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#2  0x00007f6bee350c48 in  () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#3  0x00007f6bee351cad in  () at /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#4  0x00007f6bf0906b2c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#5  0x00007f6bf090c000 in QApplication::notify(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#6  0x00007f6befb1ac2b in QCoreApplication::notifyInternal(QObject*, QEvent*) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#7  0x00007f6befb72ae5 in QTimerInfoList::activateTimers() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f6befb72f61 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f6bebf70c3d in g_main_context_dispatch (context=0x7f6bd8001710) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:3122
#10 0x00007f6bebf70c3d in g_main_context_dispatch (context=context@entry=0x7f6bd8001710) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:3737
#11 0x00007f6bebf70f20 in g_main_context_iterate (context=context@entry=0x7f6bd8001710, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:3808
#12 0x00007f6bebf70fcc in g_main_context_iteration (context=0x7f6bd8001710, may_block=1) at /build/buildd/glib2.0-2.44.0/./glib/gmain.c:3869
#13 0x00007f6befb73c57 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007f6befb183e2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#15 0x00007f6befb2002c in QCoreApplication::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#16 0x000000000040eebc in main ()

Reported using DrKonqi
Comment 1 Christoph Feck 2015-04-28 10:41:00 UTC

*** This bug has been marked as a duplicate of bug 345675 ***