Bug 347954 - System Settings->Application Style->Window Decorations
Summary: System Settings->Application Style->Window Decorations
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-05-19 14:59 UTC by Mike Lewis
Modified: 2015-05-23 14:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Lewis 2015-05-19 14:59:37 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.16.0-37-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
Had just added a new decorations theme, now the damage is permanent.
Need a work-around... Pretty please.
Unfortunately, don't remember what I added, nor do I know how to remove them when it dies every time I try to go there.
Why are such "themes" available when they cause system management programs to crash?

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fd7fc589780 (LWP 18398))]

Thread 4 (Thread 0x7fd7ebb9f700 (LWP 18399)):
#0  0x00007fd7f8cfe8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fd7f7018b72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fd7f701a64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fd7ee0ea099 in QXcbEventReader::run (this=0xf17590) at qxcbconnection.cpp:1105
#4  0x00007fd7f937fb0e in QThreadPrivate::start (arg=0xf17590) at thread/qthread_unix.cpp:337
#5  0x00007fd7f5f326aa in start_thread (arg=0x7fd7ebb9f700) at pthread_create.c:333
#6  0x00007fd7f8d09eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7fd7db4d1700 (LWP 18404)):
#0  0x00007fd7f8cfe8dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fd7f5a13ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd7f5a13fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd7f9616c6c in QEventDispatcherGlib::processEvents (this=0x7fd7d40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fd7f95bb3e2 in QEventLoop::exec (this=this@entry=0x7fd7db4d0e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fd7f937ab44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fd7f8345f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fd7f937fb0e in QThreadPrivate::start (arg=0x1b56890) at thread/qthread_unix.cpp:337
#8  0x00007fd7f5f326aa in start_thread (arg=0x7fd7db4d1700) at pthread_create.c:333
#9  0x00007fd7f8d09eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7fd7d3d59700 (LWP 18405)):
#0  0x00007fd7f5a587a4 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fd7f5a13eb1 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd7f5a13fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd7f9616c6c in QEventDispatcherGlib::processEvents (this=0x7fd7cc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007fd7f95bb3e2 in QEventLoop::exec (this=this@entry=0x7fd7d3d58e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007fd7f937ab44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007fd7f8345f65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fd7f937fb0e in QThreadPrivate::start (arg=0x31f5a70) at thread/qthread_unix.cpp:337
#8  0x00007fd7f5f326aa in start_thread (arg=0x7fd7d3d59700) at pthread_create.c:333
#9  0x00007fd7f8d09eed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7fd7fc589780 (LWP 18398)):
[KCrash Handler]
#6  0x0000006500000065 in ?? ()
#7  0x00007fd7f7dca628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007fd7f7dc9d3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007fd7d9e9bc9a in Plasma::FrameSvgItem::updatePaintNode (this=0x44430d0, oldNode=0x4766ef0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007fd7f7e1d4bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007fd7f7e1e4cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007fd7f7e1ed80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007fd7f7dedf05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007fd7f7dee979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007fd7fa3a9b2c in QApplicationPrivate::notify_helper (this=0xeffb10, receiver=0x19f0550, e=0x7ffe4c7ee620) at kernel/qapplication.cpp:3720
#16 0x00007fd7fa3af000 in QApplication::notify (this=0x7ffe4c7ee990, receiver=0x19f0550, e=0x7ffe4c7ee620) at kernel/qapplication.cpp:3503
#17 0x00007fd7f95bdc2b in QCoreApplication::notifyInternal (this=0x7ffe4c7ee990, receiver=0x19f0550, event=event@entry=0x7ffe4c7ee620) at kernel/qcoreapplication.cpp:935
#18 0x00007fd7f9615ae5 in sendEvent (event=0x7ffe4c7ee620, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0xf4b290) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007fd7f9615f61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007fd7f5a13c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fd7f5a13f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fd7f5a13fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fd7f9616c6c in QEventDispatcherGlib::processEvents (this=0xf3f5f0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007fd7f95bb3e2 in QEventLoop::exec (this=this@entry=0x7ffe4c7ee870, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007fd7f95c302c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007fd7f9de431c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007fd7fa3a57a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-05-23 14:35:25 UTC

*** This bug has been marked as a duplicate of bug 345675 ***