Bug 351230 - Window Style error after instaling "seven" style
Summary: Window Style error after instaling "seven" style
Status: RESOLVED DUPLICATE of bug 345675
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-08-12 20:25 UTC by itfc
Modified: 2015-08-13 00:07 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description itfc 2015-08-12 20:25:39 UTC
Application: systemsettings5 (5.2.2)

Qt Version: 5.4.1
Operating System: Linux 3.19.0-25-generic x86_64
Distribution: Ubuntu 15.04

-- Information about the crash:
- What I was doing when the application crashed: 
I trying to change style from last using "seven" style window decoration, I can't choose any different style because aplication "settings" is crash. I can't even press "default" - because it's crash.
- Custom settings of the application:

The crash can be reproduced every time.

-- Backtrace:
Application: Ustawienia systemowe (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f5d2f6dd780 (LWP 1736))]

Thread 8 (Thread 0x7f5d1ed27700 (LWP 1737)):
#0  0x00007f5d2be438dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f5d2a15db72 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f5d2a15f64f in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f5d21272099 in QXcbEventReader::run (this=0x19d6550) at qxcbconnection.cpp:1105
#4  0x00007f5d2c4c4b0e in QThreadPrivate::start (arg=0x19d6550) at thread/qthread_unix.cpp:337
#5  0x00007f5d290776aa in start_thread (arg=0x7f5d1ed27700) at pthread_create.c:333
#6  0x00007f5d2be4eeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 7 (Thread 0x7f5d0f9e4700 (LWP 1738)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f5d129f9e83 in ?? () from /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
#2  0x00007f5d129f96e7 in ?? () from /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
#3  0x00007f5d290776aa in start_thread (arg=0x7f5d0f9e4700) at pthread_create.c:333
#4  0x00007f5d2be4eeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 6 (Thread 0x7f5d0f1e3700 (LWP 1739)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f5d129f9e83 in ?? () from /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
#2  0x00007f5d129f96e7 in ?? () from /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
#3  0x00007f5d290776aa in start_thread (arg=0x7f5d0f1e3700) at pthread_create.c:333
#4  0x00007f5d2be4eeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f5d0e9e2700 (LWP 1740)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f5d129f9e83 in ?? () from /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
#2  0x00007f5d129f96e7 in ?? () from /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
#3  0x00007f5d290776aa in start_thread (arg=0x7f5d0e9e2700) at pthread_create.c:333
#4  0x00007f5d2be4eeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f5d0e1e1700 (LWP 1741)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f5d129f9e83 in ?? () from /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
#2  0x00007f5d129f96e7 in ?? () from /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
#3  0x00007f5d290776aa in start_thread (arg=0x7f5d0e1e1700) at pthread_create.c:333
#4  0x00007f5d2be4eeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f5d0a315700 (LWP 1743)):
#0  0x00007f5d28b58d4d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f5d28b58fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5d2c75bc6c in QEventDispatcherGlib::processEvents (this=0x7f5d040008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#3  0x00007f5d2c7003e2 in QEventLoop::exec (this=this@entry=0x7f5d0a314e20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#4  0x00007f5d2c4bfb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#5  0x00007f5d2b48af65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#6  0x00007f5d2c4c4b0e in QThreadPrivate::start (arg=0x1cc0ab0) at thread/qthread_unix.cpp:337
#7  0x00007f5d290776aa in start_thread (arg=0x7f5d0a315700) at pthread_create.c:333
#8  0x00007f5d2be4eeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f5d02d9e700 (LWP 1744)):
#0  0x00007f5d2be438dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f5d28b58ebc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5d28b58fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5d2c75bc6c in QEventDispatcherGlib::processEvents (this=0x7f5cfc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#4  0x00007f5d2c7003e2 in QEventLoop::exec (this=this@entry=0x7f5d02d9de20, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f5d2c4bfb44 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:503
#6  0x00007f5d2b48af65 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f5d2c4c4b0e in QThreadPrivate::start (arg=0x208d6d0) at thread/qthread_unix.cpp:337
#8  0x00007f5d290776aa in start_thread (arg=0x7f5d02d9e700) at pthread_create.c:333
#9  0x00007f5d2be4eeed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f5d2f6dd780 (LWP 1736)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f5d2af0f628 in QSGOpaqueTextureMaterial::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#8  0x00007f5d2af0ed3c in QSGSimpleTextureNode::setTexture(QSGTexture*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#9  0x00007f5d08d0fc9a in Plasma::FrameSvgItem::updatePaintNode (this=0x3324070, oldNode=0x32b60f0) at ../../../../src/declarativeimports/core/framesvgitem.cpp:495
#10 0x00007f5d2af624bf in QQuickWindowPrivate::updateDirtyNode(QQuickItem*) () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#11 0x00007f5d2af634cb in QQuickWindowPrivate::updateDirtyNodes() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#12 0x00007f5d2af63d80 in QQuickWindowPrivate::syncSceneGraph() () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#13 0x00007f5d2af32f05 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#14 0x00007f5d2af33979 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5
#15 0x00007f5d2d4eeb2c in QApplicationPrivate::notify_helper (this=0x19bdb10, receiver=0x1d36970, e=0x7fffdd60f860) at kernel/qapplication.cpp:3720
#16 0x00007f5d2d4f4000 in QApplication::notify (this=0x7fffdd60fbd0, receiver=0x1d36970, e=0x7fffdd60f860) at kernel/qapplication.cpp:3503
#17 0x00007f5d2c702c2b in QCoreApplication::notifyInternal (this=0x7fffdd60fbd0, receiver=0x1d36970, event=event@entry=0x7fffdd60f860) at kernel/qcoreapplication.cpp:935
#18 0x00007f5d2c75aae5 in sendEvent (event=0x7fffdd60f860, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:228
#19 QTimerInfoList::activateTimers (this=0x1a0b940) at kernel/qtimerinfo_unix.cpp:635
#20 0x00007f5d2c75af61 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:177
#21 0x00007f5d28b58c3d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f5d28b58f20 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f5d28b58fcc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f5d2c75bc57 in QEventDispatcherGlib::processEvents (this=0x1a041e0, flags=...) at kernel/qeventdispatcher_glib.cpp:418
#25 0x00007f5d2c7003e2 in QEventLoop::exec (this=this@entry=0x7fffdd60fab0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#26 0x00007f5d2c70802c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1188
#27 0x00007f5d2cf2931c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1510
#28 0x00007f5d2d4ea7a5 in QApplication::exec () at kernel/qapplication.cpp:2956
#29 0x000000000040eebc in main (argc=1, argv=<optimized out>) at ../../app/main.cpp:54

Reported using DrKonqi
Comment 1 Christoph Feck 2015-08-13 00:07:06 UTC

*** This bug has been marked as a duplicate of bug 345675 ***